No road feel for Neo Smart Bike

Hey folks,

Looks like the road feel is not working for the Neo Smart Bike. I don’t get an option in settings to turn it on or off when connecting via Bluetooth not via Ant+.

Thanks.

Have you tried checking the settings in the Tacx Utility App.?

Have you come across any places in Zwift where there is road feel? There are not that many.

Where is the best place to double check the road feel in Zwift? I figured that it would trigger when going over the wooden planks

If you’ve gone over the planks and have no road feel, then you are probably right. But… The app includes the ability to turn particular road surfaces on, off, and/or a percentage of feel. I’m just trying to cover all bases for you to trouble shoot the problem.

If you went over the wood planks to or from the Desert Flats expansion you may not feel it. If you went over the wooden planks on Ocean Blvd you should feel it. I’d say the cobbles near the Italian Villas are the best test.

It works when I use the Tacx utility testing dashboard to swap between road types.

Does Zwift have it’s own setting or do you have to enable it via the Tacx utility app?

Zwift should recognize that you are using a Neo, and then an on/off toggle presented in the settings screen.

Same here, Zwift does not recognise my Tacx Neo Smart Bike, so not way to activate Road Feel. It does recognise my old Tacx Neo Smart Trainer so the issue must be with the Smart Bike!

Also for me- no road feel :frowning:
My first “neo” so was keen to experience this…

1 Like

Bei meiner neuen Neo T2 T Smart funktioniert das Straßengefühl bei Zwift auch nicht. Bei meiner alten Neo 2 funktioniterte es.
In der Tacx Software funktioniert das Straßengefühl.

I raised a ticket with Zwift regarding that the road feel does not show as an option via ant+ and after sending all the logs, they confirmed that it seems to be a bug for the new 2T.

They mentioned the bug existed also for the original Neo 2, but that it has been solved?

Here the answer to the missing Road Feel from Zwift support:

Hi Ralph,

Thanks for reaching out to Zwift support!

The new Tacx Neo Smart indoor bike will work with Zwift, but at this moment does not officially support​ the road feel setting that the regular Tacx Neo does. Our team is working on this but at the moment we don’t have any updates on when it will be implemented.

We also encourage you to share your thoughts and vote up support on our Community forums athttps://forums.zwift.com/​​.

The forums are a great place to get more community support for an idea and attention from the dev team. The more attention an idea gets, the more likely it’ll get implemented into Zwift. You may find many members have the same thoughts and ideas as you!

If you have any other questions, please let us know.

Ride On.

Eric W.
Member Experience Agent

1 Like

Same here with new bike: no road feel :disappointed_relieved:
Hopefully very soon fixed. It was one of the key factors for me to go smart and with Zwift…

With my bike finally arriving tomorrow, this comes as a bit of a disappointment, as Road Feel was one of the USPs that kept my order with Tacx rather than one of the other trainer bikes recently announced.

I’d imagine that the Road Feel communication is no different from one type of Neo (Neo, Neo 2, Neo 2T, Neo Bike) to another, e.g. Zwift sends signal to trainer saying “Cobbled section starts now”, trainer starts bumping - I can’t see why this would be any different between trainers (although how that signal is processed by the trainer itself may vary, but that’s ‘invisible’ to Zwift).

So, if that’s the case, it would suggest that all this is down to is Zwift not recognising that the bike supports Road Feel, which should just be a matter of adding the bike’s ID code to Zwift’s library of trainers that do, but I’m not sure how much inclination Zwift has to do this. It might just be a very quick bit of coding, but if it never gets on their ‘things to do’ list, it’s never going to happen. The fact that there’s already sections in the recent additions to Watopia where Zwift hasn’t bothered with Road Feel makes me wonder if they’ve lost interest in supporting it any more.

Let’s hope not!

4 Likes

Same here. No road feel on the Tacx Smart Bike.

Also my heart rate does not get transmitted to Zwift. I use a Ant+ Belt and it connects to the bike. When riding, my heart rate is shown on the monitor on the Tacx Neo Bike. But it does not get transmitted into Zwift. Any possibility to upgrade this?

Thanks, Samuel

Samuel: Are you running Zwift on a Windows 10 PC?

Hi Steve,

no, I am using an iMac for Management and iPad with Zwift App on it for Training on the Bike.

Samuel, you want a heart rate monitor that transmits both Bluetooth and ANT+. The iPad requires Bluetooth; it won’t receive ANT+.

Wahoo, Scosche, and 4iiii are among the brands offering dual band heart rate monitors. Garmin does too, in their latest HRM. Earlier Garmin HRMs are ANT+ only.

1 Like

Got the bike today and no option in Zwift to turn road feel on.
In Tacx utility app it works.
Please fix this😊

1 Like

Same here. Just bought my first ever trainer so I can immerse myself in Zwift. Went for the new Neo 2T over the Wahoo specifically for the road feel and I don’t get the option to turn it on. Strangely the option is there if I use my iPhone but not when using my PC which is what I’m setup for.