No road feel for Neo Smart Bike

Agreed, road feel is one of the key features with the tacx neo bike smart - please enable it on the zwift side.

The tacx neo bike smart has been advertised as having road feel on zwift, however it seems like this hasn’t been enabled on the zwift side. Can this please be enabled for this smart bike?

I’ve been looking forward to the Game Update: Oct 29, 2019 - but nope, no mentioning of NEO Bike Smart :face_with_raised_eyebrow:

Still won‘t work on my Neo2T - please fix this!

Recently purchased a Tacx Neo 2T as a perceived upgrade and to replace my 2016 Kickr. Road feel was a unique selling point. Very disappointing that Zwift has not enabled this feature. It works perfectly on a friends Neo 1. Have sent Zwift an email.

Road feel is fine on my 2T connected by Bluetooth. The issue is with Ant+

1 Like

Once I switched my Garmin heart rate chest strap to Garmin Dual (ANT + Bluetooth) the signal would transmit to Zwift.

It works both on my iPAD but I have since switched to Apple TV 4K. Works great.

Agree, I just took delivery of the Neo Smart Bike there on Thursday last, very disappointed that road feel is not available in Zwift out of the box. Please make this a priority.

1 Like

Oh yeah, please add Tacx Neo Bike Smart to the supported bikes. Tacx is advertising this - which brought me to Zwift in the beginning:

Just tried my Neo 2T today. Switched the road feel button on, on the utlity App and no road feel. Come on Zwift this is a feature many of us are really looking forward to! Otherwise the Neo is amazing. Have been riding a 15 year old Computrainer…what a difference!

I picked up my Neo 2 last weekend and initially the road feel worked. I logged back in mid-week and since then the road feel has failed to work Thanks to @Ralph_Sigg_PCR for sharing the Zwift response, at least I now know it’s not something I’ve messed up. Disappointing though.


I have the same problem. On my PC I can’t see the settings to turn on or off road feel then on my iPhone I put Zwift on and it works. I’m pretty disappointed that I can’t use my pc set up to get road feel. Shouldn’t this be a priority?

Same here. Set up new Tacx Neo 2T this morning, updated firmware, first ride no road feel. Glad to see it isn’t something wrong with my unit in particular but would like to see it fixed. I like most here was really looking forward to this feature and is a contributing factor to paying more for this trainer than others. Zwift, please help. Thank you.

Don’t have a smart bike, but the road feel was why I bought the Neo. The road feel is worth the wait !!

1 Like

Zwift what’s going on here? I bought a neo smart bike expecting road feel to work. When will this be implemented?

I’ve just tested a NEO 2T Smart trainer and I’m very disappointed that Zwift hasn’t corrected this issue with road feel not working on the 2T. I’m using an ANT+ dongle connected to a Windows 10 MS Surface laptop. With this combination Zwift does not show the option to enable road feel when connected to the 2T. We also have a NEO 2 (previous model to the 2T) here and I can confirm that the NEO 2 road feel currently works fine using the same connection method. Unfortunately I can’t easily switch to a Bluetooth connection since receiving the Windows 10 update (version 1903) that Zwift warned about some time ago. It seems a little fishy to me that the road feel feature is supported on the NEO 2, but isn’t supported on the 2T even after numerous Zwift updates since this issue was first reported. Road feel on the NEO is one of the reasons I use and recommend Zwift over other training apps. When people try the Zwift + NEO combination they are always impressed, but once they hit a section where road feel is enabled it often “seals the deal” for going with Zwift.

So another Zwift update and still no road feel for Neo Smart Bike… :frowning_face:

1 Like

Same here, i use a Neo Smart bike and Ant+

1 Like

I saw that too. Really annoying. Only way to get them to listen is to get enough owners but the bike probably doesn’t sell in big enough units. Really disappointing that one of our main features doesn’t work. Anyone know of alternatives to try?