Tacx Neo 2T - No road feel option via ANT+ but works via Bluetooth?

Hi all,

I reached out to the support but thought I’d post here also. I just got the Neo 2T delivered and just connected it and did my first ride to check that everything is OK. To my surprise the road feel option to enable or disable is missing when connecting to the FE-C device via ANT+. I’ve upgraded the FW on the Neo, rebooted the PC and everything without success.

If I however switch to Bluetooth via the Companion app (iOS), then the option of enabling it is there and it seems to work. Very weird.

Anyone have any ideas?

Thx!

Best regards,
Martin

Same problem here with neo 2

Road feel works in tacx utility app, but not in Zwift on my 2T.

Also the connection lights (BT and ANT+) don’t work in Zwift. But trainer works perfect.

The Zwift support confirmed that is seems to be a bug. However, what you can try is to remove the file knowndevices.xml in the Zwift folder and then to connect the controllable device first, not the power reading.

I’m having the same issue on my Neo 2T and no amount of deleting the knowndevices.xml or prefs.xml seems to fix it. The only way I can get road feel to work is via Companion App BT.

I’m due to take delivery of a 2T in a few days as a warranty replacement for my Neo 2 which in itself was a warranty replacement for the orginal Neo.

I guess given I’m an Ant+ connection I’m gonna be without road feel until Zwift release a fix. It’s not a massive issue for me. Any ideas as to when it’ll be fixed?

Yes - same thing - road feel only via BT and companion app
Ok once you know I guess but not obvious to find

Hi, same bug.

I have Notices that sometimes my HT is detected as “NEOT 2 + SN” and then it works. But if is only detetec as “FC-E + SN”, in this case it doesn’t works.

Has their been any response from anyone at Zwift about this yet?
Seems like it should be a very easy fix to enable same road feel for the 2T as Neo and Neo 2 already have it.

Ok, that explains things…
Just got a 2T and riding in Zwift over different surfaces felt just the same to me. So i though, oh well not that spectacular of a feature people are talking about.
Will definitely check it out on my tablet.

But that’s not the way I want to ride Zwift, I want the nice graphics +roadfeel +Ant+ hah!

So I kindly ask the Zwift team to address the issue asap

Thank you!

1 Like

I tried riding on my Mac with hooking up the TacX ant+ usb device. When everything is hooked up through ant+ I can’t see the option for road feel however, when I only connect through Bluetooth I get the option for road feel and it worked…

Maybe the problem is with ant+?

Finally installed the 2T today.

I can confirm that there is still no roadfeel on ant+

1 Like

Seems like the last update solved the problem for Tacx 2T!

Ooh, I did a race this morning all on road so I didn’t notice.

RIDE ON! Since the latest update (on about December 7) road feel is now working for me on the Tacx Neo 2T Smart trainer over ANT+.

Yep, confirm it’s fixed.

I’ve noticed however when coasting downhill I’m holding 7/8 watts. No cadence but reporting power.
I’m investigating

Hi everyone.
I confirm road feel works, but only during normal ride. I noticed strange situation when I started training ride road feel didn’t work. When I poused my training on companion app and ride along road feel works. At the moment I click play button road feel stops immediately. It reppeted over and over again clicking pouse and play button. And the same was with uphill and downhill simulation. During normal ride it was ok but in the training ride didn’t work.
Did someone can check on theirs neo 2t.

Do you thing it is worth to write to zwift support about this situation and is it possible it is a software problem or hardware.

Man ir taip pat 8w