Tacx Neo road feel is excessive [April 2022] [1.24] [SOLVED]

tacx road feel on a neo2 on tempus fugit is very bumpy instead of smooth now; had to turn road feel off

8 Likes

At the last interval tonight my neo felt like it was riding over rail tracks. This is not present when riding the trainer outside of Zwift.

5 Likes

Hey @Mike_Szymanski_KRT_C @O_ne_Eyed_Jack and @Paul_Cooper_SZR

Thanks for flagging this up. We’ve investigating what may have changed to cause this excessive road feel in v1.24.

For anyone else joining this thread, it would be helpful to know:

  1. What OS platform you use to run Zwift
  2. What model Tacx you own.
  3. What version firmware is installed on your Tacx, and if it’s the most recent version. We’re not asking you to update the firmware necessarily, we’re just trying to identify common threads. Garmin’s Youtube channel has a how-to video.
3 Likes

Same Problem here

Mac OS
Tacx Neo 2T
0.0.38

1 Like

Neo 2T

Windows 10

0.0.38

Hope this gets fixed soon as it was unrideable.

2 Likes

Update: we’re making good progress on triage. Don’t have an ETA for a patch that will fix this, but it’s looking like we will soon.

In the meantime: please disable Road Feel in the game’s setting menu. You may need to exit the game and log in again for it to take effect.

4 Likes

Tacx neo 2t

Mac

0.0.38

Bumpy as h*** here

2 Likes

Windows 11 - fully up to date

Tacx Neo 1 - Firmware 0.2.1 / 0.7.4 / 0.8.4

Thanks @shooj

1 Like

Ok after the new update I have a massive problem, I mean, I have Tacx neo 2t and in every single pedalling I do it’s like I’m kicking a rock, the feeling its like I was going through stairs or something like that.

No idea why it’s impossible to use it

3 Likes

See here: Tacx Neo road feel is excessive [April 2022] [1.24]

Same issue on my Neo 1. horrible jolting every other pedal stroke. There is clearly an issue caused by the latest 13-4-2022 game update which is affecting all Tacx Neo trainers. Sort it out Zwift !!

3 Likes

The 13-4-2022 game update is causing intermittent jolting every other pedal stroke on Tacx Neo trainers. Help !!

2 Likes

same here-

2 Likes

Hope this is fixed soon, I like the road feel feature on my Neo and aside from races on Paris (and the recent ToW stage), I never disable it.

1 Like

I just tried it again- even if I turn road feel down to 0, it still feels like I’m biking over logs.

2 Likes

Hi @Jennifer_Baker_REVO
Question - did you exit the game and log in fresh? For some settings changes to take effect, you need to restart Zwift. Would you let me know?

yes- I exited the game three times- tried different routes each time. Also exited and restarted my laptop and turned difficulty down. Same issue-

just reread your question- I turned road feel down while in game- I will try now by turning road feel down prior to starting zwift and see if that works.

ok- just setting road feel to 0 prior to launching Zwift. I still felt the bumps-