Tacx Flux 2 issues

Hi,

Possibly, you might want to take note of Tacx Flux 2 issues (an entry in the “Known issues” section abut this is missing…): power output spikes at zero cadence, inaccurate cadence and resistance control stopping after stopping pedaling.

Tacx got back to me saying a FW fix is in the works. However, until such time as the fix materializes, this is an issue to be aware of (this is a Tacx Flux 2 issue - completely unrelated to Zwift; it appears in their own app as well…)

Thanks.

Hi,

Thanks for the heads up on this issue! Hopefully this is something where Tacx can resolve it soon :slight_smile:

1 Like

Thank you for the update , i have the same problem , did they mention when this FW fix going to be released ? Any estimation?

4 weeks… (But I wouldn’t be surprised if it took more …)

Hi, Is this the problem where you stop pedaling and then the watt spikes to 2000? If so, I have it too on my Flux 2. So they are aware of the issue and a fix should be available soon? That would be great :slight_smile:

Yes… That’s it.

Never stop pedaling…

Does it happen every time when you work out ?

I did a short workout today (± 30 minutes). Was winding down (low rpm and watts during a few minutes) and when I then stopped completely, it happened. As I found it strange, I did another ± 15 min workout afterwards to see if it would happen again, but that time it didn’t. However, I didn’t let my rpm go as low before stopping completely. Now I don’t know if it’s due to not doing the few minutes of low rpm before stopping, or the shorter duration of the workout… Did you notice a similar pattern?

As far as i recall, the spike occurred immediately after cadence dropped to zero following some effort. I haven’t research it much… 2kw is inhuman.

Hopefully, Tacx will have a solution soon. In the meanwhile, never stop pedaling…

Is it possible to undo the Zwift challenges I’ve unlocked as a consequence of this fault ??

Cheers

No as far as I am aware of.

According to Zwift the 2000 watt spikes were a tacx flux 2 firmware issue. But my last 3 rides were without the spikes, the Tacx Flux 2 still running FW 1.09 and i think (which means i’m not sure) after a update from Zwift. Happy that the spikes are gone. Don 't mind where it went wrong anyhow.

Ever since I learnt what not to do (stop pedaling…), I havn’t seen the 2KW. Granted, Zwift can address the issue (not “fix”), by removing excessive wattage (don’t know if they do).

Still waiting for the new F/W…

I’ve just got a flux 2 and there is a spanner coming up on my page where the cadence is and keeps asking me to Pedal up to 37kph and then stop each week to keep my cadence up to date but keeps saying failed, is anyone else having this problem.

Hi Mark,

The spanner is Zwifts calibration option. It doesn’t work with the Flux 2 at the moment. You can ignore it and use the Tacx app to calibrate your Flux 2. There’s another thread about this here

Well, the new F/W is has finally arrived… (actually, a couple of weeks ago.) No more 2KW… :frowning_face:

Note, however, that whenever the flywheel is spinning faster than the pedals, power output drops to 0. To me, this is the result of the Flux2 only estimating the power, and once there is no tension between the pedals and the flywheel, the device - unable to estimate - still needs to output some value - hence the “0”.

That sound about right, if the flywheel rotate faster then you are no producing any power thus it should read Zero. even if it had strain gauges and measured torque it would read Zero.

Hi, i still have same problem with 2KW peak on classic(not ergo) mod. What number of yor firmware?

i don’t belive it’s only the firmware.
A friend of mine bought its Flux 2 a week ago and struggles with that peaks. I bought my Flux 2 two weeks ago and i never had that issue while cycling for 9h and 250km.
I have a 51xxx serial number, she has a 58xxx serial number.
Both we have the firmware 1.1.2 and com-firmware 3.3.40 so i don’t think it’s software related

what is a difference in the setup is that i use the sigma Duo cadence sensor. Maybe that is the point why it works for me