Training sessions wattage and resistance going bezerk

I have a tacx flux 2 and it’s been weeks I haven’t been able to have a training session where the resistance and power are stable.
I never had this issue before, it started since my first training of 2024.
I tried reinstalling the app, i tried reconnecting the trainer, I tried recalibrating it, nothing worked
Furthermore it happens that at some point cadence and power gets stucked and resets once the trainer stops.
What is happening?

Hi @lg_grandi

Welcome to the Zwift Community Forums.

I took a look at the server side reporting for your account, and between what I and your description it seems like your trainer is swapping connections to something else. Do you have your trainer connected anywhere else? Something like a head unit or another program can cause issues like this. even if the trainer is connected directly to another device, it can cause these sorts of issues.

It’s also worth giving our wireless interference support article a once over to see if any of the things listed there seem like they might be causing an issue.

If none of that seems to apply, my best recommendation at this point is to send an email to our technical support staff at

this seems to be working up to a degree, thank you!