Incorrect Power and cadence


Having major issues with training at the moment. I have a Tacx Vortex smart trainer, about 2 years old. Never had an issue.

This week I’ve been training and noticed the Cadence has been inaccurate and dropping to below 40rpm, and at other times speeding up to +160rpm. This is whilst peddling a consistent 90rpm. I tried pairing up with my third party cadence sensor and got the same results.

It initially felt like the power reading was accurate but today it was way below what I was peddling. In addition, when I sped up my cadence and pushed harder, the turbo decreased resistance and I end up spinning without putting any power down.

I’ve updated the Tacx firmware, updated Zwift, and played around with the difficulty settings all to no avail.

My next course of action is to delete Zwift and its files entirely and start again, unless anyone has a better idea?


this is probably a silly suggestion, but have you tried powering everything down completely (maybe even unplugging) and waiting a few mins?

sometimes a hard reset clears out these kinds of gremlins.

also, make sure nothing else is trying to pair with the trainer (like your phone).

Yeah, powered everything down with no luck. I’ll try turning all other BT devices off and see if that helps…

Thanks for the suggestion

Hey @James_Wilkinson_WLFE,

Any luck or fixes on this? I’ve come across the same problem. I have a firm idea of what I’m giving in regards to my rpm, but it feels like the Zwift app has a mind of its own and will change this reading often and on its own.


George, I’m afraid I didn’t get a fix for this… I’m assuming it’s a sensor failure, I have the same issues when linking to sufferfest and Tacx…

James Wilkinson