Tacx Flux 2 and 2000W peak at the end of session

Hi,

I recently upgraded my Tacx Bushido to a Tacx Flux 2.
Since then I often experience a 2000W peak at the end of a session.
Contacted Tacx support and they replaced my device but that didn’t work; still 2000W peak every now and then.
Now Tacx support is telling me this is an Zwift issue.
Anyone experiencing the same and/or has more info on how this could be solved?
Looking forward to your replies.
Thanks!

Greetings,
Johan Barelds

I once had a 2000W spike on my Tacx Vortex. I’ve only ever known it to happen once. Happened when I was a bit late to start an event, and sprinted to catch up. Zwift seemed to think I peaked at 2000W, but it didn’t show up in my Strava upload.

I have exactly the same problems when using ZWIFT and my Flux 2, which Computer/ Platform are you using? (In my case its IOS with an iPad)

Edit: this was the reply I got from ZWIFT support in April 2019, however these things didn’t help in my case (already had the latest firmware, recalibrated the trainer, placed the iPad next to the trainer for testing purposes):
I’m sorry to hear you’re having issues with your trainer. I’d like you to try updating the firmware on your trainer to see if this resolves the issue.

Instructions for updating your trainer’s firmware should be available on your manufacturer’s website, and we list information for some brands on our knowledge base​.

After updating your firmware it’s a good idea to calibrate your trainer as well. Calibration for some trainers can be done in Zwift. Instructions on our knowledge base​ article “How to calibrate your trainer​​,” and most manufacturers provide a mobile app that you can use to do this as well.

This could possibly also be caused by a Bluetooth signal drop. We’ve written a guide describing common potential interference sources​, in the article “My Bluetooth signal is Dropping​​,” so you can try and eliminate them.

Give that a try, and let me know how it goes.

Hi Bernhard,

I am using a PC with ANT+ dongle attached via an extended USB cable.
Go the same info you shared from Tacx support and Zwift support.
Since I already upgraded the firmware and calibrated the devices this won’t solve anything.
Also when I got a new replacement device from Tacx this didn’t work.

I also tried all recommendations concerning possible interference of other electric devices which might cause ANT+ connection spikes.

My guess is that it is a trainer hardware issue although Tacx support is blaming the Zwift software for it. So I contacted the vendor which sold me the trainer and asked them if I could swap the Flux 2 for a Wahoo Core trainer.

I am fed up as a customer being men in the middle between Tacx and Zwift support.
So let’s get rid of the current Tacx trainer and get another brand/type one for which no issues are being reported currently.

Gr. Johan

Hi Johann,

ok interesting, so this seems to happen with IOS/BLE and PC/ANT+ (couldnt be more different I guess).

Would be interesting to get a log file of our trainings analyzed by the ZWIFT developers to see why the peak in wattage happens.

@ ZWIFT Support: Is there a possibility to do this?

Best regards,
Bernhard

FYI: there is an workaround to get rid of the spikes in your .fit files. I upload my .fit file that contains the spike to https://www.fitfiletools.com and use the Peak Remover to remove the spike. Just select “power” and “Remove values above” 1500.
Save the updated file and import it into Strava or other tools you are using.

Gr Johan

Hi Bernhard,

Other question: how do you have your Flux 2 paired with Zwift?
I noticed that there are several pairing options for “Cadence”. Flux allows to choose for “Cadence/Speed” but also “Cadence” only. How do you have yours configured?

Gr Johan B

This is identical to what I see. Yesterday, riding downhill from ADZ, I was experimenting with supertuck (which worked). Upon reviewing my Zwift logs on Strava, there were a couple of 2000W surges around the time.

Flux 2 also seems to lose cadence/speed tracking if I stop pedaling (this is essentially the second unit I use. My Flux 2 internals were completely replaced due to noise. The previous one behaved similarly)

This is not a Zwift issue. I’ve been logging this ride with my FR935, independent of Zwift. Sure enough, the same 2000W spikes appear there as well. I will soon be contacting Tacx support, and will update here as appropriate.

Ride on!

Update: Moved from ANT+ to BT; made sure no nearby 2.4GHz WiFi source was active. End of ride: 0 cadence, 2000W.

Still unable to repo unless Zwift is present…

Update 2: Another ride, this time using Tacx training app only (also tracked by ANT+ watch.) Two abnormal high-power occurrences: one 850W BT reported (accompanied by cadence spike), another 1788W (with 0 cadence) ANT+ reported on another location/ride.

Based on the above, I would say this is not a Zwift issue.

Update 3: Another day. Another ride. Tacx app only. Again, high power spikes on both ANT+ and BT.

Another Flux 2 power spiker here. Noticed it when I was experimenting with the tuck as well. However had cadence issues on the climb up too where it was recording a cadence of only 30-40 when it should have been more like 80+. Then on the downhill I stopped pedalling on 2 separate occasions and had the power spike issue. Wasn’t pushing hard before freewheeling just an easy cadence before the tuck. My power on my Flux 2 also reads at least 20w-40w less than my vector 2s pedals but I’ve just put that down to power meter variance.

Just to update you. After being unsuccesful in solving the spike issue with Tacx support and Zwift support, I contacted the online shop where I bought the Flux 2. They where very helpfull in replacing the Tacx Flux 2 for the Wahoo Kickr Core trainer. No issues anymore since. I suggest every one to try to do they same. The Tacx Flux 2 is a trainer with serious issues if used in combination with Zwift.
Good luck all in solving your issues.

Greetings,
Johan

Hi,

I just bought a new Flux 2 and I also have that spike problem at the end of my workouts, 2000W when I stop pedalling and it is winding down…