Steering device (Sterzo) takes me off course [August 2023]

I’ve been using Sterzo elite for about a month now - windows platform with companion on android, all good until a week ago- with Sterzo enabled takes me off the course of the pacer group I joined at the start of my ride and will not allow me to correct. I’ve given up and no longer using steering, so even though I cannot turn on purpose with Sterzo- it does it on it’s own

Hi @M_Michaels

Sorry to hear that you’re having this issue. If you haven’t tried this already, it could be that it needs calibration. Check out this article that we have, particularly towards the bottom where it discusses the calibration process and try those steps to see if it improves your situation. Another thing is making sure that the batteries are still good, and may not hurt to pair it up to the Elite Upgrado app and make sure no firmware updates are needed.

If those things don’t help, reach out to our support team and we can start taking a deeper look into this issue.

The fix you recommended very slightly improved steering predictability but did absolutely nothing for the going off course problem. I tried going to the forums there is no answer there and there is nobody else that I can contact to solve this problem.

Message generated on my mobile device

Hi @M_Michaels
I don’t know whether we have the same issue, but I’ve been highlighting the same experience for some time now. The problem I realised is that during RP rides, I am totally focused on using the Sterzo to maximise draft position, without realising that it can flip to route options at intersections (that I ignore because I’m focused on my position and just assume Zwift will make me track the RP). See my posts below:

So actually, I have been “choosing” to steer away from the RP without realising, and I’ve been thinking it’s a connection, software issue etc.
Having paid more attention for the last couple of rides, I have seen the wrong route option selected (I think because I was steering for the draft position), then quickly reselected to stay with the RP.
I’m still not happy with this issue because occasionally I’ve needed to steer for the draft, but this has inadvertently forced me off the route when the left/right markers pop up, and I haven’t switched directions with the handlebars quickly enough.
I’d be interested if you try a RP ride and watch carefully how you’re steering when the route options come up.

Thanks that is a possibility, I’ll look for it. Steering is still in beta it seems, but it definitely makes the whole experience more immersive.

Message generated on my mobile device

Weighing in on Sterzo and routing. I definitely feel that this is worthy of a feature request. Been riding with Sterzo for some time. Have done calibrations. Like other Sterzo users, I initially found myself routed off-course several times before realizing that it was Sterzo input that was selecting a different path. Since then I’ve been super careful at intersections, but STILL occasionally go off-course. This usually happens at intersections preceded by S-curves or complex intersections (Scotland). Undoubtedly, I’m either drafting or trying to ride the inside of corners and it’s tripping an off-course selection. Some feature ideas to address this:

Have a “stay on route” check box, defaulting to yes, when selecting a route. (It’s exceptionally rare that I select a route and decide to diverge anyway).
Highlight the default direction for the chosen route at each intersection.
Require a more explicit input for choosing a different path from the current route (a double-tap for example).
Provide a means to get back on-route.
Yesterday I rode Sugar Cookie for the first time. Even being super diligent about intersections I was still sent off-route at 17.2 miles. And once the rider is off-route, you’re screwed. You can do a U-turn but there’s no indication of which turns to make and route stats/credit are lost. I enjoy the steering functionality overall, but the behavior at intersections while riding a route is not an acceptable user experience.


In the last 4-6 weeks I’ve been misrouted and I’m curious if anyone else is seeing this. I start out by selecting a route in Watopia, Makuri, Scotland, etc. Zwift keeps me on route, tracks miles, etc. as planned for a while and then suddenly introduces a wrong turn at an intersection. Route tracking stops.

It’s happened approximately once a week. On Sand & Sequoias it sent me to Repack Ridge. It’s happened 4-5 times on Muckle in Scotland. On Sleepless in Makuri. Hugely frustrating as I’m usually riding with a friend (not a Zwift planned/scheduled friend ride).

Win11 desktop and Android companion. In all cases I haven’t touched companion app (and not sweating on it, etc.).

I searched and have found very few hits on misrouting. Considering deleting all Zwift associated files and re-installing, but welcome other ideas. Weird behavior. I rode for a year and a half and never saw this happen until recently.


Have you seen this?

Interesting! No, I searched on misrouting but either missed this or it didn’t come up. Thank you, I’ll do some experimenting with my Steerzo, change batteries, recalibrate, etc.

If this is the root-cause, I would prefer to have a more explicit confirmation. Or disable route changes at the start of the ride.

I have the same issue and am almost certain the routing errors are steering related. It would be useful to have the option to turn off steering-based route changes.

I’ve determined that misrouting is happening when the turn decision is preceded by a corner. The rider leans into the inside of the turn with Sterzo and Zwift perceives that as a routing change. This explains why it happens so frequently in Muckle where there are roundies and/or complex intersections preceded by twisty roads. Obviously, maneuvering, such as passing a rider or trying to catch a draft, right before a turn decision can cause misrouting as well. Unfortunately I’ve simply disabled Sterzo as a result

You might be interested in this feature proposal

I am experiencing similar issues. Specifically, I choose a route (for example, the long route in Scotland, or the North-South Islands route in Makuri) and ride along start to finish. What happens is that partway through the route, not entirely predictably, the app pops up the turn options, with the correct turn highlighted. I do nothing, just keep riding, with the intention of following the route. However, in some cases, it fails to make its own turn, then loses the route on the top display, and I am riding on my own, no longer on any route. In one case in Brittany the right-hand turn that goes via the Balloon Field was the intended turn, but it insisted on going straight, and losing its routing. At the top when reaching the branch point for back to town or to Mt Ventoux, it refused to allow me to doing anything other than head towards Mt Ventoux; nothing I could do in terms of U-turns or clicking on the turn would cause it to permit me to continue as intended back to town.

I noticed these posts on the Forum, and am heartened to see that others have similar experiences. It does not always happen, and so far I have not been able to sense that the deviation is due to my steering, but perhaps there is some connection, I do not know. The Zwift responders to my complaint deny any knowledge of such behavior, yet here it is described on their own Forum! I hope to work with them and others to get this problem fixed; it is a serious bug.

Hello all,

While it’s intended for Zwifters to be able to make intersection selections by Steering with the Sterzo or JetBlack Steering Block, there has been an increase of reports of unintentional turns at intersections with a steering device connected. This is being tracked to be improved in a future release.

In the meantime, you may want to double check that your steering device is calibrated before your activity by selecting the wrench/spanner calibration icon next to your steering device on the pairing screen. Any steering done outside of an intersection (when the turn options are not onscreen) should not affect your turn, but you may inadvertently choose a new route if you continue steering while in an intersection.

If you notice this happens without your steering device paired, please reach out to us in Support!


Improvements would be nice but why not just trust the user when they signal their intent to never make a turn ever under any circumstances? That’s the route lock feature request. You can trust the user to tell you when they want to avoid all turns.

1 Like

Same problem here. Today got re-routed 3 times off volcano circuit. It is very frustrating. Is this caused by the steering device? I’m on a sterzo.

The issue is that the system locks you into the turn option before you get to the intersection. The options come up well before the intersection and shows your choices. It initially defaults to the option that keeps you on course but if you are coming in or out of a turn at the time the choice switches to where ever you are turning sometimes before you can see what the original default option (to stay on course) was. When you’re riding a course like Neokyo with several 3 option turns it is almost impossible to stay on the course using steering.
Anyway, I’m glad it is being tracked to fix in the future. A minimal fix would be to have a notification of some sort over the option that keeps you on course. This would allow the rider choice as it is now but would give us the information to stay on course if we want.

I steer off course several times when using the Sterzo. If you are using the steering to stay in a draft when the route options pop up, it’s easy to go off route without realising before it’s too late. Actually on the occasions when I’ve been quick enough to spot that I’ve selected to steer away from the course, the correct option is highlighted specifically as the Robopacer route so that you can select it and keep on track. However, this all happens to fast and even in those cases I usually fail to correct my choice before the intersection. And then there are numerous times when I’m focused on the positioning, so I don’t even spot that I’ve “chosen” to turn off course until I suddenly find myself away from the crowd. Before teleporting, this was a much bigger issue for me, but even now still irritating.
So this does need an alternative solution, like a “route lock” option at the start, or something else that makes it easier to follow the RP without too much fuss.

I recalibrate before every ride. The lock feature request is a no-brainer and probably easier to code than figuring out how to handle sensitivity of various steerers.


Hello folks,

With the release of Zwift version 1.58.0, you’ll now have the ability to toggle whether your steering device can select intersection turns. Please note that this feature is enabled by default, so you won’t notice a change in behavior unless you manually toggle it off.