Rider does not move in game [macOS]


i am a paying member. My rider is not moving in the game. My Kickr `Core is connecting to Zwift (Both Kickr and the cadence) but the rider is not moving. I am using IoS. I updated my Kickr Core to the latest version on Wahoo and I updated Zwift to the latest version. Please help.


Do you mind sending a screenshot of your pairing screen once you have everything paired? Also, when you are in the game and riding, in the top left corner, does it display your power output?

1 Like

Hi Ooi er.

Thanks for getting back to me. I will do so in the morning if that is fine.

Much appreciated.

Kind regards

Shaan Watkins

1 Like

Looking through the forums, I found this thread: Wahoo Kickr Core Not Reading Power - #43 by Duncs_Firth. Looks like lots of riders had this issue, and many ended up having to get a replacement. That thread might be worth a look.

Hi @Shaan_Watkins,

Welcome to the Zwift forum community!

It’s always a good thing to make sure that the Kickr and Zwift app are up to date. One thing to make sure to check is that your Kickr is not paired to any other device or app as this can cause this issue to happen.

Once you’ve made sure it’s not paired to any other device or app, check out our support article on pairing your devices. You can also check out the thread that was mentioned above.

Another thing that can cause this to happen is signal interference. Check out our signal interference support article that has some things to consider in your setup that can cause things like this to happen.

If those things don’t help, we suggest reaching out to us. You can contact Zwift here.

Hope this helps, but let us know how it goes.

1 Like

Hi @Shaan_Watkins

Shuji at Zwift HQ here. I looked at your server logs from my end, and noticed that you have the Zwift game app running on both an iPad and a MacbookPro, is that correct?

It looks like you have both of those devices logged in to your account at the same time. Your avatar may not be moving on device #2 because your session is still open on device #1. Please exit Zwift on both of those devices, wait two minutes to let the server clear your session, then log in from whichever of those is your preferred Zwifting device.

On iOS - swiping an app into the background is not the same as force-closing the app. Please make sure you’re following Apple’s guidelines for that, and better yet - if your preference is to Zwift on the laptop - uninstall the Zwfit game app from your iPad entirely.

Would you try that and report back if that gets your avatar moving again?

1 Like


I uninstalled Zwift on my iPad but it is still not working. I had no problems before.

Kind regards

Shaan Watkins

When you installed Zwift and it asked for location access did you say yes. This is a new bluetooth requirement.

As of today (June 27) I’m seeing you logged in at the same time on a MacBook10,1 and an iPhone13,4. I’m guessing you’re testing across multiple devices, but this is counterproductive.

Please uninstall the Zwift app from your iPhone and iPad, wait 2 minutes for the server to clear your sessions, and try using the laptop exclusively to log in to Zwift.

Please also reset your Mac’s Bluetooth module to make sure that you’re paired correctly to the trainer. Instructions are here.

1 Like


I am only logged on, on my Macbook and I have deleted the app on all my other devices.

Kind regards


I might be completely wrong, but as far as I know your KICKR Core shouldn’t be paired in your laptop’s Bluetooth devices list (as is visible in the top photo) but only in Zwift.
Try ‘forgetting’ the trainer in your bluetooth devices list.


Thanks for the suggestion.

It did not solve the problem. At this stage I have a beautiful white elephant called a Wahoo Kickr I can’t use. :-(. It worked for two years and now stopped working.

Try using the companion app to bridge the signal over wifi, in other words, use the companion app to pair the trainer and see if that works.

On joining a ride my rider is not moving. I have done the following

  1. Signed out on all apps
  2. Did a new installation on my iPhone
  3. Replaced the battery on the Wahoo cadence sensor
  4. Opened the Zwift app on my phone. Kickr Core and cadence sensor connected via bluetooth to the app
  5. Did a spindown successfully to calibrate the Kickr Core via my iphone in the Zwift app
  6. Started a ride and the rider does not want to move

Please assist me in resolving this issue.



when you installed Zwift did you agree to allow the use of your location, that is required .

check that the trainer is not paired to the phone only pair in the app.

Hi Gerrie,

Thank you for coming back to me.

i was not asked to choose the allow the use of your location” option. Where can i access this?

The trainer is only paired to the app and not my phone.


I don’t use Apple products so I can’t help with that.

But it should be under permissions on your phone.

If the sensors connected and you managed to do a spin down then your permissions should be fine.

when you try and ride and nothing moves try opening the paring screen again to see if they’re still connected correctly.

in the paring screen if you pedal does the cadence and power show values?

Hi @Shaan_Watkins, seems like you started a thread about this a few days ago. It would be helpful to keep using the same thread rather than starting a new one and getting all the same suggestions over and over again.

Question, why are you using a cadence sensor with the Kickr Core, it should have built in cadence without the need for an additional sensor. I would get rid of the cadence sensor as it might be interfering?

Thanks Mike. :sunglasses:

I merged the two threads.

1 Like