Rider does not move in game [macOS]

Thanks for merging. I will attempt
Zwift companion again. My sensors are connected but not responding.


Kind regards

Shaan Watkins

if you pedal while on that screen do the values for watts and cadence change from zero?

Hi @Shaan_Watkins

Try this on your Phone: Updating Your Permissions on AppleTV

Hi Chris
Thanks for responding.

No they don’t.

Kind regards

Shaan Watkins

I think that is only needed for Android - on iOS bluetooth has its own setting (i think, i don’t use apple products so could be wrong)

Do you have anything else that might be able to record data like a bike computer or anything? try connecting the trainer’s power to that via Ant+ to see if the trainer is transmitting power

Hi Chris

I suspect my cadence sensor is faulty. I installed the wahoo fitness app. The trainer is transmitting speed but my cadence sensor (rpm) is working intermittently.

I can see Bluetooth light flashing and then it goes off for a while before it starts flashing again.

Kind regards

Shaan Watkins

might be a trainer issue in that case, update to the latest firmware if you haven’t already and see if that helps.

Hi Chris

I did that as well. :smile:

Kind regards

Shaan Watkins

After spindown on your phone, ensure that you are completely disconnected from the Kickr App. Hard close the app, etc…

I am going through the same. I have tried everything and since the latest update I can no longer race or see other riders on Zwift. It seems to be a problem with the latest update but it from what I have been reading, Zwift is trying to place the blame on internet connexion instead. I have internet connection but Zwift wont connect. Super disappointed

A lot of people with Internet problems it seems. I have a Kickr Core which is useless which I can’t use.

I wonder if I take out a new subscription and cancel my current one if it will work.

I know I will lose my stats but at least I will be able to ride again.

Kind regards

Shaan Watkins

You won‘t lose your stats when cancelling your subscription!

I actually did this too and nothing changed.


I just wish that someone will contact me or spend time with me to solve this problem.

I am connected from the app to my Kickr core. My devices are connected. I can do callibration but the cyclist Do not want to move. I am only signed in from one device.

If I use the wahoo app the app works and I can record what is going on.

It can also not be internet as I have a 100mbp/s line.

Kind regards

Shaan Watkins

Hi @Shaan_Watkins, You’ve gotten lots of good suggestions, let’s see if I can summarize your setup and try to help you troubleshoot the issue.

  1. you are using your macbook only, correct? The ipad and iphone are not being used for the game app and it was force closed or uninstalled. You can however use the ipad or iphone for the companion app (this is different from the game app, not the same, don’t open the game app on different devices at the same time).

  2. connecting with bluetooth and letting the game find the trainer, do not connect the trainer to the macbooks built-in bluetooth, if it is connected “forget” the trainer.

  3. using the Wahoo app, you can connect and do a spin down calibration. Do not use Zwift to perform calibration, just use the Wahoo app. Once that is completed, force close the wahoo app.

  4. All other potential signal interference has been disabled or turned off such as fans, microwaves, other bluetooth sensors, etc. You don’t need the additional cadence sensor, make sure that is disabled.

  5. internet connection is strong, are you using wifi?

  6. Zwift was given location permissions as per Gerry’s post above.

  7. Using the companion app to bridge the signal doesn’t work either? For this to work you need to click on the small gear icon on the pairing screen in the top right side of the “paired devices” box. Choose the “use companion” option rather than “built in bluetooth”.

If all that is correct, you’ve tried all the suggested solutions and it still isn’t working, then the next suggestion I have is to purchase an inexpensive ANT+ dongle and a USB extension cable, there are bundles on Amazon for around $20 last I checked. ANT+ might be your best option if bluetooth will no longer connect.

1 Like

Hi Mike.

Please see my answers in the mail below. Ip also provide you with some pics.

  1. ANT+ and Companion on devices paired

  1. ANT+ and Bluetooth on

  1. Bluetooth on

  1. ANT+ on

  1. Bridging with Companion

You can see the signal on the left top corner. In all these instances the rider does nothing.



Hi @Shaan_Watkins

Shuji at Zwift HQ again. I’m looking through your server logs and see that your Macbook10,1 is on version OSX 12.0 of the operating system. Apple’s latest version is OSX 12.5.

Weird things can happen when the OS is out of date. Would you update that so we can eliminate that as a cause of your issues?

VERY IMPORTANT: when you update macOS, Apple resets the app permissions to the default (restrictive) security settings which prevents apps from using the Bluetooth radio hardware. Please follow these instructions on our Support Hub after you’ve updated macOS.

Side note: I know you’re frustrated, but I’m seeing logins from both your iOS and macOS devices again. We’ve talked about this upstream. Please pick one device as your primary Zwift computer and uninstall Zwift from your others to eliminate concurrently logged in devices as the cause of this issue.


Hi Shiji

I used my IPad but after Mikes recommendation I used my MacBook. Do you see the log entries for today.

Kind regards

Shaan Watkins

In recent days, I’m seeing logins from iOS and macOS devices, and concurrent logins will definitely cause the avatar not moving issue.

Please choose one as your Zwifting computer. Uninstall the app from the others, update the operating system, etc and let’s get your avatar moving like it should.