Wahoo Kickr Core Not Reading Power

Add me to the list as having the exact same issue. I was able to setup, pair, and use my KICKR Core for exactly one ride yesterday. Today was a different story as all the apps and devices connect just fine, but none of them register power/speed. I’ve submitted a ticket.

I would agree that it definitely sounds like there is a hardware issue that hasn’t been resolved just yet. I’m thinking of paying the extra $300 for the 2018 Edition. I’d rather keep my cash, but value dependability.

Add me to this list - opened my new Kickr Core on xmas, rode for 4 days straight, then today, zero power or watt output. I’ve tried resetting everything, deleting every app and re-downloading - the trainer is connected to all devices, just doesn’t output any info. Seems like this is not a new issue - so disappointed!

Well, Wahoo was great and sent me a Kickr 18… an upgrade at no cost to me… It worked great from December 19th until today when it failed after about a mile on Zwift. Same symptoms as the two Kickr Cores before this one… worked for a while, then no speed or power indications. It pairs by both bluetooth and by ANT+, but there’s just no speed or power. Did all the debugging, powering off and on, rebooting, checking software updates, etc… no dice. Bother. 'Just submitted another ticket and we’ll see what happens.

My kicker core worked great for about 2 hours of riding then no power or speed via any protocol. I was hesitant buying the core because of all the bad press but did really like it while it worked. I will exchange it at my lbs and hope the 2nd one works. I have had kicker 2016 and 2017 and they were rock solid. Do not know what they did different in 2018 but they best get a handle on it if they want to stay in business.

Same issue here – no power or speed xmit to zwift or the Wahoo app on my iPhone. My first ride was this past Sunday (30-Dec) and Zwift and the Core worked perfect. I went to join a group ride tonight and had no pwr or speed. I did several reboots on Kickr Core, Wahoo iPhone app, Zwift on the PC and even the Windows PC running Zwift and my problem persists. I am not even able to a spindown test from Wahoo iPhone app as the speed never registers.

I’m now on my second Kickr Core which has done this. I received a replacement last week, conducted the spindown and today when joining the Tour de Zwift I was in the 51/11 and spinning like a demon. I disconnected and found that exactly the same problem has occurred.

I just got my replacement and have ridden it for a couple of days. So far so good but… It is very discouraging to hear about all the people who’s replacement unit’s have failed. My concern is that my replacement will fail one day after my thirty day window for warranty return to Backcountry. I really like the Core. Hopefully the one they sent me will survive. I am a little curious, it seems like the failures occur between sessions. In other words it never quits in during a workout. Has anyone had the failure during a workout? What I have been doing with my new one is to leave the power transformer connected to the unit and use the wall plug to connect and disconnect the unit. By doing that I reduce the chance of a voltage spike in the board as the transformer will act as a giant capacitor smoothing the voltage. Just a theory.

When you said you disconnected, did you mean that the unit stopped transmitting power and speed data while you were riding? If so, that throws my theory out the window.

Dave,
I found that there was resistance so I disconnected from Zwift and ran the Wahoo app. The Core connects via both ANT+ and Bluetooth however no data is transmitted. Wahoo know exactly what is a fault that’s why they changed my Core without question. It’s
infuriating that the replacement has developed this fault as well.

Duncs

STRIKE TWO!! Thanks for the reply Duncs. Got on my replacement trainer this morning. And yes, you guessed it. No power or speed data. Same story as yours. Worked great last night on a step test. I am getting a refund from Backcountry and have already ordered a Tacx. Fingers crossed.
Disregard my theories by the way. Oh and I talked with Wahoo, they had no arguments and said to send my replacement unit back to them no cost to me. They are trying, I will give them that.

I’m in touch the Sigma Sports as well. So far this week I’ve had issues with:

Vector 2s pedals

Vivoactive watch

iPad

Panasonic TV

Turbo trainer

What a week.

Duncs

Add me to the list. My first one showed connected but my Zwift rider didn’t move. Nothing registered on the wahoo apps too. Wahoo shipped me a replacement which also doesn’t work. For the price this is officially the biggest waste of money purchase I’ve made.

At this point, even if I miraculously got it to work, I have zero confidence it’ll last into the future. I’m ready to go with a different brand. Wahoo clearly doesn’t have their ____ together

Just got a kick core, new in box thursday (2 days ago) was able to do a spin down in the set up and the longer factory recommended spin down then same as everyone else. Doesn’t work sending any data. no watts, no ability to do a spin down again. I did talk to my LBS that I purchased from, they will let me return it but my wahoo dealer is 4 hours in the car RT. Guess Ill just return it and go another brand? Anyone else happy with the brand they switched to? Ironman coming up and I don’t need the downtime now!
thanks

Well, I’ve heard enough evidence in this forum to ask for a full refund from Wahoo. I’ve only heard once from their support team in a week. Just purchased a CycleOps H2 from my local bike shop so I can get back to riding. Joined a ride in the Tour de Zwift for tomorrow. I’ll makeup stage 1.

Ride on!

1 Like

Wahoo support has been responsive and my replacement unit should be shipped this week. They also provided a shipping label (at their cost) for the return.

I specifically asked about root cause and reoccurrence as others have noted here. Wahoo stated that they believe that the issue has been identified and the replacement unit will ship with updated internals. Fingers are crossed (Chattanooga HIM is only 18 weeks away) and I’ll update this thread with my experience with the replacement.

They believe … :-))) … fingers crossed for you, my friend …

don’t want to be rude, but honestly, I don’t believe in anything Wahoo staff say nowadays … there is a bunch (huge one) of defective units (Cores), and nobody knows what he is going to receive … good or bad? Wheel of fortune. Some folks got two, even three units (replacement) with the same problem … but Wahoo always promised the new unit is PERFECT … tested … verified … NOPE … they just take one box somewhere and send it to you as a replacement … and everybody hopes it’d work this time …

I have a Kickr 2018, I wanted to order Core, but it was sold out (God bless), so I had to order Kickr 2018. Am I lucky? Well, I’m not sure … at least I’m (was) able to use it for 3 months. Now I have 1.100 kms on it, and guess what … it is slowly dying … strange sounds, vibrations etc … become worse every day … if you are interested in what I’m talking about just google Kickr “clicking” and/or “drone sound” - those are two different issues … I have both and today I discovered third one - some strange scrub …

If my Kickr die (and I suppose it will do), then I will never touch any Wahoo product even with long pole … I’m really upset …

GdF

I appreciate the sentiment and I’ll be right there with you if I get stuck in the defect/replace cycle. I have to reserve throwing them under the bus until it happens to me personally.

I had the same issues as posted above. I sent email to WAHOO CS and they responsed on monday. I provided receipts etc, and today got an email that a new unit would be sent with 'upgraded internals". I asked about upgrading and they “dont allow it at this time”. Im not sure why as I would pay the difference? Hope my new unit is on the way soon and will keep updated. But all took place in 3 days time. So not too bad so far.
Paul B

just for “fun”… my Kickr 2018 in action :slight_smile:

Btw … my unit had strong vibrations/known as “drone sound” already, but it (mostly) appears only if my speed is over 30-40km/hour (to be honest it happens sometimes-not always) … well, so I tried to avoid higher speeds …

… now, new “effect” comes … this is new scrub sound - appears in low speeds only (like climbing) …

so now, I’m not sure what pace to keep = which sound I prefer … “Sir, do You prefer drone or Scrub ?”

Last Wednesday I updated my open ticket with Wahoo Customer Support and requested a full refund. I finally received my RMA today. My chapter with a Wahoo trainer is coming to a close. Next chapter involves a CycleOps H2 and it has to get better.

I purchased a H2 from a local shop on Saturday and was excited to get back to training. I set the trainer up Sunday and participated in the Sunday TdZ Stage 2. So far so good. Today I thought I would login to Zwift and just peddle easy in preparation for Stage 3 tomorrow. About 30 minutes into my ride I noticed some odd noises coming from my trainer. It was like something was loose inside. After peaking a hill and letting up on the pedals the trainer went into a free spin. There was absolutely no resistance on the pedals. Firmware on the new trainer was up to date, but I noticed a rubber seal had come loose. It appears the fly-wheel is broken. I’ll call the support line tomorrow.

What are the chances that I get 2 hoopty trainers from 2 different company’s?! Ugh…so defeated right now. And so much for completing the Tour de Zwift.