Rider won't move

I have seen a few old posts with the same issue, but none of them seem to be the same setup as me. I’m a subscriber with a Wahoo Kickr Core which I have been using with no problems for a couple of years. I use the zwift app on my iPad.

A few months ago I connected and my rider wouldn’t move, however I could get it to work using my iPhone so I have been doing that, but a couple of days ago that stopped working too. I did the calibration and that worked but still no movement when trying an actual ride.

I’ve tried disconnecting and reconnecting the trainer but it makes no difference.

What else can I try?

I have the same problem or, rather, my wife does. KICKR ROLLR. controllable, cadence, power all pair. but, rider stands with a foot on the road when the actual bike is pedaling.

Hello @Paula_Higgins welcome to Zwift forums.

Shuji at Zwift HQ here. I looked at your server logs and noticed you sometimes are logged into the game on both an iPhone 15 and an iPad 7. Concurrent log ins from two different devices will cause all sorts of weird symptoms like yours because the server thinks you’re still playing on Device 1 when you’re looking at Device 2.

Best practice 1: Always save and exit (or trash and exit) your Zwift session, and on mobile devices like phones / tablets / Apple TV - force-close the Zwift app when you’re done. Here’s how to force-close an iOS app. Swiping and app into the background is not the same as force-closing.

Best practice 2: If your device of choice is the iPhone, I’d recommend uninstalling the Zwift app from the iPad. Or vice versa. This way you’ll avoid the concurrent login situation.

I have the same problem. Suito shows as connected but then there’s no resistance or cadence once the route loads. I use a PC, been on Zwift for years, had a Tacx Flow that worked fine. Suito worked for a while, then starting yesterday, nothing, Tried this morning on my iPhone and it worked for a minute, then stopped. Seriously considering returning this trainer and going to something else if I can’t get it working soon. I’ve tried connecting via ANT, FE-C, Bluetooth, restarting PC and trainer, and nothing works. Got any advice?

Make sure it’s not paired to anything (kill Zwift). Pair and test it with the Elite app. Check for firmware updates. Calibrate using the Elite app (never in Zwift). Do a test ride in the Elite app. If any of that fails, contact Elite support.

Hi @Joshua_Mordin welcome to Zwift forums.

I looked at your server logs too, and the three of you reporting this symptom have different situations and probably different root causes for the same symptom.

In addition to checking the trainer in the Elite app and updating firmware if available, here’s a couple things for your case specifically:

  1. I see in your server logs that you’re trying to pair via ANT / Bluetooth. I’d recommend you unplug the ANT dongle and stick with Bluetooth only while troubleshooting.
  2. Because you Zwift on a Windows computer - open Windows Explorer and go to your Documents/Zwift folder. Look for a file called knowndevices.xml and delete it. This is the file that Zwift uses to remember previously paired devices like trainers, heart rate monitors, etc. Deleting it basically means you’re pairing to your trainer as though for the first time, and it will forget the ANT connections.
  3. When you pair via Bluetooth - pair to the Power signal first. Once that connection is made, the trainer takes ~10 - 15 seconds to start broadcasting the Controllable (Resistance) signal. This delay is expected and normal over Bluetooth. Pair to that, then Cadence last.

Would you try those things and report back?

1 Like

Nope! Didn’t work. I first deleted the app from the iPad, didn’t make a difference. Uninstalled and reinstalled the app on the iPhone didn’t make a difference.

Thanks, this is helpful. I got it to work today by doing the following:

Testing the trainer by just using the myEtraining app. I noticed some wonky data on the app, and recall seeing other people report that if the trainer is connected to the app it won’t connect right to Zwift, so I deleted the app off my iPhone, reinstalled, reconfigured and retested. Everything worked on the phone app. I Shut the app down, restarted Zwift and it worked just fine. (I later also uninstalled Zwift, deleted the folder and resinstalled just to be sure.)

As of now, I can connect via bluetooth (in the order you suggested above) and it’s working.

2 Likes

@Joshua_Mordin
Appreciate you looping back to report progress. Great to hear it’s working. I’d recommend you keep the ANT dongle unplugged and stick to Bluetooth as long as it’s working well. Simpler is better because when Power is paired via Bluetooth and Resistance is paired via ANT, weird things can happen. Splitting a trainer’s three signals over BLE and ANT is something you should avoid.

Hi @Paula_Higgins
As of January 9 - I’m still seeing several log ins in a row from your iPhone15 without a log out in between. A log out means you’re ending your session by 1) saving-and-exiting or 2) trashing-and-exiting. If either of those two actions aren’t received by the server - the server thinks your previous session is still open. This is one possible cause for your symptoms.

Joshua raised another possible cause:

Since you use a Wahoo trainer - do you have any of their three mobile apps installed? Any one of them might be hijacking the trainer’s signal and interfering with avatar movement. Please uninstall them to troubleshoot.
If not one of the Wahoo apps - have you installed any other fitness apps recently? If a third party app is getting in the way - we have no way to know on this end, so please check through your list of phone apps.

Still not working. I did have two wahoo apps although don’t think I’ve ever used them but deleted them. Zwift made me do an update this evening so I did that and it didn’t make a difference. I then deleted and reinstalled the app and it’s still not working. I don’t have any other cycling apps and my other fitness apps have always been there… I’m assuming you don’t mean Fitness Peaks, Garmin or Strava etc. as I’m not going to delete them just so that I can use Zwift.

I don’t understand why it’s been working fine up until a couple of months ago and I hadn’t changed anything to make it stop working.

OOOOO. You may have found the culprit. Garmin Connect is one of the apps that listens for a Bluetooth signal from your trainer. It’s running in the background, and will hijack the trainer signal before Zwift app has a chance to do so. I discovered this for myself. Please for the sake of troubleshooting - uninstall Garmin Connect.

Just so you’re aware - your Zwift activities sync to our third party partners like Garmin, Strava, Wahoo, Training Peaks, etc once you save an acitivity to Zwift’s servers. Our server sends that info to their servers. You do not need those apps installed on your phone for the sync to happen. Instructions for how to make that happen are on this Support article.

I’ve been troubleshooting with wahoo and they also couldn’t give me a solution. However, I moved the trainer from the garage into the living room and it started working. It appears as if people are just suggesting I try random things which don’t make sense considering it has been fine where it was for nearly three years. I don’t understand why all of a sudden it’s proposed that the signal is being hijacked by apps that have always been there. I need the apps on my phone for other activities.

Hi Shuji

Been trying everything in this thread, no luck yet even after isolating Garmin connections

Wondering if you can check my logs to see if there is more to see and understand?

I’m pedaling but it’s not! Note I have a Stages trainer

Thanks
Ian