Renpho AI Bike - no resistance in game [January 2022] [SOLVED]

And what make you think Zwift did not notify them. All the other trainers still worked.

Fancy replying on this message if you have it working?

  • State your device - Android/iOS
  • Your console version number
  • Serial number if you can be bothered

This would be handy for the developers in Renpho. They know about this thread. Although I have a suspicion some the staff are people on this!!!

I just got a refund and bought something else as I need to get fit…

I have done the same. I was trying out Kinomap while my bike didn’t work and found it was more suited to me. I too bought a lifetime membership so even save money long run. I now plan on slowly seeing the world - by indoor bike! :slight_smile:

1 Like

Hi AY,

We feel really sorry for the late reply. Could you please check if your AI Gym APP “Console Version” is 1.0.1087? Did you offer the SN code of your Renpho AI Smart Bike to the Renpho Customer Support Team and do the firmware upgrade?

We are handling this issue positively and some customers replied that the problem has been fixed after the firmware upgrade. If the Zwift no resistance issue still persists, please kindly contact us via email:[support@renpho.com].

We are looking forward to hearing from you.
Please enjoy your wonderful weekend!
Renpho Customer Service Team

1 Like

Hello folks, I’m going to throw in my 2 cents with a Nexgim MG03: Nexgim seems to use the same OEM as Renpho but is for APAC I think. There are two models MG03 (white colour, older model 1 year old) and QB-C01 (which looks to be the same as the Renpho trainer). I have used the Nexgim:MG03 with both SIM/ERG modes working fine untill recently.

Anyway today I am at 1.0.1085 and did TDZ 2022 Stage 2 and SIM mode has gone back to working.

A few days ago, I only had ERG mode working and then after a firmware update both SIM and ERG modes stopped working. After a full power restart of the iPad (not just bouncing bluetooth) both SIM/ERG modes are now working .

Both Rouvy and the Nexgim Int’l app(this seems to be a slightly crappier version of the AI Gym app for Nexgim-badged trainers) are working.

There is a Standard who describes the protocol between a server and a training device. FTMS. It might be the case that not all comply with the FTMS standard.

1 Like

Hi Piotr_Mlynarski

I riden around 1000km in Zwith since November 2021 when I received my AI bike and after my last 3h00 ride at 165w (111km) on december 24th it stopped working the way you described.

I just found out about this post today because I was no longer using Zwift since december 26th, the day I found out about the problem.

Renpho sent me a new handlebar with the control knob on Jan 12th to troubleshoot and it did not fix the issue. I have been dealing with Renpho up to this morning Jan 16th to find an arrangement.

I can share two videos I made about my issue.

youtu.be/1dkCKfO76Fk
youtu.be/dwGZPRCdDOw

I hope that this can help you with your case with Renpho.

I just looked at your stats regarding the amount of km or miles and elevation totals you made in Zwift.
This to compare if the Renpho AI bike is subject to break after a certain amount of time or rides and your stats are higher than mine.

Also since our issue is not related to the Zwift update and Renpho update we may want to open a new post like “ZWIFT and RENPHO AI Bike reliability” and have this one renamed “Renpho AI Bike - Found no resistance in game after latest Zwift update”.

In our case it is hardware related, not software related.

Martin,
I’ve seen your videos, and this is exactly what’s happening on my bike. I’m 99% sure this is a hardware issue. I have my bike since mid January 2021 and rode around 2000km on it before it broke a week ago.
I’m dealing with Renpho customer service now, sending them similar videos to the one you’ve posted. We’ll see where it goes, but thanks for letting me know about the handle bar, because they will most likely suggest the same thing. My bike still has a few days of warranty left, so I’ve asked for refund. We’ll see where this goes.

I think this is a hardware failure. If the bike doesn’t work without a connection, then it won’t work with a connection either. There is a main board in the inner of the bike. And a lot of cables. The knob is just one possible cause of malfunction.

Has anyone found definitive solution for the bluetooth connection issue?

1 Like

To Frank_Behr

Yes in our case it is hardware related. I found only a handful of owner with this issue over the year and they all got a replacement bike. I contactated them by chat and it’s how Renpho fixed the problem. None of them could tell the root cause though.

I finally got a refund today and I don’t have to return the bike. This mean I can now look at the internal components without voiding the warranty. My first impression is that the bottom part of the bike comes very hot and is not well ventilated. This may affect the internal components. I might not be able to fix the issue if new parts are needed but at least I will see if there is a way to improve the cooling of the bike.

My plan now is to weither buy another one when the price go down again or find a used one one marketplace adds. The only equivalent that is as quiet as this bike with a small foot print is the Stage SB20 but the price is way too high for my budget. The technology on the bike is fairly new and already 2 years old like the Renpho bike. I think there will be more offers for smart bike using the “motor damping” technology in a neer futur.

At 500$ (when rebate is available) the Renpho is still one of the most affordable smart bike available and is worth a second try if I can find a way to improve its cooling.

Martin,
If you ever open the bike up, imho, the most likely component that causes this issue is possibly a power transistor that regulates the current flow to the motor damping mechanism. I wonder if a bigger heat sink on one of those transistors might solve the issue.

Yes I will see once I have open it.
My plan is also to check if it is possible to move any circuits boards out of the casing in order to be less exposed to the heat produced by the motor resistance when riding.

1 Like

Yes, there is a fix from renpho and zwift. Download latest zwift update and Contact renpho support and they will send you the latest firmware.

2 Likes

The latest firmware update from renpho fixed the problem for me. Gave them my bikes SN number last week and another update appeared soon after.
I’ve tested with Bluetooth connections to my android phone and apple tv. Auto resistance in free ride mode works well on both again.

Latest firmware update from Renpho fixed the issue for me as well.

Do have some detail pictures of the inner of the bike? This would be very interesting. :slight_smile:

1 Like

after firmware upgrade zwift works again…

To Frank_Behr

Yes sure, once my wife free me to start this project :slightly_smiling_face:.

As a side note related to the new code update for the Zwift resistance issue…
Can someone provide the final version number of it?

Zwift version:
Renpho AI version:

Also I am happy to announce I have bought a second AI bike yesterday and it is new in box. Found someone selling it on FB Marketplace for 460$ CDN. I will be able to swap components between the bikes and identify the “bummer” part.

1 Like

I got the firmware update from Renpho this morning and Zwift is back to normal with all modes working as expected. If you’re still waiting for an update, contact Renpho support and send them your bike’s SN (visible on the sticker above the power cord). You can send them a photo of that sticker.

Motor Controller Version: 10.19.00
Console Version: 1.0.1087
Zwift Mac Version: 1.21.0(100317)

1 Like