Renpho AI Bike - no resistance in game [January 2022] [SOLVED]

Howdy all…

For the people who have it working, what console version are they on?

And does the resistance, gears, and ERG all work correctly?

What console version are you on?

Console version 1.0.1087

Damn so am and it’s not working.

It’s not working for me either. Really disappointing as this is the reason I bought the bike.

Mail from Zwift:

Thank you for your recent contact to Zwift Support!

We’re aware you recently experienced issues with your Renpho smart bike. We recently made a change on our side to address this. Please reply to this message confirming that you are able to Zwift without issue. If you are still experiencing issues, please reply with details of what you’re experiencing and we will work to resolve.

Unfortunately it still does not work on my bike. But feel free to try it.

1 Like

Hi Pawel, did you contact Renpho Customer Service for further help?

Still no new Firmware From renpho…. And Zwift is still Not Working….Consoleversion 1.0.985

Contact renpho support. You may need to send your bike serial number. I had a longer ride today and Its definitely working now.

1 Like

Send the Numbers (there 2 Numbers) to renpho, Hope i dont have to wait so Long for it… :frowning:

Weird, I’m on 1.0.1083

I just did a firmware update on Renpho bike (Motor controller version 10.19.00 and console 1.0.1087) and it make things even worse. I cannot get any POWER and CADENCE readout on ZWIFT running on APPLE TV. Bike connects POWER and CADENCE fine, just all 0’s when I pedal. Getting frustrated here. At least before it worked in ERG mode and with QZ app, now I’m screwed

I found mine didn’t work initially after the update either but, by turning Bluetooth off then on again on my iPad it reconnected and all works now.

Looks like my bike fully died following firmware update, it doesn’t even work with AI GYM app anymore. It connects but no resistance control. I got about 4 more days for warranty to expire.

It is also working for me. I had two firmware update this week. The last one solved my issue.

How come you all have higher console versions when mine is stuck at 1.0.890? The app doesn’t allow me to update the firmware. The update button doesn’t do any on Android, and the iOS app says it’s on the latest version. :frowning:

Piotr, I had a similar problem last weekend - connected to Zwift but 0 power and cadence. Also no workouts available in ai gym.
With some advice from renpho support and a LOT of trial and error, the following steps eventually fixed it for me…

  • uninstall ai gym app
  • power cycle bike, and make sure nothing else is connected to it by Bluetooth
  • power cycle iPhone (full power down reboot)
  • reinstall ai gym

I currently have motor controller 10.19.0 and console 1.0.1083. It is telling me I have the latest version. If I perform the above steps, I guess it may install the version 1087 you have, but as it’s working for me at the moment, i am reluctant to try. I rather hope nothing changes for a few weeks!

Colin, I have tried all that several times, but it looks like a hardware issue (or corrupted firmware on the bike) because even when I power cycle the bike, without any bluetooth connections, it should adjust resistance when the knob is turned. In my case, the knob shows gears changing but no resistance change.

It runs with update 1.0.1087 in a short session. I will test it in a longer ride later this day.

No firmwareupdate today :frowning: i bought lifetime license for Kinomap now and canceled my subscription for Zwift……Kinomap is working fine ….Zwift have to communicate with vendors before they Change such Important things….or publish it 2-3 weeks on there website so that the vendors can implement the changes….