Remaining distance counter measures line-of-sight

Hi, i just did the Tour of London Stage 1 and observed that the remaining distance counter was very much off.
First it dropped to 0.3 km, then started to count down from about 700 meters.
It then fell to about 200 meters, then started to count up again. This happened about when I could see the finish gate on the Mall on the mini map (see photo 2, it can be seen a bit there).
I’m on AppleTV, did the new update released today.
Looks like it is not measuring along the road, but line-off-sight.

I have same bug. Told this at 6. Oktober at Zwift. See my post, no reaction from Zwift!Calculation of distances in Zwift

1 Like

Gang: we’re aware of the distance counter issue and it frustrates us too. We’ve thought we had it fixed with last week’s release, but apparently not.

We’re still working on it, and will be glad to announce when it’s resolved.


I observed this same issue today on the tour of LDN stage 1, as well as last week on a group ride event that was also in London. Maybe it was fixed in the other worlds, but not London?


Maybe I’m wrong here but I almost feel like the fix/update for this is worse than it was before. Thank you for saying that you are working on it.

Yesterday, It was awful for the finish in Innsbruck. It bounced from .3km to nearly 2,000 meters, then back down. The inconsistency in the units also made me laugh.

1 Like

Not only did I just get hit with the distance bug in the 7pm eastern tour de London, but I was in the top 100, but results came up as 684 when they popped up after crossing the actual finish. What’s happening!? Seems super buggy and it’s incredibly frustrating when racing for a false finish line.


Same problem on LND stage 1 on Windows 10. Not nice sprinting this way.

but “it’s not a race” :rofl::rofl::rofl::rofl::rofl:

1 Like

I had a similar experience today in the Italy Specialissima race. The distance counter started at 30k, I was ’all in’ with 0.4km to go looking for the finish banner. Next time I looked at the counter it had switched to metres and was increasing from hundreds of meters to thousands. Thinking I may have passed the finish banner while looking down at the bars, I thought maybe the counter had switched to a post race distance. Unfortunately, I discovered later when I tracked down the race report that the race was 37km (not 30km), and I picked up a DNF. I have also reported the problem to Zwift Support.

So just raced the epic mountain on Watopia. I thought Innsbruck was bad…but holy ■■■■. You guys got me trying to sprint 3 times, final time being the really finish, which I finally just rolled through. How did this new version get beyond alpha testing??

1 Like

In today’s Tour Of London Stage 2 the remaining distance was way off (TV OS). I knew we would finish at the banner near the start pens, so I wasn’t really worried about it, but the distance to go counter hit zero while i was still out in Surrey Hills (descending) and then went back up to about 2 miles (although it showed the remaining distance in feet from that point forward, which was really odd). I was kind of wondering if the original ‘distance to go’ was calculated based on two laps of the route, neglecting the lead-in, and then just recalculated itself when it hit zero, but even that doesn’t seem correct. I truly hope they figure out this bug soon.

Also, I’m not sure if I’m remembering this correctly, but it seems that this bug was introduced at the same time the lead-ins were specified as that. Prior to the ‘lead in’ update people were confused as to why the total even distance was longer than what ZC was showing, but IIRC once you were in the even the total distance was correct and there wasn’t any of the remaining distance issues. Am I correct in that thought, or were there issues before, also?

A new update just came out earlier today (1.0.43801) that has fixes for event distance and riders on unknown roads, so maybe this will be fixed this time. :crazy_face:

Look like Zwift found and fixed the distance bug.

I watch one stream this morning and all seemed to work as expected.

Thanks Zwift team for staying on top of this.


I did Tour of LDN stage 2 last night, after the most recent update applied, and the distance counter worked perfectly.

1 Like

December 13 release should have fixed this on Windows / Mac / AppleTV.

iOS version is pending Apple’s approval.


I’ve been doing the Tour of London. Yesterday I did Stage 4. When I got to the last mile or so, the distance to the finish started to be shown in feet. But the countdown of feet seemed to start at, say, 4000, count down for a while, then increase again. This happened 2 or 3 times. It is difficult to describe it exactly as I was pedalling flat out, trying to stick with the group……….and even leave them behind!

No major complaint, but when you’re going flat out and trying to race to the finish, it’s strength sapping to see that you have 4000 ft to go, then it’s counted down to say 1000, then it increases again to 4000. I may be inaccurate with my description because the numbers are small on my ipad, but there’s definitely an element of countdown, increase, countdown, repeat.

Despite that, I’m having a fab time. After those awful hours of mind numbing turbo training over the years, I could never have believed that indoor training could be so thrilling.

Ride On!

Personal info removed

1 Like

@Duncan_Gaskell: I notice you were running Zwift on an iPad. Perhaps the most recent app update hadn’t been downloaded yet.

The Tour of London Stage 4 countdown to the finish worked correctly yesterday for me, on a Windows 10 PC.

1 Like

I downloaded an update quite recently but I’ll see if there’s one I’m missing. Thank you

Distance to go was completely bonkers for me last night on Watopia Waistband. .2mi to go jumped to 10k feet. I mean… it’s math and it’s only been two months and it’s only a major feature.

Are you on the current version? It worked well in Watopia from what I saw during the DIRT/IS Baker’s Dozen race.