Problems after tvOS 16 update [September 2022] [SOLVED]

I am suddenly having issues with my Apple TV and connecting devices. To try and fix this I have updated both the TVOS version to the latest version and removed and reinstalled Zwift but still have issues, along with a complete factory reset.
If I select my Suito as the power meter it doesn’t see it as a controllable device, If I try and select the suito as a controllable device it says only allows 1 device.
I was using a Viiiiva HR strap using ANT+ bridge to connect a cadence sensor. This connects as an HR sensor but doesn’t pass the cadence information.
Everything connects ok through Zwift app but I would prefer to directly connect.
The only bluetooth item listed on the Apple TV is the remote control.

Can anyone confirm what the default name of the Viiiia HR strap should be as the Zwift page refers to the Viiiia manual which doesn’t say. There is a Viiiia post on its supports page which says it is Viiiiia (with 5 i’s)

I have a similar problem:
I updated today my ATV to version 16.
I havent used Zwift for a while. But when I try to pair my sensors, I got the message that ATV only supports 2 separate devices
First I pair my Kickr Snap, after that my heart rate 4iiii. Normally I am able to pair my cadence sensor after that, because it works bridged with my 4iiii. But now that doesnt work anymore.

I think it is due to the latest ATV update

I had the same issue this evening.

Updated the the Apple TV last night.

Managed to get everything connected after a bit of messing about.

Hope it’s not going to be like this every time I ride.

I agree, I think it’s the Apple TV update.

tvOS16 is crap!
You know Apple, it will take ages to fix this. Maybe it will never be fixed …

1 Like

I had this exact issue this morning. I paired my Kickr Core for Power, my Garmin Dual for HRM and then went to add the Core for cadence and got this error.

I updated TVOS last night and confirmed that Zwift was up-to-date at the same time.
In the ATV system settings, only the remote is paired

I’m guessing that this has to do with the TVOS update but Zwift changed fonts without an update so who knows?


Lucky me, my update to version 16 failed this morning; no idea why (15.6 update failed too on the first couple of tries).

On the plus side, I managed a 56 min workout using the Companion app Bluetooth bridge, yippee! (first time I’ve tried this since things went t*ts-up in February of this year). No hardware changes my end; it’s a miracle. Let’s see how long this lasts; going to try a Pace Partner ride tomorrow :crossed_fingers:


I rode tonight and didn’t have any issues, same as usual. However, I also didn’t update to tvOS 16 until after my ride. Will let you know tomorrow if I have any issues w/bluetooth pairing directly to the AppleTV.

My problem is, that the ATV doesnt allow me to pair my cadence sensor (using my 4iiii HRM as a bridge).
Because there are already 2 devices paired at that time (my Kickr and my HRM 4iiiii)

I’m glad that I haven’t updated to tvOS 16 yet!


Rebooted my ATV and connection on last two rides is back to normal.

Fingers crossed.

Hey everyone - thanks for flagging up the issues after the update to tvOS 16. iOS 16 also dropped this week too.

When Apple operating systems update - they reset app permissions to the default (more restrictive) security settings. This means that you may have to manually re-allow Zwift to have Locations permissions so it can use the Bluetooth radio correctly.

AppleTV users: please follow these instructions to update those permissions.

iOS users: Apple’s Support Site has instructions for that.

Please try those steps and let us know if that resolves the Bluetooth issues? Thank you.


no that doesn’t work.
I am still unable to connect my cadence sensor with the 4iiii bridge.
When I try to pair the cadence sensor, I have the Bluetooth error, “a maximum of 2 separate devices can be paired at a time to Apple TV”

I have tried the fix suggested, Bluetooth was enabled already. I turned it off and on again but it still isn’t working. It used to pick up the Suito as controllable however now it doesn’t , if I add the Suito and then add the Suito as the controllable I get a message that only 1 device can be added, this is without attaching any other devices.

Because of the pop-up window I am unable to see to what two devices you are already connected. The Snap is paired as controllable, and it doesn’t appear that any HRM is connected, but what about the Power and Cadence connections?

Have you tried using the companion app? Id never had connection problems with ATV until the last few months. Started using companion app and been rock solid. I know it’s not perfect but a potential work around.

Thank you @K_DPW and @Grant_Harris for looping back and adding screenshots. Pictures are always helpful.

Question for everyone in this thread:

It sounds like you’re all using a bridged Bluetooth connection to pair to more than 3 total Bluetooth signals. Are you

  1. Using Zwift Companion as the bridge?
  2. Using the 4iiii Viiiiva heart rate monitor to bridge?

Trying to identify common denominators other than tvOS 16 update. Since these reports came in yesterday prior to today’s 1.29.0 game release, it’s probably safe to say that it’s not today’s game update.

I am using the 4iiii HR as a bridge. However as stated if I add the Suito as the power meter and then without connecting anything else I try to set the Suito as the controllable I get the message below


if you set aside the 4iiii for a minute what happens if you do the following;

  1. Pair to your trainer using the Apple TV’s native Bluetooth pairing. Are you able to pair to the Power and Controllable signals (forget the HRM and Cadence because that’ll exceed your 3 signal limit). Do you see the same Bluetooth error message?
  2. Pair to your trainer using Zwift Companion as the bridge - are you able to pair to Power and Controllable, or do you get the same BLE error message?
  1. I hadn’t connected the 4iiii HR strap and had removed it from the room.
    No devices were connected via Bluetooth, I added the Suito as the power meter but get the above error when trying to add it as a controllable device.

  2. I tried using the Zwift companion app it all connects OK if I use my wahoo tickr HR strap but still can’t connect the 4iiiii but the 4iiiii connects ok to the 4iiii app.