Problems after tvOS 16 update [September 2022] [SOLVED]

Thank you for posting this, @Grant_Harris. I have the same issue.

Kickr Core (one device) as Power, Cadence, Controllable
Garmin HRM Dual as HRM

Too many devices error. Except that it worked fine early this week. :frowning:

And yes, Bluetooth Sharing was already enabled. I did go there to confirm that the TVOS update did not undo the setting.

To add insult to injury, when I got the Unpair All Devices option from Zwift and I clicked it, nothing happen. I was just stuck at the Bluetooth Error pop-up.

1 Like

As mentioned, above I rode yesterday w/out issue. Post ride, I upgraded to tvOS 16, but did not ride/test anything.

This morning, I upgraded to Zwift 1.29.0 before testing things out for about 5min.

This is what happened next:

pairing

Okay! So I selected the unpair option. Nothing happened. I selected it again and it worked, i.e., unpaired everything. I then added my Neo which automagically paired as power, cadence, and controllable trainer. Then I added my Viiiiva HRM. :white_check_mark:

Entered whatever world was selected. Upon pedaling, cadence and power registered normally. HR was also reading normally. All good!

One last note, the Viiiiva is typically bridging my bike p2max power in addition to providing HR, but the battery happened to be dead this morning :man_shrugging:, regardless the Viiiiva paired fine and HR worked.

Summary:

Zwift Version tvOS version Result
1.28.1 15.6 Normal
1.28.1 16.0
1.29.0 16.0 Normal
3 Likes

OKay, I am using using the 4iiii heart rate monitor to bridge an old ANT Cadence sensor.

I do not have screenshots, because at the moment I am not a home, but this is what I did yesterday.

  1. I paired my trainer (snap) using the ATV’s native bluetooth pairing, I was able to pair power and controllable signals.
  2. Next I pair my HRM 4iiiii using the native Bluetooth pairing, everything still ok.
  3. Next I want to pair my ANT cadence sensor, who shows up as Viiiiva in cadence, but when I select it, I receive the Bluetooth error.

Oh, and when I try to connect my snap, hrm and ANT cadence sensor, using the 4iiii a bridge for my candence sensor with the Wahoo app, on my phone: no problem, works as it always had worked

I have exactly the same issue right after updating ATV to ios 16.yesterday. No hardware change was made from my end.

I’ve been using Kickr Core as a single device for power, cadence and controllable. Another bluetooth-connected device is a heart rate monitor.

Bridging through the companion app is working, but I’d like to directly connect Kickr Core and the heart rate monitor as before.

I wasn’t able to test the bridging (bike power via Viiiiva) since the p2m battery was dead. Otherwise, everything worked fine.

You might try changing the ordering of your pairing. Cadence, then HR :man_shrugging:

I didn’t have any issues other than the initial error message. Once I unpaired everything and then paired them all again, all was back to normal.

Neo: power, cadence, controllable
Viiiiva: heart rate monitor

Both direct to AppleTV, no Companion app bridging.

1 Like

I tried that, doesnt work.

My solution now is:
I have another cadence sensor, a bluetooth one. and my polar HRM
So, now I pair everything using the companion app as a bridge, that works without problems.

But I want to use the 4iiiiViva HRM in combination with my ANT cadence sensor. It always worked, until now …

I guess, there is no easy way to downgrade back to version 15 on the ATV?

Google this…How do I restore Apple TV to older firmware? I tried to post a link but not allowed too !

Okay, thanks, but I have a 4K version without a dedicated USB port. I guess downgrading is not that simple.

I have the same issue since I upgraded ZWIFT to 1.29. The Apple TV update to Ios16 did not cause the issue as I was using Zwift alonge with the Suito and the heartbeat Bluetooth belt. THe mess started with the update to ZWIFT 1.29…before that everything was fine. I guess since the suito shows three different parameters ZWIFT might believe that these are 3 connections plus the belt being the fourth. I hope they fin a solution to it!

What I have tried is: Connect the Suito (power Source) first and add the frequency and thereafter the Controllable. DO not have the Heart being connected at the first instance…try to add after the Suito has been added with its three features…might work for other Smart Trainer as well. I guess it is not an iOS issue, it is more an issue of version 1.29.

First things first: if you’re just joining this conversation - we advise Apple TV users against updating to tvOS 16 for now. We’re still investigating why this Bluetooth pairing bug is happening to some, but not all tvOS 16 users.

We’ve been testing on our end and are having a tough time reproducing it consistently. One thing we’d like to ask is to clear the Zwift app data, which removes the hardware ID’s associated with your trainer, heart rate monitor, cadence, speed and other Bluetooth signals. On ATV, that’s done by uninstalling the Zwift app.

Uninstalling apps on AppleTV is a little tricky.

  1. Click the Zwift app icon on the ATV home screen, and hold down the center button till the widget shakes.
  2. Then press Play > Delete.
  3. Reboot your Apple TV for good measure, then reinstall the Zwift game app.

Would you try this and see if clearing the app data helped?

1 Like

@shooj I generally haven’t been using the ATV lately because there is so much racing on GCN that it gets the TV while Zwift is relegated to the iPad. I did just boot everything up and try it (with all updates to Zwift and ATV) and everything worked just fine. No workarounds, no uninstalling, nothing. It just worked as normal.

Tacx Neo 2
Garmin Dual HRM

Both paired directly to game through ATV.

2 Likes

The issue I had appears to be intermittent. I Zwift on a Tacx Neo & use Garmin Dual HRM.

Tonight I did a warm up ride prior to doing the Baseline Ride. Everything worked fine. Finished warmup, saved it and went to log back in for the Baseline Ride at 1800 UK time. Bluetooth couldnt find the Tacx at all. Rebooted everything several times, no joy. Gave up & watch a friend, who I planned to cycle with, do the Baseline Ride.

Around 1850, I thought i’d give it another chance and everything connected & worked fine. Competed the 1900 Baseline Ride.

How can it be so temperamental?

1 Like

Also worth noting that one one of our testers at HQ was able to reproduce this error and fix it by following @Lin_Alan steps above.

To summarize, after updating to Zwift v 1.29.0

  1. Try to connect devices.
  2. If “Bluetooth Error” message is received, choose “Unpair All Devices.’
  3. Try to connect devices.
  4. If this didn’t work, try choosing “Unpair All Devices” a second time.

@shooj Tried both fixes (i.e. unpair and reinstall) on my ATV 4K. Neither fixed the problem. I consistently get a Bluetooth Error and need to unpair/re-pair my devices on every Zwift start. Seems to be ok for the rest of the session - although I have noticed that my internet connection seems to have intermittent disconnects/reconnects. Internet connection was always rock solid before updating to tvOS 16 and Zwift 1.29.0.

I’ve always enjoyed using ATV because “it just works.” Not enjoying the current situation where it just doesn’t.

1 Like

Hi @dcsleep welcome to Zwift forums.
We feel your frustration, because we’re trying to get to the bottom of this. What we know for certain is that reports started coming in the day prior to us releasing Zwift v1.29.0.

Also - your internet connection waffling is independent of Zwift or OS version. More likely a WiFi issue in your home, or possibly the network between your home and your ISP. Sometimes a simple reboot of your router and/or cable modem will help. There are other things you can try on our Support Hub

Same here while doing what I’ve done forever, using my Kickr as power/controllable/cadence.
I now get the “two devices” warning.
So I have to use the ZCA as a bridge, which I hate, becuase I get BT dropouts.

I also found that my Kickr Climb acted erratically. Gradient changes were abrupt and didn’t follow the terrain. It was particularly bad coming out of the subway tunnel in London.

Also, the font is horrible.
I can’t easily tell the difference between 5’s & 6’s or 3’s & 8’s when the font is small (leader boards etc.)

I expect a few minor bugs, but this is awful & inexcusable.

Thanks for your efforts in getting this resolved.

For what it’s worth I didn’t have any problems with Zwift 1.28.1 after the update to tvOS 16. I ran this combo for a couple of days. The problems only began after updating to Zwift 1.29.0.

I haven’t noticed internet connection stability issues on any other devices in my house. My ATV has been rock solid until these two updates. Not pointing fingers - just noting changes that may be relevant. As an IT professional for over 35 years I view all information as potentially useful during problem determination.

still experiencing drop out with Saris Hammer and Tickr HR strap. Permisions were already set as you suggested

Lunch ride. No issues. Started right up and rode for an hour. So that makes two for two since upgrading to 1.29 AND tvOS 16.

AppleTV 4K (1st gen)
Neo (1st gen)
Viiiiva HRM

Everything direct connect to AppleTV.

1 Like