Fix the Apple TV App PLEASE

You have a serious bug in the TV App that makes it unusable. The App will auto connect to the first BT device it finds and will NOT let the user disconnect it. In my case if always finds my Stryd pod and connects to it reducing me to 1 BT port. It does not show that it is connected but the app will only allow me to connect to 1 device. Most of the time the app auto cycles between connected and disconnected devices. FFS DO NOT AUTO CONNECT to any BT device that is available.

Don’t worry - I cancelled my membership and moved to a more reliable service.

1 Like

used apple tv from the release and NEVER seen this issue
only annoying thing is if i switch from riding to running i have to deselect all devices before selecting = you cant have all the riding devices paired in riding and just switch over to running then you have no channels left running,you have to deselect those devices first before switching
but really dont see that as an issue its just the way it works

never seen the apple tv pair to anything unless i have allready chosen to pair it THEN it will show automaticly next time

Deselecting would be nice but the instant I do it reconnects the same device automatically.

What is your set up? I use ATV 4K and the devices definitely do not connect automatically. I am able to select each possible item to pair.

I have the latest version but not the 4k. I can open Zwift and when the Stryd pod is just on the border of detection the Zwift App switches on then off connection to the Stryd all by itself over, and over and over again until I pull the power plug on the APTV (I’ll take a .mov next time) at 1 sec intervals. The app simply ignores any input from me via the remote. I’ve also had the app switch between the stryd and the Kickr over and over and over again when in Ride mode (Stryd pod has a power channel which is probably why the app picks it up in Ride mode).
I’ve tried resetting the APTV, deleting and re-installing the Zwift app to no avail. It worked flawlessly until about a month ago so something changed (either in the APTV OS or Zwift)

Frank, your suggestion of going back into Run, selecting the Stryd then disconnecting it again seems to have worked. I’ll see if this continues to be a solution to this problem.

Nope - there is a bug in the Apple TV version of Zwift. It auto connects to one of my Stryd pods and literally will not release its connection (reliably). The only solution is to power down the apple TV and restart it. How bad is it - well take a look at the picture. Noting paired yet the app returns a Bluetooth connection error!

Try terminating the app. Double click on the menu button, and then swipe up on the Zwift app. I do this after every ride and it seems to help.

Thanks James. Not the menu button but the TV button on my remote. Didn’t realize that function existed to terminate Apps.

I also see automatic pairing of devices on Apple TV 4k. When I try to unpair the power source, the Zwift app doesn’t let this happen. See the following video.

The BT device pairing is extremely complicated and unreliable. Today I had 60 minutes time to train and I actually managed to train for 10 minutes. The 50 minutes was sensor pairing and restarting things. Can you make the sensor pairing easy, please?

1 Like

I use ATV and have never seen that before. When I select on if the pairing icons it just opens up and shows the devices available to connect.

In the video it sounded like you were pedaling the whole time. Have you tried to pair when not pedaling?

If that doesn’t work you might want to try deleting the app from ATV and reinstalling. That may give you a chance to start from scratch.

I am seeing exactly the same weird behaviour as shown in the video. Zwift goes into some kind of loop in the BT pairing screen where it automatically connects and disconnects and connects and just continues like this.

I experimented with the order of how the BT devices get connected to the ATV and I have (luckiliy!) been able to find a workaround for this that works for me. I need to wake up and connect the BT devices/sensor in a certain order and then I am able to get everything connected without triggering whatever tvOS or Zwift bug that has been introduced recently.

Let me share the steps I follow in case it helps someone facing the same problem. Below are the steps that I go through (my equipment: Wahoo Kickr, Assioma Uno power pedals, Wahoo Tickr X HR):

  1. Make sure that all BT devices are off and have your Zwift Companion app open on your phone
  2. Turn on ATV and start Zwift and go to BT device pairing setup
  3. Wake up power pedals - usually Zwift now automatically selects power pedals as Power Source and as Cadence sensor. Otherwise do it manually
  4. Power on Wahoo Kickr - usually Zwift now automatically selects Wahoo Kickr as Controllable sensor. Otherwise do it manually
  5. Turn on Wahoo Tickr X - I usually always then need to manually select the Tickr X as the Heart Rate sensor
    5a. However, since the power pedals and Kickr already occupy the two ATV bluetooth connections then Zwift will ask if you want to connect the Heart Rate sensor through the Companion app instead. Choose ‘yes’ and try again to configure the Heart Rate sensor - this time it will use the Companion app for the heart rate connection

Using the above steps, I can now consistently get all my sensors connected and get on with the real stuuf, i.e., cycling!

Definitely, some update (either tvOS or Zwift update) changed some pairing behaviour which causes problems at least for some of us.

This has become a serious issue to me, so much so that I am unable to train. Zwift keeps auto-selecting my stryd Power pod for rides. Please fix this zwift, it is a serious bug.

Maybe I’ll also try to explain how I at some point get Zwift and sensors working. This is a very unreliable process and requires great care in the order things are done.

System:
Apple TV 4k with Zwift
Elite Qubo Digital Smart B+ trainer
Stages Gen3 power meter
Polar H7 HRM
Companion app on Android smartphone

  1. Start Zwift
  2. Qubo needs to be connected first as controllable trainer. If Stages power meter is connected first, Qubo will never be found and it will not appear on the list of BT devices.
  3. After Qubo is selected, it will also be automatically selected as power meter and cadence.
  4. Unpair power meter. This results in the endless loop shown on the video. Pressing menu will start the game and then exiting from there and starting Zwift again gets back to the pairing menu. Here you have to be quick because power meter selection happens automatically after a few seconds. If this happens, the only way is to enter the game, exit the game and try again to go to pairing menu and select power meter pairing before it happens automatically. At this point there is a small chance that Qubo has remained as controllable trainer. If this happens, you need to wait so that the pairing device list becomes grey and a remote control icon appears on the screen.
  5. Now it is possible to pair Stages power meter. If the remote control icon doesn’t appear as it often happens, the BT device list will remain empty and it will not be possible to pair power meter. The only way is to enter the game, exit and restart. This phase will typically take 5-20 minutes of trial and error.
  6. Stages can usually be selected as the cadence sensor when power meter pairing with Stages has succeeded.
  7. Activate HRM. This has to be activated at this point because otherwise HRM will interfere with controllable trainer/power meter/cadence sensor pairing.
  8. Click pair HRM. Choose HRM from the list. Zwift tells that Apple TV BT connections have run out and ask to use Companion app. Start Companion app and turn on BT on the smartphone. Unpair HRM because it is somehow connected to Apple TV and pair it again via Companion app.
  9. Enter game!

The endless loop shown on the video didn’t happen last winter so I assume that it is a bug that has been introduced within the past 9 months. I think that without it, it would be possible to pair sensors, though it still requires great care in order for it to succeed.

I think it would be sensible for the Zwift app to offer a feature for saving sensor settings. This way when a functional setup is found and saved, the Zwift app would just restore the BT connections exactly as they were saved. This would help immensely with the app startup, because sensor pairing is by far the most error prone part.

1 Like

Yeah, that endless loop issue is a real pain. I used to pull the power cord on the Apple TV but now I know how to terminate the Zwift App its a shorter process but still trial and error.

Has the fixing priority / schedule been decided for this bug already? This is so easy to reproduce (happens 100% of time) that it should be straightforward to make a correction.

1 Like

Any news on this? The issue remains as described above and makes starting Zwift troublesome. Sensors keep auto-pairing themselves. This bug was not there a year ago so it would seem to be software regression. As a paying customer I’d like this clear software bug to be fixed, thanks.

Today I was unable to pair both the trainer and the power meter with the Zwift Apple TV app at the same time. Either device can be paired without the other, but not both together.

If I pair the Elite Qubo Digital Smart B+ trainer as the controllable trainer first, it gets selected as the controllable trainer and also power meter. When I unpair the power meter, it gets stuck in the loop I showed in the video above. If I choose the Stages power meter as power meter first before controllable trainer, the Qubo trainer will never appear on the BT pairing menu.

The Apple TV SW version is 1.0.44368 - published 31.12.2020. This information is taken from Apple TV app information. I hope this is not the version that will stay for the entire year as the date suggests.

This is sooooo annoying! Just started using Zwift with my new Tacx Neo 2T and Garmin Vector 3 with an Apple TV 4K and so far… well, what can I say. I can’t use the Vector as power source and cadence with the Neo as controller. Yeas I know there are some BLT limitations but that is not the e issue. Vector connects but rarely shows power. Instead it switches between “no signal” and that icon dancing loop that is shown in the video below that is impossible to escape from. Please fix this bug immediately!