Companion to AppleTV connection failure [August 2023]


my girlfriend had trouble yesterday with connection failures on AppleTV.

As dar I could see, all Systems are on current patch level.

AppleTV 4k 2021 Ethernet,
Elite Sterzo, Polar OH1 both Bluetooth to ATV
Wahoo Kickr v5 direct connect
Zwift companion app on Android

Connection lost from ATV to Kickr so that Power and Cadence dropped to zero.
Happend on Makuri and Scottland regularly after approx 20 minutes.
She needed to drop connection to kickr (power and controllable) to be back in game.

Kickr direct connect and ATV on same switch.

What to do?

Hi, a bunch of folks are having the same issue and the common points are Apple TV and Companion app. Yesterday, I rode Road to Sky and it worked right until the descent when I got the connection failed message and could not reconnect again.

This has been happening for a while now and Zwift is not giving any straight answer other than check your connection, make sure of that thing. It doesn’t matter, it keeps failing eventually.

One more thing, they don’t realize that most of us are having this issue because we bought the Zwift Play and are forced to use the companion 'cause the limitation of BT connection in the Apple TV. What’s the point of wanting to promote a new device and when people support you, you just don’t deliver a solution right away and I’d say you don’t even listen to them…I understand that it is summer, things go slower but, they have issued a few Zwift updates already during summer…

Thats why I bought the direct connect for Kickr to have the 2 BT Channels for HR and Steering. Sterzo instead of Zwift Play.

We have to check if TVOS zwift version is now 1.45 and if dropout happen there too.
Second, if the connection is driven by CA on Android (is it 3.49 on her device) has dropouts.

I will give an update …

No dropouts after ATV Zwift was lift to 1.45. Thank you.

Yeah, I had the same experience yesterday but I want to keep trying just in case.

I run the Zwift Companion on my Andriod phone. I have a Zwift Hub, and Zwift play that I connect to through Companion app. I also have my heart rate strap connecting via the app. I then connect the app to AppleTV. The issue that I am having is that the last few rides that I have tried, AppleTV lost connect and I had to continue just using the app, or completely log out and then log back in to restore connection. I also tried power cycling the Hub trainer with the same results.

Hi folks,

I’ll flag this up at HQ for further investigation. Several of you have mentioned that you’re running Zwift Companion on Android, could you confirm which Android models? If anyone has experienced this when running ZC on iOS, please let us know.

Any additional information about the timing around the disconnect would also be helpful. For example, if it occurs after you minimize or background either app, receive a notification, see something happen in-game, etc.

Thank you all for raising this up.

I am running Companion(Ver3.49.0) on Android (S911USQS1AWFD). The last time issue happened to me was on Monday August 7th, after 6 minutes 27 seconds into workout.

I’m running 1.45 on Apple TV (4K 1st gen), with my Android 13 phone running ZC 3.49.0.

Since I’m using Zwift Play I’m pairing through ZC.

Earlier today I did Crow Road in the Climb Portal. When I finished the descent after the climb, and re-emerged into Watopia, very shortly afterwards I selected the teleport option to go to one of the Robopacers (also in Watopia). After the teleport and when the pedal assist had finished I noticed that all my pairings had dropped out (trainer, HRM, Play) and I had the Connection Failure message.

Is there an update on this issue? It has been over two weeks since this blog was setup. What is the status?

My problem with atv and sterzo seems to be solved. Girlfriend is happy.

I am still having the issue and it seems to be related to “Zwift Play” Controllers. I saw that there was an firmware update for the Play Controllers, so I downloaded the firmware and tried to run a workout. My Zwift HUB lost connection again after 11 minutes. I restarted Zwift and did another 33 minute workout without and issues.
Can you please look into this issue.