Apple TV 4K: Cannot connect power meter and smart trainer to Zwift at the same time

Hey all,

My current setup is this.

  • Apple TV 4K (tvOS 13.3.1)
  • Power meter: Power2Max Ngeco
  • Smart trainer: Elite Suito
  • Zwift (1.0.44575, 15 Jan 2020)

All devices are on the latest firmware and are unpaired from their manufacturer’s apps.

I cannot get the pairing to work so the power meter connects as the power source + cadence, and the smart trainer as controllable. The following describes what I tried.

Scenario #1:

  1. Wake the power meter when the pairing screen appears.
  2. Selected power source. The power meter appears in the list and is selected.
  3. Zwift will pair the power meter to power source and then to cadence.
  4. The smart trainer is powered on.
  5. The smart trainer does not appear in the controllable list.

Scenario #2:

  1. Both power meter and smart trainer are on before the pairing screen.
  2. Selected power source. Both power meter and smart trainer appear in list.
  3. Selected the power meter.
  4. Zwift will pair the power meter to power source and then to cadence.
  5. The smart trainer does not appear in the controllable list when selected

If I try to un-pair the power meter from the power source Zwift will glitch with a pairing loop. A video posted in this thread around post #10 shows what I’m experiencing.

thread: Fix the Apple TV App PLEASE

Scenario #3:

  1. Power on the smart trainer before the pairing screen and do not wake the power meter.
  2. Able to select the smart trainer as power source.
  3. Zwift will then pair the smart trainer to cadence and controllable.
  4. If I try to un-pair the smart trainer from power source Zwift will glitch with the pairing loop.

I only got Zwift to properly pair with the power meter and smart trainer a handful of times, but this requires 15-45 minutes of trial and error of disconnecting and reconnecting devices while Zwift is glitching. Even if I do get things connected properly sometimes the smart trainer doesn’t change resistance in sim mode (I find this always happens if I end a ride and start a new one).

I haven’t found a reliable solution and I tried the suggestions in other threads with no luck. Zwift support hasn’t got back to me yet.

Thanks for the help.

Do you have a HRM paired?
The Apple TV can only pair 2 BLE Connections.
So if you paired a HRM and the Powermeter, the smart trainer will disappear from any list cause the ATV ran out of connections.
Maybe this is your solution: https://npe-inc.com/cableinfo/

(or buying a decent PC and get better graphics on top of better functionality)

The problem is exactly what I am also experiencing. I posted the video of the endless pairing loop a while ago to the other thread. The problem has nothing to do with HRM because it happens 100% of time even if there is no HRM / 3rd Bluetooth device anywhere.

I have found a workaround that often makes pairing work.

  1. First pair the controllable trainer’s internal power meter as power meter. This will also pair the controllable trainer as controllable trainer and cadence meter.
  2. Try to unpair power meter. This will 100% result in the endless unpairing loop bug.
  3. Press menu on Apple TV’s remote. You are taken into the screen where you can choose the route, event, etc.
  4. On this screen you can also pair devices. Go there and suddenly you can see your separate power meter in the pairing list. Pair your power meter as power meter.
  5. Pair HRM via Companion app. There is also a separate bug here which make this a bit slow, but eventually it’ll work.

Pairing in the main pairing screen and in the route selection screen seem to work differently. Someone could explain this.

I can’t understand why Zwift has no interest in fixing this absolutely clear bug.

Hey all. Thank you for the suggestions.

@Ben_Fricker
Nope I don’t use a HRM when running Zwift. The power
meter and smart trainer each use one bluetooth channel. Including the apple remote this setup
should not be exceeding ATV’s 3 device limit. I do have a gaming rig that can run zwift; but it is a hassle (too heavy!) to move it each time I Zwift.

@Petri_Latva-Rasku
It appears that your workaround is working! I can consistently get the devices to pair right. It seems like I can only pair stuff in the “route/event” screen without causing the looping glitch.