Can't pair both Controllable and Power signals separately [1.15.0] [July 2021] [SOLVED]

Since this update I can’t connect my kickr to zwift via Bluetooth on my MacBook. My kickr connects fine using the wahoo app and I didn’t install the update on my iPhone and it connects via Bluetooth to my kickr fine. Very frustrating given that it was all working fine yesterday!


Same issue here. Was working before the update. No controllable trainers recognized using iPad. Updated Zwift after my ride today. Now not working. Same issue with multiple friends.


@Faz_Ashni_BSC and @James_Smith2 welcome to Zwift forums. I’d like to verify I’m understanding what’s happening on your ends.

  1. Please verify that you do not have multiple computers with Zwift running. If your trainer is already paired to one, it will not show up for a second.
  2. @Faz_Ashni_BSC same applies if your trainer is paired to your Wahoo app Assuming this is on your smartphone? If that’s the case - please try powering off your smartphone to eliminate this as a source of interference, give it 2 minutes, then try pairing your laptop to the trainer.
  3. After verifying these 2 steps - does the trainer show up when you manually try to pair to it?
  1. I do not have multiple computers with zwift runnung.
  2. I have tried this also.
  3. No it does not.

Not working after new update. No multiple computers running. Phone off. Nothing showing up under controllable. Not seeing my kickr but see hr and cadence. Happened the minute after the update. Friend same issue. Can you provide a tel # please. Thanks


Exact same issue with me!

1 Like

While waiting for a reply I pulled out an older iPad with older version of Zwift (1.13) and it connected fine. Zwift pushes out the update which I ignored and it was fine. However the updated version does not work . All roads lead to the update I think


@Faz_Ashni_BSC and @James_Smith2
I split your posts into a fresh topic.

Did a little digging, and it looks you’re both on Wahoo Kickr and Kickr Core trainers.
Using your Wahoo app - can you see what version of the Wahoo firmware is installed? If prompted - do not update the firmware. I’d just like to know what version it’s on now.

One last thing to verify - are you able to find the Wahoo’s power signal, but not it’s Controllable signal? Usually you have to pair Power first before the Controllable signal. You’re doing that, correct?

I have the latest firmware on my kickr core (V.1.1.1). I have both signals on my kickr - power and bluetooth.

1 Like

Thank you for the additional clues.

1 Like

Wahoo version v3.4.71….connects to wahoo with no issues. Can also see wahoo power signal.
Zwift older version works on my old iPad.

Thanks both for helping troubleshoot.

Typically - there’s a delay of a few seconds when you first pair a trainer (i.e. it’s not already remembered in your app).

After you pair Power signal, you hit the Controllable button. At that point, it can take ~10 seconds (for me anyway) before the list of Controllable devices appears. Waiting for this pause still doesn’t help, please verify?

1 Like

Ok that worked! I hit the power source and it found my kickr and then I hit the controllable button and it found my kickr! I am also now able to unpair it from my power source (as I use my own power meter) and it still finds my kickr as a controllable! Yay! Going to test it again though just in case.


Ok great Faz!

@James_Smith2 how about you? Does the Controllable signal show up if you give a few seconds?


Ran through this advice again and it worked, thank you!

1 Like

I’m having this same issue as well after the update. I use my power meter for power and cadence and kickr18 as controllable. I can see both the power meter and kickr when pairing the power and zwift sees the kickr when pairing the controllable. However when attempting to switch the power from the kickr to power meter the controllable is no longer paired to the kickr and I let it sit a good 60 seconds in the pairing screen again (controllable) and the kickr did not appear. My kickr firmware is updated and current, never had an issue connecting in 2+ years on zwift. Using iOS (iPad). Appreciate the help, thanks!

1 Like

Same here using a 4iiii Precision PM and a Saris H3 via Iphone Xr have tried shutting all down and restarting as well as uninstalling and reinstalling Zwift App.
I tried following Faz_Ashini_BSC success but it kicked them all empty and it is still searching for the green blinking H3.

I’m having this similar issues after the update. Zwift seems to be able to see my power meter, cadence and kickr18 as controllable. However, when I select a course and try and rife nothing happens. Very frustrating.


Magene T300 has issues with connecting to Ipad as a controllable as well.

Do you guys not run ANY SOFTWARE QA before release?

1 Like

Exactly the same for me. Running on an ipad. Worked perfectly before the upgrade this afternoon, now exactly as you say above. Very annoying.