Controllable trainer is not discoverable using Zwift Companion v.3.15.0 [SOLVED]

Hi, can’t pair my kickr as controllable since the companion app update today. Anyone else?



This is a known bug that we’re working on right now. Thank you for the report.

If your computer is able to pair natively to your trainer - please use that method instead of pairing via Companion.


Glad I’m not the only one. I was thinking my Wahoo had crapped out.


@shooj Can this be intermittent, and be a common issue with the Kickr Bike ? Yesterday I got stuck at 155W in a training session, even though Zwift was throttling me up and down. Today, upon starting Zwift wasn’t seeing any power coming from my Kickr Bike. I restarted and this time checked the connection screen. Everything was good and the second time it worked.

Same Issue here with my Gen2 kickr . The controllable trainer won’t pair after the update

This inability to pair to controllable trainer signal using Companion as a Bluetooth bridge is a confirmed bug we discovered after version 3.15.0 went live.

Just checked your session logs on the server and you hadn’t updated Companion until today June 12, so I don’t think it’s the same issue you may have experienced yesterday.


I thought the same thing but then tried sufferfest and rouvy and my trainer worked perfectly on those, so it has to be a Zwift bug in the update.

1 Like

That’s odd @shooj. I looked at Google Play this morning and it said I was up-to-date. I just checked on in the app. info. and it says I updated yesterday, June 11th.

@Bill_Velofix Same deal here. I exited Zwift, went into the Wahoo Fitness app. and was able to see and control power, monitor cadence, etc.

1 Like

I came across this issue today; my Wahoo Kickr snap won’t pair to Zwift after the update. Hopefully this is resolved very soon.

Same here, but works fine on my phone…

Same here, and I’m even not a Wahoo user (using Cycleops Hammer)!

In my case, Hammer as Power and Cadence sensor is recognized, but not Smart Trainer.

My environment.

iOS 10 + Zwit Comparison latest
OSX catalina + Zwift client latest

Yes, I had the same problem. Glad it’s not me. Thanks for posting this, you saved me a ton of time trying to root cause it.

1 Like

My trainer issue began this morning after my Mac did a Zwift software update. We’ve tried everything and can’t get the trainer to show up as controllable on our computer.

1 Like

2 hours of my life I won’t get back but glad it is being worked on. Is there a known issues page for releases?

1 Like

Hi @Andrew_Irvine welcome to the Zwift forums.
We make every attempt to highlight crucial issues discovered after a release goes live.

New game updates are posted to the What’s New board, and Zwift Companion links you to that announcement when a new game version is available. We ask people to report any issues within that thread.

We broke out this issue-specific discussion to the Known Issues board that you’re reading right now, and pinned it to the top right corner of the home page.

1 Like

That screencap shows the date when the Play Store released this version.

I’m looking at your data on our servers. Your phone didn’t get the update until June 12.

1 Like

I’ve had the same problem today with the companion app work controlling my smart trainer
Power sync (BT)
When is it likely to get a fix for this issue?

I have an Elite Zumo. Today I went to Zwift and something isn’t right - on the flats I can spin out really easily, and i’m barely feeling a change in the hills. Have tried setting difficulty to maximum and moving it about to see any change at all.

Has a recent update broken the control of the turbo, or any known issues?

I connect via Zwift Companion.

Currently Zwift is pretty much unusable as I have to spin as fast as possible in my smallest back cog and still hardly moving. It’s really easy to “spin out” which I’ve not been able to do before today.

If I use the Elite app I can manually change the resistance and that works fine.