Fix the Apple TV App PLEASE

Question: Why would you want to use the Vectors for power over the Tacx Neo 2T? The Neo is far more accurate than the Vectors, so why not just use it for power AND controllable? Perhaps that would solve the issue.

Well cycling dynamics for one but also consistency due to the discrepancy between different power meters. In a few months I’ll be back on real roads and then the Neo will be kind of an inconvenience to use on asphalt. :wink:

1 Like

Well, riding with Zwift would also be a bit inconvenient on the road, too, right? :slight_smile:

No reason I know of that you couldn’t use the Neo as your power source for Zwift and your Vectors while on the road (since they would be connected to a Garmin head unit most likely, which you might not even be using during your Zwift sessions). You could actually still use your Garmin head unit for the cycling dynamics stuff while Zwifting, since that can’t be interfaced to Zwift, anyway. Having each power source running during a Zwift session (with the Tacx connected to Zwift and the Vectors connected to your Garmin) would actually give you a point of reference for your road riding to understand how far off the Vectors are from your ‘actual’ power, since the Neo is (at least reputedly) more accurate.

On the cycling dynamics front: I do hope that at some point Zwift will find a way to work this is so that my avatar will stand or sit in unison with what I’m doing on the bike, as opposed to some algorithm.

The issue is broader than just using Neo’s power output. I am not lucky enough to have an accurate smart trainer and it is essential to get the power accurately measured. Nonaccurate power readings are pretty much useless when doing power based training. Therefore I don’t have an alternative except to use a separate power meter.

This bug is a new one and has been introduced during the past year. The infinite endless unescapable power meter loop wasn’t there a year ago. Please fix this urgently as it is affecting Zwift usage badly every single time it is started.

There is no reason why Zwift should combine controllable trainer/power meter/cadence meter together. They are separate sensors.

I don’t know if this helps to debug the issue, but when I have the smart trainer selected as controllable trainer, power meter and cadence meter, unpairing the power meter always results in the endless loop bug throwing boxes around the screen.

1 Like

I’m relatively new to Zwift on AppleTV (been using it on a Mac for a couple years), and I found this thread after experiencing an issue today where despite my Neo 2 not being paired as controllable (only paired as power meter), it was still controlling the trainer. I paired and unpaired the controllable part several times, no help. Then I unpaired the power meter part and it automatically re-pairs both power AND control… grrrrr.

Finally, after quitting that Zwift ride, closing the app and restarting, did it actually leave trainer control alone.

As background, I like to run TrainerRoad (via Ant+ on another device) and Zwift (via BLE on the AppleTV) simultaneously, with TrainerRoad in Erg mode and Zwift just running off of power.

This. This has been going on far too long. It’s bad enough when it happens before a ride, but I was just in stage 2 of TdZ, and my KICKR dropped out. Went to reconnect, and sure enough here comes the Stryd Pod. Every time I try and disconnect, it auto-connects to the Stryd. After 10 minutes of trying everything (even wrapping the Stryd in foil so it can’t be seen) I finally had to drop out of the TdZ. Since my ATV is in the basement, I don’t recall ever even pairing it with the Stryd, I don’t own a treadmill.

Why is this not fixed. Just turn off auto connect!

While on the subject of BT connection issues, also fix the BT through companion app connections. I run out of connections, it asks to use the companion app. I say “YES”. It looks like it is connected, but there is no data. Because it never really connected through the companion app. I have to “disconnect” and then connect to the device again. Then there is data. Polar HR10 if that makes a difference.

I am seeing the same issue when trying to pair Elite Nero rollers and a Powertap hub (through CABLE) to ATV. Hoping to see a bug fix soon.

Glad I found this thread. I was so excited to hook-up a new Apple TV 4K today and install Zwift. I’ve been frustrated ever since. The Stryd footpod is persistent in grabbing the power source slot and Zwift won’t let go. Stryd was downstairs and out in my garage too with my kickr being right next to the Apple TV. Zwift/Apple still grab Stryd and won’t let go.

1 Like

Workaround:

  1. Unplug ATV
  2. Launch running phone app or running watch and let it find/lock on Stryd
  3. Fire up ATV and then Zwift
  4. Pair your power source, controller, cadence etc. to preferred sources
  5. Start the Ride

The idea is that Stryd can only connect to one BLT device at a time. Lock it up with your running watch so APTV can’t grab it. So far this has worked for me. Not great, but at least it puts my KICKR as the only pairing device.

2 Likes

Good call. You could probably just close the Zwift app on ATV, not fully unplug the entire device.

I see the same thing in the video - I thought it was because the trackpad on my AppleTV remote is cracked.
If I run first, I end up removing the battery from my run pod in order to be able to switch over to Ride.

I’ve recently entered into this circle of ■■■■. My AppleTV has decided that it wants to talk to the Stryd. Sadly, I am on the bike and I want it to talk to my powermeter! I spent 30 minutes this morning fighting with it. :frowning:

Yes, I should have removed the battery from the Stryd. Good call.

Ugh, I just remembered, my Stryd is rechargable. I suppose Plan B is move shoes to a Faraday Cage. :-/

1 Like

Honestly, Appletv 4k works great…hardly ever any real issues. There are some things you learn to do as you understand how it behaves…but overall a great platform. You do need to close the app page so it doesn’t stay open when you exit…cause if you don’t and leave it open the messages don’t work right…pairing has always been automatic and no issue with 2 bluetooth trainers I’ve had. On Elite Direto now. Wahoo tickr pairing has been only finicky thing…but have worked out how that works too. Waking up hr monitor (seeing the lights when connecting it) just before opening pairing page and it gets found. Doesn’t always pick up my hr right away, but does as I either get sweaty or hr gets up enough…

A few drops of water on the contacts will fix that.

Maybe you could use another app on your phone to grab the BT signal from the run pod.

1 Like

Looks like the NPE Runn can have multiple BT connections. I connected it to my iPhone, and Zwift still tried tried to auto connect.
I have had some success letting letting Zwift connect it as the speed sensor, and then un-pairing the cadence first, and then unpairing the speed, then switching over to Ride, and connect my KICKR. But, that doesn’t work every time.

That’s what I’ve resorted to doing. Unclip Stryd & wrap it in aluminum foil when I’m not using it.

It’s ridiculous that we have to do this (and that Zwift seems to view this as acceptable).

It does work though.

1 Like

Fixing this bug today is not soon enough.

I could not get Zwift to release control of my Neo 2. Even with the “controllable” pairing box unchecked, checked, unchecked… nothing. Even after restarting the app (which worked last time) multiple times. At one point, I got stuck in the endless loop similar to the video that Petri posted above.

I ended up missing the start to a Tour de Zwift ride and starting (and quiting) 5-6 rides just trying different things… then I figured out a solution!

I like to train using TrainerRoad, while riding in Zwift. This means I don’t want Zwift controlling the trainer, only reading power. I have been using using TrainerRoad on my iPhone, using a CABLE device to port the Ant+ FE-C signal over to Bluetooth for my phone to pickup. Then I would run Zwift simultaneously off the native Bluetooth power-only signal from the Neo 2. BUT with Zwift constantly controlling the trainer and not releasing it, this was not working…

So instead, I quit Zwift, fired up the TrainerRoad app on my phone, had it connect to the Neo 2 directly instead (power and control/FE-C). THEN I fired up Zwift ATV and had it connect via the CABLE. The real trick is that in the CABLE configuration app, I turned off FE-C control for the Neo 2. So with Zwift connected to the trainer via CABLE, it’s now impossible for it to control the trainer! Yayyyy!

I then was able to get my workout done on TrainerRoad while riding happily in Zwift. So frustrating to deal with this though. And when I just want to ride on Zwift without TrainerRoad, I just connect directly to the Neo 2 via FTMS. ¯_(ツ)_/¯