“No Signal” in the pairing screen

hope zwift comes up with an update soon to resolve this. its been a few weeks already.

using windows.
kickr trainer auto detects when the zwift program is launched.
the HRM connects but there is no signal. HRM is working fine as i can connect it to the wahoo app.
zwift program hangs quite often too.

I have exactly the same issue. Tacx trainer which works perfectly with an iPAD when I try with my windows PC the trainer connects and I get the no signal message. I have tried all the suggestions I can find on the forum and none seem to make any difference. I take it there is no word of zwift fixing this it is very very frustrating

Hi all.

Not sure whether anyone else has found a solution but I think I’ve made some progress on this tonight after several frustrating days.

I have a Wahoo Kickr Core transmitting via Bluetooth to a Macbook Pro. Heart rate is separate via an Ant+ dongle.

After using the companion app and having intermittent success I’ve gone back to scratch and firstly tried removing the laptop and just using the Zwift android app on a Samsung S20 which connected immediately and without any issues.

That made me think that the issue was with my Macbook bluetooth rather than the turbo or Zwift.

I loaded Zwift on the laptop and got the dreaded 'No Signal screen when trying to connect.

I went into Bluetooth at this point with Zwift still open and saw that the turbo was constantly being connected and disconnected by the laptop over and over. Very odd!

I then deleted all devices and debugged the bluetooth on the Macbook. Follow these instructions and I’m certain there will be a similar process for Windows:

  1. Hold Shift + Option and click on the Bluetooth icon in the menu bar
  2. Click Debug and select “Remove all devices”
  3. Click Debug again and select “Reset the Bluetooth module”
  4. Restart your Mac and re-pair your Bluetooth devices

Fingers crossed!! I’ve restarted the laptop several times now and the Wahoo is connecting to Zwift via the laptop without any issues. The Bluetooth icon on the menu bar now has an ellipsis through the centre indicating a connection having gone through the logging in procedure on Zwift.

I’m going to slowly start connecting other bluetooth items such as Garmin watch and headphones and see whether it remains stable but well worth a go.

2 Likes

Hello guys, I found the solution after 3 days and trying everything! It occurred to me to replace the battery of the Ant + module (in my case an Elite Turno trainer) and now it works as it once did! Hope I was helpful!

This fixed my issue. Thanks!

1 Like

Having this issue today. Worked fine yesterday and months before this. i’ve been using BT Wahoo HR, Kickr Power and Wahoo cadence sensors with no issue before today.

WTF Zwift?

i rebooted Kickr and laptop to no avail

Same issue here my spped and cadence sensors are connected but red “no signal” message on zwift app. Phone and watch both recognize these sensors. First time having this issue on zwift app.

Same here, new kickr & tickr. Does work with the app, zwift says connected but no signal. Connecting to Windows 10.

When i connect via the companion, all works accept cadence.

Bit disappointed having spend a lot of money in devices and tools to make this work…