Bluetooth devices connect, but No Signal [January 2022] [Windows11]


This issue is essentially the same as the one reported under “Known Issues”:

[Bluetooth broke with update [September 2021] [1.17.0] [Windows10] [SOLVED]]

However, this issue also affects Windows 11.

I added a comment to the above thread, however, since that thread was marked [SOLVED], I feel the need to open a new thread, since the issue is not solved on Windows 11, even with the latest release.

My details:

Windows 11 Pro - 22000.194

Wahoo Kickr 20

BT power, cadence and controllable shows as pairable, and intermittently shows power for 5 seconds maximum, then shows “No signal”

I tried both the vc_redist.x86.exe as well as dll file linked in the other thread, and no improvements.

ANT+ is working fine.


Same issue here!

I can connect Zwift to my trainer (power and controllable) but it shows “No signal” after a few seconds.

Today I even tested all my setup (trainer, cadence e HR) on my wife’s computer (Win 10) and it all worked fine.


Just updating that I am no longer experiencing this issue.

Zwift game version: 1.0.83765

Latest “Patch Tuesday” patch for Windows 11 installed: 2021-10 Cumulative Update for Windows 11 for x64-based Systems (KB5006674)

Latest Intel bluetooth driver installed (Asus AX-3000 adapter): 22.80.1

I suspect the Windows patch may have been the difference, as that’s the only thing that’s changed since I last tried.

Marcelo can you confirm?

I take it back, I am still having the same problem with the latest release: 1.0.85474

The only way I can zwift reliably for now on W11 is using FE-C ANT+

Same here. Bluetooth broke with the prior patch, and issue not resolved with the latest. BT actually shows as connected, but the game doesn’t process input from the trainer. True for me on a fully updated Win10 and now Win11. To make matters even worse, this version defaults to Bluetooth, and insofar as I can tell, the default cannot be changed to ANT+ - which works as well as it always has. So one must remember to turn off BT on the PC, then launch Zwift, which forces it to find ANT+, and then and only then may you ride. Game Version 1.0.85474; Launcher Version 1.0.52

No improvement with latest update.

Game Version 1.0.85684

Also experiencing similar issues on Windows 11 - trainer appears as connected but switches between 0W/0rpm then and No Signal.
Managed to connect with speed and cadence through companion app but not controllable.
game version 1.0.85684

Same problem for me since October update

Hi, I might have found a workaround to get you going,until a more stable solution is found.

So the trick is to pair your trainer using the Windows bluetooth settings just before connecting to Zwift.
I then unpair in windows settings after the session.

Or I did once get it to work by doing a “remove device” then “reconnect” in Windows before the session.

It can still be flaky if I try to select Power, Cadence and Controllable, meaning I have to unpair again in Windows so I’ve done the last 2 sessions without cadence but I’m never fully convinced by the trainer’s calculated cadence anyway.

I hope that 1) helps you get some sessions in 2) is reliable enough for me to keep training until the next update

1 Like

See two messages below.

That was one of the first things I tried actually. It seems the Kickr cannot be paired to Windows. I get an error during pairing, “Try connecting to your device again”. I don’t think I was able to pair even in Windows 10.

Hi all,

A bit more information on the issues I met with Windows 11.

I am a fresh user equipped with a Kickr v5 and running Zwift on a Huawei Matebook 14 2020 laptop with the Zwift Companion App. I’m using bluetooth connection only and directly to the laptop.

During two weeks running Windows 10 everything was fine and I started the 4wk ftp booster workouts.

But 2 days ago I switched to Windows 11 and noticed several issues:

  • The most critical is that the power setting of the trainer get locked, so the power doesn’t change anymore when it should, the trainer is not usable anymore.

  • Tons of “Ride On”, i.e. I see any new rider or runner receiving a Ride On when entering my field of view.

  • When connecting an external screen while the Zwift is running, if the Zwift windows is minimized it won’t get back to the full screen anymore.

There are lots of network errors in the log such as “sending player state” and “auxiliary controller failed to connect”.

There was a new Windows update yesterday but it didn’t fixed the issue, so I went back to Windows 10 this morning to be able to continue my workouts and everything is running fine again.

Pairing the device with Windows 11 wasn’t working, I haven’t tried with W10.

1 Like


Just wanted to post my thoughts on this. I have just updated to Windows 11 and am now having Bluetooth connection issues but not with my Kickr 5. It’s my Wahoo Tickr hrm that is the problem. I connect using bluetooth on the connection screen and all is fine, sits there for 10 mins with correct readings. However, as soon as the screen changes to the ride screen, the connection to the Tickr drops and does not return. The Kickr 5doesn’t drop and works as it should do. It was working fine at the weekend before I updated from Windows 10 to 11. I also use Wahoo SYSTM and the Tickr works fine on there on Windows 11. Seems to be a compatibility issue between Zwift and Windows 11, not just an issue with Windows 11.

1 Like

Shocking update:

This morning I double-checked my trainer firmware in the Wahoo app. I was already at the latest for my trainer (KICKR v5 Firmware v4.2.5 - 13 October 2021).

However, I had a strange idea to rename my trainer in the app. I changed it from the default, closed the app, then brought up Zwift on my Windows 11 PC, and paired Power, Cadence, and Controllable to bluetooth (note: the new name I chose for my Kickr does not appear - only the trainer model with the bluetooth address).

Anyways, my session was 100% success. No power drops, no “No signal” messages. Everything was great, at least for my sample size of 1 out of 1 Zwift sessions.

I don’t know if this was a one-off fluke or if it’s a reliable work-around. I’ve had bluetooth magically working on a single session before, so I’m not super optimistic.

1 Like

As I suspected, Bluetooth not working on the second day. Everything looked good at the pairing screen, but as soon as I dropped into the game menu, I could see the Bluetooth light turned off on my trainer. Attempting to re-pair failed again, showing me “No signal” message. Back to ANT+

1 Like

I have spoken with Zwift support as I have two Microsoft surface pro 8 devices and the same issue for me as everyone here mentioned. Zwift said that Zwift is currently not supported on Windows 11 so the official word on the street is to not use W11. I hope they get this resolved soon! I do not have a PC with Win 10!

Hey everyone, I’m looking into this now as more reports pop up. I’m compiling a list of members who’ve experienced this issue, and if anyone would be willing to provide some more info via email, please let me know. Thanks!


Hi Win11 - I can’t control the trainer with ant+ or BT
Tacx NEO 2T/Hammer 1

Adding to this:

  • I can see and pair both trainer bt/ant+
  • I can see power numbers/cadence for both trainers bt/ant+
  • Zwift CAN’T control the trainer bt/ant+

What I tried:

  • Reboots
  • disabling one protocol reboot

Update 11/14/21 4pm

  • Updated all drivers (including graphic card)… nope
  • I moved my wireless from public to private network… nope
  • I disabled Defender… nope
  • I paired with Windows first… nope

Something that I notice that I can’t pair the trainer unless I pair power source first… if I unpair everything and then I try to pair just the trainer nothing shows during the search

btw: Both trainers work great with Zwift on my mobile device

1 Like


  • when I use the mobile app (erg) I get resistance on the trainer right away when I am not hitting target number
  • when I use my win11 pc I don’t get resistance at all (or at least not much) so I checked the companion app and the trainer is in incline mode (with a green small target that is before target number - it looks to me like “engage ERG mode” target) so as I pedal hard and I hit the green section the trainer changes from incline to erg mode and then I get the rest of the resistance and I can hit the power number.

is this new? I was used to get resistance as soon as I was not hitting target numbers???

is there anything that I can enable/disable on the windows app to make the behavior same as the mobile app?

Hi Lauren I cannot get my Bluetooth Treadmill Woodway to work with Windows 11 Zwift. It will pair initially on screen but as soon as I go in-game it drops and I cannot reconnect.
The Bluetooth treadmill connects up to Zwift on other devices eg ipad but not to Windows 11.

1 Like