"No Signal" message

Since weeks I have not been able to use Zwift. Pairing is unsuccessful - I keep getting a “no signal” message. This problem seems to have occurred after the update which was done some weeks ago. I am using Companion to connect my laptop to my trainer (Neo Tacx).
(I tired to contact Zwift on numerous occasions over the past few weeks via email, phone, chat, and via their FB page - received no reply - Im a very dissatisfied customer.)
Any help on how to resolve this issue would be appreciated.

Have you checked the Tacx app to see if there is a firmware update? Have you tried unpairing and then re-pairing? You might also want to get an ANT+ dongle and use that; I think it makes for a more stable connection than the Bluetooth.

Thanks for the help Nigel_Tufnel,
Yes I tired unpairing - but everytime I try to unpair Zwift program crashes.
No, I didnt try the Tacx App - I will give this a go.
(the connection worked fine some weeks ago - i never had any problems with the Bluetooth connection - I understand your recommendation to get a ANT+ dongle, but I shouldn’t have to)
Thanks again

1 Like

The recent windows 10 update may have messed with the bluetooth again, I read some reports about that so it might not be a Zwift issue.

1 Like

Hi Mike, thanks for the reply. Is there any solution if it is the Windows update?

Can you roll back to the previous version? I’ve never tried that on Win10, so I don’t know for sure. Otherwise, wait for Windows to send out a patch.

1 Like

And this is why I only use ANT+ :sunglasses:

1 Like

Difficulty connecting to more than one Bluetooth device

Realtek and Microsoft have found incompatibility issues with certain versions of drivers for Realtek Bluetooth radios and Windows 10, version 2004 (the Windows 10 May 2020 Update). Windows 10 devices with affected Realtek Bluetooth radio drivers might be unable to connect or pair with more than one Bluetooth device at a time after updating.

To safeguard your update experience, we have applied a compatibility hold on Windows 10 devices with affected Realtek Bluetooth radio drivers installed from being offered Windows 10, version 2004 or Windows Server, version 2004 until the driver has been updated.

Affected platforms:

  • Client: Windows 10, version 2004
  • Server: Windows Server, version 2004

Next steps: Microsoft and Realtek are working on a resolution and will provide an update in an upcoming release.

Note We recommend that you do not attempt to manually update using the Update now button or the Media Creation Tool until this issue has been resolved.

1 Like

Ok so I have done an update of the Tacx Tranier via the Tacx App. Now I do not receive and “no signal” messsage - now there is simply no pairing at all (without any message).
I dont recall any update to my windows happening in the past few weeks so I dont suspect that that is the problem either.


@Gerrie you appear to be from Zwift support: I dont have an Ant+. If this is the only way to connect then i suppose I should cancel my subscription until I buy an Ant+ ? Because what is the point in me paying for a subscription when I cannot even use Zwift? As I said it was working fine a few weeks ago, and now its not working.
And what do I do if I spend money to buy Ant+ and then the problem still persists?
Why is the Zwift support not replying to my emails requesting help on the matter?

1 Like

And what if I use my wifes Mac and run Zwift from there; if it still doesnt work then Windows cannot be the problem, right?

Hi @Ronan_Guirey, Gerrie isn’t from Zwift support, he is a community member like you and I and helps monitor the forums. Support is currently taking about 2 - 3 weeks to respond due to the huge backlog and all the new users the pandemic created for Zwift. If you continue to contact support with multiple emails it will put you at the end of the line, it is best to wait it out.

Is it possible that the Tacx app is still connected to the trainer, Bluetooth can only connect to one device at a time. Also, make sure the laptop isn’t connecting to the trainer through windows, let Zwift take care of it when you log in.

If you can test it on the Mac, that would help us determine what is going wrong. Also, can you try using the companion app to bridge the signal?

1 Like

Hi @Ronan_Guirey Im not from support just a mod on the site and a Long time user.

Make sure your sensors is not connected/paired to any other apps or devices.

I would say likely then.

Turn off Bluetooth on all your devices, Macbook, phones, tablet, Windows. Then turn on only windows, see if Windows BT shows your trainer, not even with Zwift open. if it sees nothing, I would contact the Tacx support to note their device is no longer sending out any signal to any BT device.

1 Like

Thank you @Gerrie_Delport @MatthewB and @Mike_Rowe_PBR for your further suggestions. I will try all of these today and will revert back to you and let you know if any have worked.
(@Gerrie_Delport sorry for confusing you are Zwift Support. And I apologize if the tone of my last message was not so pleasant - it’s just that I am just so frustrated and angry with the Zwift support because I have had this problem for weeks now and have reached out to Zwift support so many times without receiving a reply.)

Hopefully we can figure it out, just a simple process of elimination really, nuke it all from orbit and start with 1 thing at a time.