Zwift not pairing with bluetooth anymore

Hi there,

I have a very VERY frustrating issue since the patch, I cannot use the bluetooth anymore to connect my zwift, I tried on 3 computers, laptop using mac OS, a PC using windows 10, and a Mac pro using Mac OS too. (using bluetooth companion)

I got the zwift companion greyed out, I can edit the pref.xml, put it to 0, not greyed out anymore but still not working with the warning sign on the bluetooth icon.

I’m an IT technician so I tried everything I know, so don’t lose your time asking me if I’m on the same Wifi or if the app is running on my phone, yes they are connect on the same Wifi, the thing is, EVERYTHING was working perfectly, I can still ride with ANT+ but I’d prefer use the bluetooth.

This is so annoying, I’m about to cancel my membership and use trainerroad to be honnest, every time there is an update I’m running into problems, I and don’t touch anything, is someone having the same issue what the ■■■■ can I do ?

Thanks

Update : with my macbook pro and Catalina I can pair bluetooth using the built in bluetooth, but still impossible with the companion, is there a problem on zwift ? I am the only one having this issue ? I just received a mail concerning windows 10 bluetooth issue. what is going on ahah ?

Hi Denis,
I find that Ant+ is much less problematic. I always avoid connecting via bluetooth and only ever use Ant+. I like its ability to multi connect.

It would be a shame to see you leave Zwift, especially as you have the solution without any financial cost. I can understand your frustration though, as I dislike things that refuse to work.

I have Macbook Pro running Catalina. No problems before or after the patch w/Bluetooth. :man_shrugging:

What trainer are you connecting? Could the problem be the trainer?

I cannot get my Win 10 laptop to connect with my Neo2 using Bluetooth in Zwift.
It connects instantly through Tacx Desktop App so clearly the laptop and the trainer can make a decent connection - it’s just Zwift that won’t work. Zwift doesn’t see the Bluetooth module in the laptop - it just shows the yellow exclamation mark next to the Bluetooth symbol.
My feeling is that Zwift’s implementation of Bluetooth is flaky.

2 Likes

A Wahoo Kickr, no… The trainer is working perfectly fine with ANT+ and was working perfectly fine before the patch. Also, I can connect it using my laptop w/ Catalina, not through the Companion but through the built-in bluetooth, but this is not my “zwift computer” I just want my zwift computer to work, for now I’m just using ANT+

You using the companion or the buil-in bluetooth in zwift ? Also working with my laptop and catalina via built-in bluetooth. The only difference with my Mac Pro is my Mac pro is running Mojave.

not sure if this will help, but take a look at this thread:

1 Like

I use the laptops built-in Bluetooth. I have never tried the Companion app BLE bridging. Have you checked the Setting > Privacy > Bluetooth setting on your iPhone? The Companion app will need to be allowed access. I believe this is new w/iOS 13. Catalina also had some similar new privacy/security settings.

1 Like

Hi @Denis_Coulet welcome to Zwift forums.

Shuji at ZwiftHQ here. I looked at the session logs for your last successful session on January 30 and compared them to the next failed session on Feb 13. I’m seeing a Mac Pro 5 in both cases, so I’m assuming that is your preferred computer for Zwifting.

On January, that machine was running OSX Sierra v10.12 and the Zwift game app was version 1.0.44575.

On February 13, that machine had been upgraded to OSX Mojave v10.14 and Zwift game app v1.0.45663 (still the current game version). Apple’s changes to app permissions on Catalina can also trip up users running Mojave. Please have a look through the link that Mike posted and try the steps I outline there. Would you let us know how that works out?

Also - is your Mac Pro capable of being upgraded to the new-new OSX version 10.15.x? If it is, please upgrade to Catalina.

First off, thank you for your time. And having a look in my log, really, really appreciated.

I know I’m a little bit complicated with all my computers, actually everything stopped working when I change my old 2008 mac pro to a mid 2012 mac pro. I was running High Sierra, and on my new mac pro Mojave, I actually was able to ride with mojave and companion, but just once. Never worked after that. So I tried with my Macbook pro and catalina, worked instantly, so I guess Mojave is the problem.

I also tried with my PC with windows 10, it never worked at all.

My mac pro is not capable of running Catalina, actually yes there is a few tricks to do it, but I don’t want too cause of the 64-bits interface, that’s gonna interfere with some software I’m using.

I’ll take a look at your poste, but as I said, for now ANT+ is fine, but scary cause I had drop in the past, but seems ok now ! Thanks again

Oh, I took a quick look at your post, I did this several time, I actually removed the whole folder every time I was trying to make it work. On my cellphone, in privacy companion is checked, but on my Mojave I’ll take a look :slight_smile:

Thanks, that’s fixed it!