Bluetooth available despite not having a dongle / connection issues

pairing-error
(S. Urista (C) ODZ) #1

I have an ANT+ dongle. I do not have a Bluetooth dongle. Zwift has been rock solid for the last 15 months or so that I’ve been using it.

Today, Zwift appears to be picking up both an ANT+ signal and a Bluetooth signal. The app sees my Favero pedals but then quickly shows ‘No signal’. My Wahoo Kickr doesn’t show up at all.

I have no idea how the app can be finding a Bluetooth connection when I have no Bluetooth dongle on this PC. I turned off Bluetooth on my iPhone, just in case - no change. I’m on Windows 10 (64-bit). There is no Bluetooth device connected, Bluetooth is not on / available on the PC (confirmed in Device Manager etc).

As noted, Zwift has been 100% rock solid for the past year+ that I’ve used it. This is the first connection issue I can recall having. Only thing I can think of is that having both Bluetooth and ANT is confusing it or something, but I don’t see any way to shut of Bluetooth.

FWIW - Bluetooth displays as off (unavailable) in TrainerRoad and Sufferfest (although SufferFest has its own issues). For some reason, Zwift is the only program that insists it is still seeing a Bluetooth signal. The icon at the top-right only allows the ‘Beta - Use Built-in Bluetooth’ option; the ‘Use Zwift Companion’ option is greyed out.

(Steven) #2

Hi there,

I checked without our team, and there’s a currently known issue/bug where the Bluetooth widget is appearing on Windows machines where native (built-in) Bluetooth (BLE) is not supported.

Our team is working on a fix and while there isn’t a workaround for this issue yet, the fix will come from our end, so all you should have to do is keep your game client updated. We appreciate your patience and understanding as we continue improving Zwift.

The Zwift preferences file sometimes becomes cluttered with conflicting, inaccurate, or irrelevant data. We’ve had some measure of success resolving these kinds of problems by having Zwifters delete the prefs file.

  1. Exit and close Zwift.
  2. Open the Documents --> Zwift folder on your computer and delete the file named prefs.xml and also delete knowndevices.xml. If you have file extensions hidden, then these files will simply appear as prefs and knowndevices.
  3. Launch Zwift again, try a ride, and see if that helps.
  4. NOTE: After deleting the prefs.xml file, you will have to pair your devices and sensors again, as if for the first time.

If deleting the prefs and knowndevices doesn’t work, have you tried completely uninstalling Zwift, and then installing a fresh copy from Zwift.com? If not, maybe try that as a semi-workaround/solution.

After uninstalling the app through the Control Panel, delete the following folders:

  • Program Files (x86)\Zwift
  • Downloads\Zwift
  • Documents\Zwift

If you want to save any workouts, be sure to back those up from the Documents\Zwift\Workouts folder. Note: this process will reset your personal bests, as those are local to your computer.

Once you’ve uninstalled, you can download a new setup file from our website​ and install from that.