FIXED: Kurt Kinetic Trainer receiving 'No Signal' when pairing with Android Zwift Companion

Hey Zwifters,

Update #3
We should have a fix for this in the next update. There was an issue with the fix before so it had to be delayed but we’ve got that sorted out. Here’s to Update #3 being confirmation of the fix!

Currently trying to pair the Kurt Kinetic Trainer to Zwift through the Android Zwift Companion app will result in “No Signal” in the pairing screen. We are currently investigating and will update this post as we receive new information.

Thank you for your patience!

[ZG - 4709]


Hello… still no solution ? I can’t wait to start using ZWIFT again !!!

Hello Zwift Staff,
How long do you suspect it will be until this is fixed? I am really missing using zwift! Is there a way to connect my kinetic trainer to a pc without using the companion app?


1 Like

can we have news please ?

No updates yet, there are some base functionality issues that we’re working on with Android ZC.

Do you have a time frame around when you expect this to be fixed?

I’d like to know this, too. Right now, I’m paying for something I can’t even use. If this isn’t going to be fixed soon, I’ll have to cancel my subscription rather than just throwing my money away. I’m currently looking for zwift alternatives or will just ride with the KK app (boring, but at least it’s something).

Your right about being charged for something you can’t use. I kind of got fed up with the Kinetic trainer and got a Cycle Ops. Now I can ride on Rouvy and BKool apps too. If Zwift ever fixes this issue with I’ll sell my Kinetic trainer.

My Zwift updated with new features I can’t use since my Kinetic trainer still shows no signal. When will there be an update I can use?

I’m having consistent success with a work around.

I get the no signal issue with my trainer every time I ride, but can still get it to work after refining a work-around process. I also have a BLE HR monitor, but I don’t think that changes this issue one way or another, but may be relevant.

What I do:
-Start normally (BLE connections, companion, game…) until you get to the no signal issue on the pairing screen.
-Continue to the ride as if the pairing worked. Obviously you won’t be going anywhere yet because power is not being registered.
-Close the companion app. You will remain in the ride.
-Reopen the companion app. It takes a little time (<1min) for all the connections to resume, but once connected, the connection is stable throughout my rides.

I suspect there is some process in the pairing screen that drops the signal connection after it is made, like it keeps looking for other devices. This process is different because you are already in-game, and it just starts utilizing the signal vs. searching. Of course, I’m just guessing and have no real idea why this works, but it does.


I am using a Stages power meter and once it’s connected, as usual, there is no power on the screen and it says “no signal”. I have tried both ANT+ and bluetooth and it is the same. I have been using the same set-up for about a year without any issues.
Is this part of the same problem?
Any idea of fixing it?!

New version of companion, New firmware if kinetic,… Always the same issue : no connexion !!! :frowning: :frowning: :frowning:

This work around fixed my issue for the time being.

I’ll give that workaround a try. I had gotten it to pair with signal a couple of times by randomly shutting down the game app, the companion app, my phone, but hadn’t had success often enough to pin down what the actual workaround was. I’ve since acquired a CycleOps H2 but I’ll set up the Kinetic and give your workaround a try. Once Zwift comes up with a fix I’ll sell the Kinetic.

Your workaround worked brilliantly!!

Thank you! Maybe you should think about joining Zwift’s development team…

1 Like

What work around I don’t see it

Guess I should feel fortunate. Mine works for a bit then drops out and comes back after a minute or so. Sucks though. Sometimes I switch to my speed sensor to keep going and come back the inride. Just purchased the inride3 that does ant+ and ble to hopefully alleviate this.

Spent a full day trying to set up my trainer thinking the problem was on my end! Hope there is a solution soon!

Same issue here–Kinetic smart trainer and Zwift Companion app not connecting.

So…it has been ~15 days since the update and still no resolution, barely an update? Does the Zwift software dev team at least demo the new versions with commonly used third party software prior to roll-out?

It’s disheartening to pay for a premium service which has such seemingly poor software support.

I have the same problem. The problem also occurs with the Android Beta app. I’ve mailed Zwift support twice, but the don’t respond to any e-mail.