Getting "No Signal" right after connecting


(Michael Coy [DIRT]) #1

Howdy-

I’ve been using the same setup for 1+ years with no issues but I am longer able to maintain a Bluetooth signal. Im using the Kurt Smart Trainer and connecting via the Companion app. (Android). It connects quickly, but then after a couple of seconds says I have “No Signal”.

I shut down all other Bluetooth connections ahead of time. I know this can be an issue.

Never had a problem in the past, but now it refuses to play nice.

All apps are up to date and I can connect to the Kinetic app and calibrate / train with no issues.

Any ideas?


(Vincent W.) #2

Hey Michael, this is a known issue that we’re currently investigating: Kurt Kinetic Trainer receiving ‘No Signal’ when pairing with Android Zwift Companion

Right now if there is a way to connect to Bluetooth without the Zwift Companion app that would be the only workaround. Or if you have an iOS device that can run Zwift Companion.

We’ll update that post as soon as we receive new information, thank you for your patience.


(Michael Coy [DIRT]) #3

Ah! Thank you. I should have done a more comprehensive search in the forums for this. I look forward to good news. I will check out the suggested fixes in the meantime.

-Mike


(Vincent W.) #4

No problem! There’s a lot to peruse, but browsing through the Known Issues section will give you a glimpse of some of the more common errors we’re dealing with.


(Colm Richardson) #5

Has there been any updat on this, been using kinetic trainer with zwift for past 9 mths and the past couple weeks getting the no signal message all the time, really frustrating as its winter training time


(Rob Sendall) #6

I’m also have the same problem, any updates? Very frustrating


(Anthony Robinson 3673) #7

I’m having the exact same issue! Things were fine a week or so ago, and now all of a sudden, I’m unable to connect and maintain a connection. Is there any update on this??

I’m trying to ride a series and now am completely going to miss the make up day.

Also, how did this happen? Not to be “that guy”, but is there no QA taking place when you’re pushing out updates? This seems to happen a lot with Zwift: things work fine, you push out some update which breaks something that worked completely fine, and then we have to wait weeks before you fix it.

It’s more than a little annoying


(Brad Waddell) #8

Same. Just updated and now nothing. Any update? Also pairing screen is really buggy.


(G Schisla) #9

Same here. Been going on for a few weeks. Bluetooth on the phone and PC are working fine.

Any update?


(Graham Dawson (Tcg) B) #10

Would be interested to know when this gets resolved.


(Jared Kindt) #11

Same issue here–Kinetic smart trainer and Zwift Companion app not connecting.

So…it has been ~15 days since the update and still no resolution, barely an update? Does the Zwift software dev team at least demo the new versions with commonly used third party software prior to roll-out?

It’s disheartening to pay for a premium service which has such seemingly poor software support.


(Alain Chatry) #12

Hello, I am facing the same issue on Duotrap S Sensors as Well… I was using the same devices and same setup last year and now when connecting, it finds the sensors and it immediately mention, “no Signal”…

Please see picture attached… this is really annoying, I have tried all troubleshooting and nothing is working!!

Picture Attached.


(Bucky Marks) #13

My screen is identical. I am using the Duotrap on an old Kurt Kinetic. The published workaround does work for me.
The work around is to bring it to the No signal state, start a ride (even though you can’t move), start pedaling, kill the companion app (not just stop the app, kill it). Wait about 45 seconds, restart the companion app. It should see the PC with a connected sensor, and it will start shipping signal. Once you get signal, you will start to move on screen, and it should remain connected and up from then on.


(Alain Chatry) #14

thanks… will try it!


(Ron Driscoll) #15

I just bought a Kurt Kinetic Road Machine control and am using it with an Apple TV. It worked great the first time used it in Zwift but now I get the “No Signal” shortly after connecting to my trainer.

I have tried everything mentioned in this forum but nothing works. My training is NOT paired with any other devices and I turned bluetooth off on my phone so it is only connected to Zwift on the AppleTV.

It is frustrating to sit by the side of the road and watch everyone ride by and there doesn’t seem to be any tools to help diagnose signal/connection problems. Is it just Kurt Kinetic trainers? Any suggestions would help since it would be nice to stay and ride.

Thanks,
Ron


(Ron Driscoll) #16

Found the solution on another similar thread: For anyone using an AppleTV and getting the “No Signal”, it requires a reset (as in full reset) of the AppleTV to solve it (at least that worked for me).


(Mark Stockwell) #17

Just jumped on Zwift with my Kinetic Smart Road Machine. Been working fine on Mac OS until this morning. Got the “NO SIGNAL” during pairing. Frustrating. Anyone else on Mac OS getting the same issue? Dec. 28.


(Cloned Goat) #18

Getting the same situation of “No Signal” after pairing for the last two days running on windows 10. What’s up


(Chris Hugge) #19

Same problem. Kinetic trainer worked fine out of the box for two days. Now connected but no signal on all devices.


(Allan Grawey) #20

Same issue here. Worked for about a month, but in last week 10 seconds after connecting it says “no signal”.

Have re-booted countless times, updated apps, firmware, hard stopped anything that could be causing Bluetooth interference without success.

Kinetic says issue is not on their side, would love some insight.

Rock and Roll T-6500 + IPad.

Thanks so much!