'No Signal' between the companion and my P.C


(Simon Hodgkiss) #1

Hi Guys,

I have read a few threads in the forum regarding ’ No Signal’ on Kurt Kinetic trainers but I am having the same issue with an Interchange speed and cadence sensor.

I have been using it quite happily since the start of the year but as of the last month or so it will not connect properly. The ‘Paired devices’ screen shows the interchange and the Elite power fluid red roller turbo on the respective speed and cadence boxes, the BLE-phone is happily sending out its waves on the screen picture but the message shows ‘No Signal’.

I have tried two different phones and a tablet and even swapped out the battery in the sensor but nothing has worked.

I have spoken with the Zwift tech team and they have advised me that this is a current issue with no solve date as of yet and no workaround for the problem.

Not sure if anyone else is having similar issues but may answer a couple of questions and stop them pulling there kit apart looking for the gremlin.


(Vincent W.) #2

Hey Simon, yes we are investigating similar issues to yours. Did you happen to pair your speed and cadence sensor to any other device or app before? If so, try double checking that device or app and unpair your sensor from it.

Which device are you using to run Zwift Companion by the way?


(Simon Hodgkiss) #3

Hello Vincent,
The last time the companion worked it was with an old phone that I changed only a few months ago. In a bid to try all options I did dig it out of retirement, charge it up and try it but had no joy. There are no paired devices on it now and I did shut it down after trying it to avoid any contaminated bluetooth issue.
I have checked my Tablet as I did try that and again apart from the wireless speakers there is nothing in the pair list. The only thing linked to the sensors now is my current phone.

You have asked about the devices used:

I have tried the companion app on my Sony Experian (the old phone), that has formed many successful connections in the past but sadly not this time.
Also during this trial it has been on an Asus Zenpad tablet and a Huawei P Smart phone.

I hope this helps and look forward to being able to get back out there. :grinning: