27,334 watts? Kinetic, Android, Win10


(Marc Dorval) #1

I just updated Zwift, and now my Kinetic trainer will connect, show over 27 thousand watts, then show No Signal in the pairing window. My HR monitor connects well, but regularly shows No Signal for a couple of seconds then reconnects again (Tickr). All firmware (Kinetic and Android) is up to date.

I also tried on Kinetic’s app and on Rouvy without any problems.

This is very new behaviour. Any ideas?


(Steven D) #2

Hi Marc,

My first Thought is that perhaps you’re getting some signal interference. I’d recommend reviewing our Zwift support article entitled, “My Bluetooth signal is dropping” and see if you can eliminate any potential interference sources.

If that doesn’t help, please submit a support request HERE and we’ll need to request log files from your computer, then take further steps to troubleshoot the issue. Thanks!


(David Schulz) #3

Several people with Kinetic trainers are having the exact same issue. Was working fine then the no signal kiss of death after the October Zwift update. Have to say the interference excuse sounds like bull.


(Marc Dorval) #4

Great to hear I’m not the only one!

Marc Dorval

Remember not to include your email address in your replies. - Mod


(David Schulz) #5

Find others on the Zwift forums topic Zwift Game Release: October 1, 2018. I am giving up angel going to BKool trainer and will see how BKool’s support is. Best of luck.


(Vincent W.) #6

Hey Marc do you have your trainer paired as controllable? And what device are you running Zwift on?


(Marc Dorval) #7

Yes, it’s set to be controllable. And, Zwift is running on my Pixel Android device and on Windows 10.


(David Prause) #8

Same issue here: Connection is made, but then says “No Signal.” Can’t consistently resolve.

No significant/consistent issues until recently. Not certain when, but could have been the update.
Using Moto G4 running Android 7 and a Win 10 PC to connect Kinetic Controllable.

It is also worth noting that using the Kinetic app directly works fine. Sensors read well and stay connected. This appears to be isolated to Zwift, not BLE interference.


(Dean Densmore) #9

Same here as well. I started having the no signal problem after the last update. Haven’t been able to get it to work since.


(Sascha Demetris) #10

I had this issue. Connecting the trainer to my phone, disconecting my Garmin Vivoactive 3, and putting it in airplane mode seemed to do the trick


(Mitchell Hanson) #11

having the same problem, although usually 65,000 watts. using kurt kinetic, s7 phone to computer. Same issue using the phone app in beta, but the kurt kinetic can read data just fine…


(Michael Taylor) #12

I’ll chime in just to add that I’m having the same problem since the 10/2 update to the Companion app. I’ve had a ticket open for about a week now. Though the person responding to the ticket has provided a couple potential fixes, nothing has worked yet.

Hoping we get a fix for this soon, and happy to provide log files, etc. if this will help.


(Marc Dorval) #13

Also looking forward to a fix soon. But, gives me a chance to try out other apps.

Marc Dorval


(David Prause) #14

I don’t know why, but I have gotten it to work successfully twice since all this started.
-I also had a BLE HR monitor connected. It seemed like the trainer would connect, then disconnect while waiting for the HR monitor. I removed the HR monitor (and dropped all other BLE connections to be safe), and that seemed to allow the trainer to connect, and remain connected.

I’ve since reconnected the HR monitor. At first I got the no signal issue. I then closed the zwift companion app, and restarted it, and the connections were all good.

I’m guessing, but it seems like there is some sort of prioritization of signals, and the HR monitor was pushing the trainer off the list, but only in the pairing screen. If I’m already in the game, the new connections hold.

This has only worked twice, so we’ll see if it keeps working.


(Marc Dorval) #15

Just downloaded the NYC update, hopeful for a fix to this problem. Alas no such luck. Has anyone heard anything else concerning the issue?


(Michael Taylor) #16

It doesn’t appear that the 10/18 update to the Zwift Companion app has fixed this issue. I’ve deleted my knowndevices.xml file and restarted the PC (more than once), turned off the mobile data on my phone so it can only communicate via wifi and bluetooth, even uninstalled the Companion app, restarted the phone, re-installed, and tried again.

No luck on anything so far. I’m not sure the customer support person is convinced there’s a bug here, to be honest, but I’ve definitely tried everything they suggested at least twice.

Any ideas? I’ll note that when I borrow my wife’s iPad and use the iOS version of Zwift it works fine. I haven’t yet tried the companion app on iOS if that’s an option.


(Michael Taylor) #17

Figured I’d do some more troubleshooting since I wanted to ride today…here’s what I sent customer support via email:

I tried the following:

  1. Normal login in and use (Google Pixel 2 Android phone) with the 10/18 update to the Companion app, mobile data turned off so only wifi and bluetooth were on - NO SIGNAL received on my devices (even after deleting the knowndevices.xml file and rebooting).

  2. Uninstalled and reinstalled Companion app after rebooting phone, phone in no mobile data mode - NO SIGNAL received on my devices.

  3. Used iOS version of Companion app on my wife’s iPad - Successful 40 minute ride, no problems detecting either the Kinetic smart trainer or the Kinetic HRM

  4. Installed 10/18 version of the Companion app on my wife’s phone (Samsung Note 9, Android) - NO SIGNAL received on my devices

I know 2 phones isn’t a very big sample size, but it definitely feels like the issue is the Android version of the Companion app, whatever changed in the 10/2 release (and carried through to the 10/18 release) appears to no longer allow consistent BLE communication with my Kurt Kinetic Smart Control trainer and Kinetic HRM.


(Mitchell Hanson) #18

Still having issues. Downloaded the Kurt kinetic update that was supposed to update firmware. Couldn’t connect to bike. Then downloaded 2nd Kurt Kinetic update in a week, could connect, but not update firmware.

Guess I’m using Rouvy until whatever this is gets figured out…


(Molly Hanlon) #19

Same issue here. I don’t have the option to update my KK, but works fine in their app and anywhere that isn’t zwift. Both ZML and zwift for Android can’t connect. It’s totally unusable. I’ve tried everything listed here, with no luck. Somehow I got it to work earlier this week with multiple restarts of everything. Does anyone know if Zwift is planning on fixing this?


(Michael Taylor) #20

It’s at least on the bug radar, not sure how long it till take for a fix.