Watts either 0 or spiking


I’m having a problem with my trainer, it’s a Jetblack Volt EMS, It connects to Zwift (have tried HP laptop & iPad) and have done spin down/config to try and resolve. However it either flat lines at 0 thus no movement from the bike or the other way in that it massively over-reads Wattage (it said 20,000 + W at one point!)

Have uploaded the connection screen incase this is useful.


Hi @Sam_Robinson2, welcome to the forums. It sounds like you might be getting some bad signal interference. You can try eliminating all other bluetooth signals in the area and see if that helps. You can also drop a log file into www.zwiftalizer.com and see if that tells you anything about signal interference being an issue.

Lots of things can cause signal interference like fans, microwaves, your wifi router, etc.

1 Like

Thanks for the speedy reply @Mike_Rowe1 .

Yeah from the logs the connections looks iffy, i’ve tried to turn off microwave/devices using bluetooth, pretty much everything bar wifi router as surely the router is needed to run Zwift?

try changing the channel to 1 or 3 on the router, that might help.


do you like the trainer,
I’m thinking of buying it too

@Patrick_Koppitz hard to say yet as haven’t got it working, arrived this week. Easy to put together/put bike on but the android app doesnt really work which is fine if you’ve got ipad/iphone, my friend has one and loves it, think i will too, just need to get the connection steady!

@Mike_Rowe1 thanks, need to work out how i do that on my router as i don’t know the admin password etc (separate issue) - Do you think using an ANT+ extender/dongle would help?

Myself and many others have had much greater success with ANT on windows platforms over bluetooth. So I would say yes! And no need to get a very expensive ANT+ dongle, $20 -$30 should be the most you will spend.

Unfortunately neither the Ant dongle or different WiFi worked, must be a faulty trainer unless there’s anything else that can be suggested?

Annoyingly might have to be returned!