Connecting but no watts

I have had this issue for a while now. I have bought a MacBook Pro 2012 to use with zwift and my Tacx flux s. But every time I try and connect turbo it says it’s connected but will not register any watts or show any cadence. I have tried uninstalling and reinstalling zwift, different ANT+ dongles, different cables, Bluetooth the lot. I’ve tried on the garmin Tacx app also seeing if the firmware is up to date. Any tips would be appreciated.

Hi @Gavin_John

Welcome to the Zwift forums!

Sorry that you’re having this issue. It sounds like there is signal interference going on. Zwift is seeing a signal being sent out, but not getting the whole signal. Make sure that your trainer is not paired to any apps. You mentioned the Tacx app, make sure it’s fully closed and not stealing the signal.

Make sure the trainer is not directly paired to the device that Zwift is running on. Once the signal is free, make sure the device running Zwift has bluetooth turned on, then boot up Zwift. In the pairing screen make sure the bluetooth icon is pulsing. Pair up your trainer and see if it gets a signal then.

You can also check out our support article for more tips on this.

If you’re still having issues with this, reach out to our support team so we can do some one on one troubleshooting as something else may be going on.

That didn’t work for me and am annoyed I can’t just call someone to help me walk through what is going on.

Trainer is only paired with 1 device, device recognizes Power Source, Cadence, Resistance but no output is registered on any of those. I updated the firmware, reset my device and the trainer, forgot the trainer and device, repaired, and still nothing. I’ve literally tried every configuration of updates, pairing, powering on/off and nothing has worked.

Everything is picked up by both my laptop and phone (separate trials, not simultaneous) and when paired - no output to the APP. When I try and ride with my avatar he just sits there because nothing is registering to the APP. I even tried to pair it to the Wahoo App and same thing - the trainer is recognized by the device but no speed, power or cadence is recognize by the APP.

Again, annoying there’s no one to call to resolve this.

I believe you should contact Wahoo support.