Wattage not registering

Connect via Bluetooth but rider doesn’t move at the start. RPM is fine but W doesn’t move from 0 - any ideas?

Can you post what your setup is so we can better assist you in getting the issue resolved.

If you are just using a cadence sensor that is not enough, you would need at least a speed sensor on your rear wheel.

Cadence and speed sensor, I’ve made sure that the whee magnet is close enough to the cadence sensor.

Can you post a pic of your pairing screen.

Also addition info on your setup could be helpful (PC, Mac, iOS or TV, what type of trainer, wheel size and more).

IOS (Apple iphone 5),bought a Tacx Matic smart trainer ( I know the photo says blue twist that was me just trying all of them), this is the standard pairing page. Wheel size - 700x25c.

Tried the turbo trainer with the Tacx app and the wattage doesn’t budge there either.

What speed and cadence sensor are you using? Does the speed register on the app for that device (watts won’t show on the app since it does not broadcast watts, only speed)?

using the following speed and cadence sensor - this works fine but I’m not moving from the curb

Does the Tacx app show speed when you are pedaling?

These are the supported S/C sensors for Zwift, I would think that the Tacx S/C would fall under other, but I have not heard of anyone else using it.


OK, if it is registering speed on the Tacx app it should register watts on Zwift (Zwift estimates watts based on read wheel speed and the selected trainers power curve). You may have to start the ride to see if watts are displayed and your avatar moves.

If you are connecting using Bluetooth make sure that the S/C is not connected to the Tacx app or any other device or app since Bluetooht can only connect to one thing at a time. 

Hi Paul. I’ve cycled for 5 minutes with the avatar still not moving, no matter how fast I go. I only downloaded the Tacx app last night to see if I was having the same wattage issues as Zwift, so that’s not the issue.

What a shambles

The Tacx app will not show wattage, only speed. Is the Tacx app showing speed and cadence?

It almost sounds like only the cadence sensor is connecting and working fine (assumption since you have not said anything about cadence). but the speed sensor is not transmitting the speed of the rear wheel to Zwift.

No only cadence! And you’re right the cadence is fine on Zwift, it’s the speed sensor that isn’t transmitting the speed of the wheel. Come accross this before?


So in the Tacx app there is no speed registering? You need to have the speed sensor extremely close to the magnet on the wheel, almost touching for it to register (that’s the way the Wahoo Blue S/C works). Another thing you could try is a stronger magnet on the wheel.

If there is no speed registering I would contact Tacx and see if they can send you a replacement or help you resolve the issue: https://support.tacx.com/hc/en-us/categories/200939189-Contact-Tacx

Here is a Google search for the sensor not working: https://www.google.com/search?ei=6pUxWp2CM8nAjwTS-oFw&q=tacx+speed+and+cadence+sensor+not+working&oq=tacx+speed+and+cadence+sensor+no&gs_l=psy-ab.…0…1.1.64.psy-ab…0.3.269…35i39k1j0i22i30k1j0i22i10i30k1.0.HF1EvBBiRj8