No Signal Error during Training Session

Hi There,

I use Zwift with my Cyclops Hammer and Macbook Pro, everything has been working well until a few weeks ago about the same time as I started doing training sessions on Zwift.

Everything works well and then randomly Zwift loses connectivity to the Trainer the interface shows no signal. The only way I have found to resolve this is to save the training session, reboot Zwift and start again. Any ideas what the problem is?

I have been having same issue using Bluetooth and Companion to a Windows PC. the experts are telling me to switch to an ANT connection with the extension cable. Mine is arriving from Amazon today. If you get dropped mid ride, I have been having good luck going the pair screen ( hit A key) then settings. Switch from companion to internal BT. wait a fw seconds then switch back. You loose time but you don’t have to log out and start over, Z Insider has a few articles on this and this is his recommendation too.

Hi Greg,
Thanks for the response. Im not using the companion just direct bluetooth between the trainer and laptop. Will try the A key though

Switch to ANT+ if you can, it is much more reliable than Bluetooth.

1 Like

If you are not using Companion. then my hint about the A Screen… Won’t help you I think, unless there are 2 options to connect in the method you are using. There are some nice features using the companion app. give it a look.

Hi @Anthony_Mortimer welcome to Zwift forums.
I looked at your session logs on our server, and it looks like you’re on a Macbook Pro running OSX v10.15, and the Hammer trainer connected to it.

We’ve recently identified a bug that may affect Bluetooth connectivity for Macs running OSX 10.014 and 10.15, and are working on a fix for that. I’ll update this thread when it’s fixed.

In the meantime - would you have a different device (an iPad maybe?) that you can use to run the game? Or, if you have an ANT+ dongle for the Macbook, that’s also a viable alternative.

I ve same problem. My setup is Imac with mojiave and zwift connected with ant cable to elite suito. Last Wo have been a disaster. Now i m making upgrade to catalina. This is a bug?

@Romolo_Pomaretti_ITA
Not, this appears to be specifically when devices connect via Bluetooth, not ANT+

If you are upgrading to Catalina - be aware that Apple changed the way app permissions work. When you run Zwift for the first time after using Catalina - you must allow it to have permissions to write to the Documents folder. If you do not, the app can not run.

I m using this setup from 3 months without problems…now is not good. In catalina wich folder have to check ? Need install again zwift?

After you upgrade to Catalina and run the Zwift app for the first time, you should see a prompt that asks if you want to allow permissions to the Documents folder. Say yes.

This previous thread goes into more detail for Catalina users whose Zwift app will not run.

Ok thank you hope solve this problem

I’m using a very stable android app and Bluetooth connection to a tacx flux S trainer. Have absolutely no issue unless I stop pedalling for approx 30s. After which I loose the Bluetooth to the turbo but not the hrm. I have tried every combination of powering off the turbo and bt but need to resort to the ant+ or bail and start over. This is repeatable and really frustrating!

1 Like

Posting my experience here, in the hopes there may be progress in fixing that MacOS bug:

I’ve been Zwifting four about two months – the duration of the pandemic shut down and it’s been great, a sanity saver, and a fitness booster. But I’m having constant probelms with my signal dropping between my smart trainer and the Zwift program. It’s happening to me about once on every hour-long ride. And today, it happened three times. Driving me bonkers.

My setup: Wahoo Kickr Core, Wahoo Tickr HRM connecting to a MacBook Pro (MacOS 10.15, connected via Bluetooth) running Zwift with the Zwift companion app open on my iPhone (with Bluetooth turned off). Both MacBook Pro and iPhon on the same network. I’ve learned to be sure I turn off all other Bluetooth connected devices. That helps, but it’s no panacea.

When I do lose the signal, I first switch off my Kickr via a plug strip. Then, in Zwift, I disconnect everything (Kickr, cadence and speed) except for the Tickr HRM. Then I restart the Kickr via the plug strip and pop back into Zwift to reconnect everything.

I’ve got it down to a quick exercise – maybe 20 seconds – but it’s soooo sooo frustrating to lose momentum on a long ride.

Any tips or tricks I might me missing?

Why do you need a speed sensor? Maybe this is causing the issues?

Ideally, you should just switch to ANT+, it is far more stable.

1 Like

Thanks Mike, I should have been clearer: The speed data is coming directly from the Kickr, not a separate device. But the speed shows sensor up in the connection screen, so I disconnect it too when I have to reset. May yet try Ant+, thanks. But I keep seeing people having to set put their Ant+ dongles on USB extension cords to improve connectivity and am wary of adding more cables. But hey, if it’s stable, I’d consider it. Welcome any tips or experience you’ve had.

Even if you use Bluetooth I would suggest adding a extension cable to get the dongle away from the Pc and closer to the trainer.