Bluetooth connection lost mid ride and wont reconnect

pairing
(Mike) #1

I have experienced an issue if my phone OS grabs focus from Zwift - e.g accidentally open task manager via swipe up, or asks for permission to store a photo -

Then the watts display goes to “-- W” and it’s like the Bluetooth stack connection is disrupted and wont resume. Disable and re-enable phone BT doesn’t fully work, nor reset of the trainer. As the trainer might then start showing in pairing menu after messing around, but then after every pairing attempt quickly goes to Not Connected without a single watt being sent. Briefly “0 W” might show then back to “-- W”. Even though the Bluetooth HRM pairs ok and starts reading again. Trainer resistance also goes to very low. Only solution has been to end ride, quit out and restart app. My phone is a Meizu 15, Android 7.1.1. My trainer is a Tacx Neo. My HRM is a Magene MHR10.

(😺🐾) #2

I have this problem too, but for me only my cadence sensors don’t re-connect. I have both Wahoo RPM cadence and a cheap Magene sensor. Phone is Sony XZ Premium.

(Annabel) #3

This seems to becoming an issue wiith more riders, certainly sounds like my issue as well

(Michal) #4

I have Google Pixel 2 XL smartphone and there are problems with bluetooth connections too.
I had to delete Tacx from bluetooth devices list several times to get it work properly. It was seen by a application but there were no watts- “–W”.
Another thing is i can’t exit from application. There is no such a button.

(Mike) #5

I experienced this as well - if the Tacx is paired in the Android phone OS under Bluetooth - then it’s not picked up by Zwift. Why was it paired - in my case, I paired it manually, in the vain hopes my Tacx would connect and I wouldn’t have to quit my ride
and start again. Alas, it did not work, and so next time in Zwift it would not detect the Tacx.

And yes, there’s no button to quit Zwift, which is no good. I too have to force quit the app, because, as you say, there is no other way of quitting it.

(Filipe) #6

(Offensive Language Removed) piece of software, it drives me nuts, me and my wife pay EACH a fkkkkkk subscription for a premium product that doesn’t deliver. It’s incredible the disrespect to the customer! We plan our ride, commit time and effort and in the end it’s ruined. Bluetooth drop, it won’t reconnect, it doesnt recognize my DUAL-HRM from Garmin, I have to use another brand, but the problems don’t stop there. My ELITE Direto sometimes works, then it drops, then its the HRM. We’re playing and making fun of peoples lifes, time and money.

(Gerrie Delport TeamODZ) #7

@fduarte: glad you got that out of your system.
You will notice that Android is supported as a Beta release, if you are not satisfied with Zwift on Android then try it on one of the many other platforms (IOs, MAC and Windows), I have been on Windows since January 2016 and can count the number of issues on one hand (l think it was 3 and one of them was when we had a power outage :blush: ).

2 Likes
(Filipe) #8

So if I want to solve my problems I shouldn’t complain here, just change my other platforms? “Go somewhere else, leave us alone” kinda thing?
Other platforms have the exact same problems, I was one the phone with a friend of mine 5 mins ago, who uses IOS and he is as frustrated as me with the constant drops, unable to reconnect, missing rides, tour of watopia such, to top all that we’re treated like zwift is doing us a favor instead of treating us as a customer and trying to solve problems, or at least listening to them.
Funny, I complained on another thread for a specific situation and not even a single reply from the Team whatever from zwift.
Yeah I’m frustrated and I’m sorry it showed up like that, but when you’re coming from work, tired and just want to train and have it ruined it constantly is nerve wrecking.

(Paul) #9

Have you used this document to troubleshoot the issue yet: https://support.zwift.com/my-bluetooth-signal-is-dropping-(cycling)-SJOZRkBm

(Filipe) #10

Thanks for the reply Paul!
I know it’s a zwift app problem because If I open strava or any other software everything is working fine. Is just zwift that simply ignores some, or when it recognizes it, it doesn’t show any data (TICKR example)!
Still I’ll troubleshoot again with that link

1 Like
(zwill) #11

Felipe,
Sorry for the troubles. I hear you; I’m an avid rider and I get frustrated too. I’m also the Android Platform Lead

Can you confirm these screenshots are from the latest version 35415 ?
If so that’s an issue we did not encounter.

Could you try removing the app and re-installing ? We save your most recent devices to local storage, and in reading through your posts it seems you tried 2 different HRMs; I’m wondering if there is some issue there.
Thanks for patience as we sort this out. And yes, Android is in Beta and we have limited resources but we are trying to improve.
-Will

(Filipe) #12

Hello, it’s 35415.
I will reinstall it again to see if it works. Yeap, I have to use my Wahoo HRM because my new Garmin HRM-DUAL (blueetooth ANT+) doesn’t get recognized by Zwift (I’ve tried with no luck). I understand it’s beta - I have to open it and cast it on my TV, so it’s no ideal solution, it freezes there, it has all the digital artifacts, but I can live with it, now sensor drop is really bad.
The last one was after someone tried to call me, but it happens on other situations also.
I’ll keep you posted.

Thanks!!!

(😺🐾) #13

I “think” this is similar to the multi-function HRM (Viiiva, PowerCal) issue with the latest beta since the Garmin HRM-Dual has two simultaneous BLE channels.

(speed) #14

I have same issue as described here. It is on the latest release and i reinstalled the application with no improvement. This should be on top of issues to resolve list as it makes it impossible to use.

(Finn) #15

I get the same issues with the connection dropping out at random times. Sometimes I get through a whole session, sometimes 1 minute. The image shown by @fduarte above is the exact problem I face. That is, it finds the device ok, but shows No Signal, and will not work until I restart my Android device. At the same time I am connected to my Garmin watch and it remains connected with no issues, so clearly a connection issue with the Zwift App.

(Peter) #16

My PowerCal dual BT heart rate monitor no longer works with the latest update.

(Finn) #17

(zwill) #18

Hello Finn, speed, Fellepe, and others:

This “No signal” issue one of our two top issues (multifunction HRM is the other) and we are working on a fix.
The suspend/resume flow was more reliable on older builds, and there were fewer dropouts.
We intend to get this fixed and released in the next week or so. Fix got delayed by other stability fixes.
Thanks for patience as we sort this out.
-Will
PS on a personal note I’m an avid zwifter and this bug sucks! Super annoying. I managed a 1hr ride last night on my note 9 but the whole time I was fearing a phone call or other interruption.
And you are right, you must quit the app; in the past there were some work-arounds like switching Ride/Run in Pairing screen which unpairs all devices. We are on it!

2 Likes
(Mike) #19

Thanks Will!:+1::+1:

(Andrew) #20

I’ve had similar happen to me yesterday. Tacx and heart rate monitor paired perfectly in the Android app and then started ride. About 30 mins called out “ok Google play Spotify”… Instantly the heart rate monitor dropped connection. Tried reconnecting, although it could see it the app refused to pair again. Then (stupidly) turned off blue tooth and turned it back on… Everything then dropped and wouldn’t reconnect. Ended up force quitting. Most annoying was that the app recognised that I was in a ride when I returned but it didn’t hold onto my training stars and tried to force me to start again

1 Like