Bluetooth dropping during ride, won't reconnect without quitting

Hi All,

Last couple of weeks, started experiencing bluetooth dropping out at least once in every ride on Zwift, followed by an inability to reconnect from the menu - the Zwift app claims it is receiving no signal from the trainer or from the cadence sensor. However, if I quit the app, and relaunch, the app connects to the trainer and sensor without any issue.

This is frustrating because (a) for weeks before this, I’ve had no issue whatsoever (and I’ve not changed any of my setup other than keeping iOS and Zwift up-to-date), and (b) in group rides it means I’m instantly dropped from a group, and in workouts progress is interrupted and Zwift resets the workout to the beginning when I rejoin

I’ve tried deleting and reinstalling Zwift, rebooting the iPad, making sure no other apps are running; tried turning off other bluetooth signals (iPhone and AirPods - I don’t use the iPad for music so it can focus on running Zwift).

Has anyone experienced anything similar? Or knows of a solution?

Nick

iOS 14.0.1; Zwift 1.0.56270; UK; Trainer = Saris H3; and I’m in the garage if that is at all relevant!

I hate when sensors disconnect and refuse to reconnect without restarting Zwift. I’m really surprised this is still an issue all these years later.

1 Like

this happens to me on android all the time. sometimes it lets me pair one of the power meters so i can keep riding in the session, but most of the time it’s just a hard stop

1 Like

A couple of update in the vague hope that someone from Zwift might read this:

  1. There seems to glitch in the VFX no more than a second before the bluetooth drops; I get similar glitches at other times, so it might just be coincidental, but I’m starting to be able to predict the dropout on this basis

  2. If I force a bluetooth dropout, by disconnecting the smart trainer’s electrical power, and then plug the trainer back in, Zwift will reestablish the bluetooth connect immediately and seamlessly. Thus it would seem more likely that Zwift is forcing the bluetooth connection to drop out, rather than it being caused externally.

Reseting the iPad to factory defaults (i.e. wiping and setting up as a new iPad, then installing Zwift) doesn’t resolve the problem. Increasingly difficult to see this as anything other than a Zwift bug.

1 Like

It could be some sort of radio interference. I know you said that you’ve switched off other Bluetooth devices, but there are a lot of other types of devices that use the same 2.4 GHz band - microwaves, video senders, baby monitors, etc.

Yep. I’m wondering about this. Maybe the neighbours have just bought a new microwave? Some advice has been to try switching the wifi to 5GHz (I’m getting a wifi extender so the 5GHz actually reaches the garage). I’ll try moving the trainer around - maybe even a couple of metres might help.

I get this on android - only the trainer will drop out, heart rate monitor and power meter contiue to be connected so not the devices bluetooth dropping.

Then trainer won’t reconnect, force close and relaunch and everything pairs again which suggests it isn’t a problem with the trainer’s bluetooth.

my guess is the connection drops briefly and then zwift doesn’t reconnect.

last time it happened I left zwift open but with the trainer disconnected and tried to find the trainer in a different app on my phone but it wasn’t showing which seems to suggest that the connection is still there with zwift somehow but not showing as paired. force close zwift and the trainer appears again.

especially annoying when half way on a route to get a badge.

I have had this on various different android devices so not device specific and on different trainers so not trainer specific either. Something is dodgy with the way Zwift connects via bluetooth.

1 Like

I couldn’t pair either of my sensors at all today, spent 2 hours with no success. WiFi signal was strong, sensors have good batteries in them. Had companion running on phone as a bridge. WIFI signal booster fitted to increase signal and ant+ dongle but still couldn’t pair. Zwift is so erratic and unreliable, can’t believe I’m still paying for something I’m rarely able to use

Hi @Richard_Copping_That

Welcome to the forum .

What system do you use for Zwift.

That may be the problem WiFi and ANT+ run on the same frequency range.

Windows 10 on my laptop

Same problem in the last few weeks with new Saris H3 trainer, no previous problems with my wahoo Kicker snap? Seriously considering switching to another VR app. Any suggestions anyone?

1 Like

[[quote=“Gerrie_Delport, post:10, topic:509174, full:true”]
Hi @Richard_Copping_That

Welcome to the forum .

What system do you use for Zwift.

That may be the problem WiFi and ANT+ run on the same frequency range.
[/quote]
@Gerrie_Delport

quote=“Gerrie_Delport, post:10, topic:509174”]
That may be the problem WiFi and ANT+ run on the same frequency range.
[/quote]

Is there a way to fix this ?

I have an H3 and a Wahoo TICKR and they were connecting OK but this morning was a complete mess destroying my workout. After some research I found a Youtube video commenting that ANT+ can get overloaded in Zwift so I unpaired all sensors then put the HRM and Cadence using Bluetooth and Power and Control (FE-C) on ANT+.

I then did a 25min test Zwift ride and it went without issue. The HRM never dropped and when I changed gears the Power had only minor fluctuation. At least in this first test I saw significant improvements by splitting the data streams between Bluetooth and ANT+.
The following are the YouTube video titles as I can’t include links.

  • This video indicates that ANT+ is being overloaded when used for all sensors
    “EASY FIX FOR POWER DROP OUT ON ZWIFT”
  • She changes to a mixture of ANT+ (HRM and Control (FE-C)) and Power source/Cadence to Bluetooth
  • “Zwift Dropouts - Details How to Solve”
    • Basically the same as GPLama but this guys issue was his WiFi router
    • He suggests running Task Manager Performance Tab (overlaying Zwift) to check CPU/GPU load
  • He suggests backing off on resolution 1080p->720p or even lower
  • “ANT+ Troubleshooting 101 - How to Stop Smart Trainer Dropouts”
    ShaneMiller-GPLama

Good Luck

Nick,

I am having the same Bluetooth dropout issues as you…just started happening over the last three days. I use a Saris H3 trainer with IPad (iOS 14.0.1), Swift version 1.0.56501, and Zwift Companion app on Pixel 2 phone (Android 13.0). I have had Bluetooth disconnects on group and solo rides each of the last three days. I even tried turning off the Bluetooth on the phone but still got disconnected. To resolve each time I unplugged the trainer, then plugged back in, and was able to re-pair with the trainer. Never shut down the Zwift app but had to quit the ride and save and then start again…sometimes being able to rejoin the group ride. Not sure what is causing the disconnects but it’s very frustrating and I hadn’t had any issues like this since I bought the H3 trainer a year ago.

I haven’t been on the bike a few days (heavy cold), but I did have two rides where it stopped happening. In case this is of any use to anyone (and not just coincidence) what I did was (a) get hold of a wifi extender so the 5Ghz signal could reach the garage, and connect my iPad to that (rather than the 2.5Ghz bad that is shared by Bluetooth) - I had successful group ride without bluetooth dropout. (b) second ride, extender had stopped working for some reason, so I was back on 2.5Ghz wifi. Managed a group ride without a dropout. Now maybe this ~was~ just coincidence, or maybe something changed, or maybe I just lucked out with a stronger 2.5Ghz wifi signal that time. I’ll need to run some more trials (attempted Zwift sessions) to see, but I need to kick this cold first.

Same issue here.
Trainer Saris H3 Zwift running on Win10 Laptop connected via Bluetooth.

Zwift lags for about 1 second then drops connection to the trainer. Given up with Zwift and swapped to Trainer Road. No connection/drop out issues. The issue is with Zwift

Have you tried ANT+ it is a lot more stable than the built in Bluetooth in a laptop.

Hey, yes ordered an ant+ Dongle and tested it today. It dropped out even more often then using Bluetooth. Raised a support request but not heard anything back.

There must be some interface in the 2.4Ghz spectrum.

Maybe a WiFi router?