Android Beta: Two devices connecting over Bluetooth


(Jon Andrew) #1

I’ve got a Stages power meter. I thought I would try getting Zwift to connect to the Stages Power Meter over BLE, while remaining connected to the Elite Direto for the controllable trainer and cadence. Couldn’t be done. As soon as I got the Stages power meter recognised, Zwift claimed no signal from the Direto. I knew the Direto was working fine, as I had just completed a workout.

Once I paired the Direto back for the Power Meter, all was fine again, and Zwift stopped claiming no signal from the Direto.

Not a big issue for me, possibly for others who want a consistent power reading between on the road and their Zwift sessions.


(Vincent W.) #2

Hey thanks for the details Jon! Was the Direto unpairing straight from the pairing screen, or did you not notice until you started a ride?


(Johann Griesel) #3

Not sure if this is related, but I recently did the update and tried a workout last night.
Suunto Smart Sensor connected (No Issues)
Wattbike Pro Power connected (No Issues)
Wahoo Cadence Sensor was connected, but kept on fluctuating between the correct Cadence and 1 every sec.

Been using this setup with Android Beta since day one and never experienced this. I know you can only have 1 Bluetooth connection to a device. So if you connect to the Wattbike, you either have to choose Power or Speed/Cadence. Hence I use the Wahoo Cadence sensor.

Rebooted my phone as well, but had the same effect. WIFI was also turned off, just to ensure I don’t have anything else that could interfere.

Will do another workout this afternoon and feedback.


(Jon Andrew) #4

Vincent, the Direto was unpairing at the at pairing/set up screen - next to ‘Controllable trainer’ & ‘cadence’ it was saying “no signal”


(Henk de Beer) #5

I have the same problem, using a Tacx Vortex and (attempting to use) P1 pedals.
Starting with the Vortex being the source for Cadence and power and controllable, as soon as I select the P1 (left) as the power source, I get the same No Signal for the Vortex.
If I change it back to the Vortex, the message goes away.
If I deselect the Vortex as the controllable, the pedals report power (although it jumps around like mad as it is the left side only).

I’d like to use the pedals as power source, as the Vortex reads higher than the pedals. It reads a bit low at very easy watts, roughly the same at 130-ish, but by the time I hit 200W on a climb (according to the pedals, displayed on my Lezyne GPS) the Vortex reads high by 20-30W, and more when doing the ZA intervals.


(Andrew Shevel) #6

I had the same problem with connecting more than 2 BLE devices at once. But with the last zwift app version upgrade (1.0.29500) this issue was resolved an my Huawei MediaPad M3 and I can connect 4iiii powermeter, Tacx Bushido smart trainer and BLE HRM at once and ride with no “No signal” problem.


(Henk de Beer) #7

Oddly, my Tickr heart-rate strap has no issues connecting at the same time as the trainer. Just if I want to use the P1 pedals as the power source or cadence. Unfortunately my separate speed/cadence sensor is ANT+ only, and I don’t believe the beta works with ANT+ yet.


(Vincent W.) #8

Hmm thanks for the details Henk! Are the P1 pedals the only device that unpair? Also if you don’t mind could you relay this to beta@zwift.com? We’ll have our Android team take a look at this.


(Henk de Beer) #9

I’ll see if I can make a screenshot tonight, and will send it to the email address.
(Watch it work perfectly now :wink: )


(Henk de Beer) #10

So, as luck would have it, tonight connecting to the P1 pedals worked, without getting the No Signal message on the other sensors. Of course it is still not very useful, since it is only the left (or right) pedal so the reported watts jump up around.
But that is a different issue from the number of devices thing.

I did take some screenshots anyway, and will send on anything relevant.


(Vincent W.) #11

I see, thank you for following up Henk!

Sounds like most of the unpairings are trainers disconnecting from controllable. We’ll investigate on our side, thanks again.


(Anabolic Sufi) #12

Have a similar issue when having both Garmin v3s and Cyclops hammer connected, the hammer says no signal and disappears all together.


(Matt Litwin) #13

Something interesting here i’d love to understand further and a similar situation to the wattbike combo.

I have a kickr and Quarq Dfour which provides power/cadence. Using the Companion app, i’d like to connect the kickr for controllable and the Quarq for power and cadence. Is this possible? I’ve been having dropouts with the PM left and right but the kickr is rock solid. Is it not possible to transmit both cadence and Power from the quarq via BT eventhough it’s the same connection? And is that what is causing the drops?


(Athir Ayoub) #14

Similar issue here. I had 6 rides on Zwift for Android using my Pixel 2 XL paired with a Tacx Flow Smart trainer and Wahoo Tickr HRM… not a single issue. Yesterday I got my Stryd foot pod and tried my first run on Zwift using the same Pixel 2 XL and HRM… flawless as well.

Today, I tried to start another cycling session but Zwift immediately selected my Stryd pod as the power and cadence source, even after I switched to the Bike activity. My Tacx Flow trainer wasn’t available for selection for Power, Cadence, or Controllable. I think this is a Zwift issue because I was able to connect to my trainer from the Tacx utility app (on the same phone) while Zwift was excluding it from selection. Based on what I’m seeing on this thread, I think Zwift for Android chokes when there are multiple power sources available… especially if one of them happens to be a foot pod as it prevents any further cycling activity… which really sucks when you’re standing there in your bib shorts ready to go :frowning:.

I ended up having to get my laptop out to get a ride in, which I had just put away thinking Zwift for Android was a solid performer… guess it needs a little more work.

If there’s anything I can provide to help troubleshoot this, let me know.

Thanks,
Athir


(Mitch Schrader) #15

I have same problem. Speed and candince wahoo. Will only read one or the other. Rider will not ride if just on candince, but will show candince. Rider will ride with speed but no candince reading.


(Christopher Weis) #16

@Mitch_Schrader - exact same situation for me today. Brand new Wahoo speed and cadence devices and new app install on OnePlus 6T.


(Mitch Schrader) #17

I have just been riding with the speed sensor. Hopefully Zwift will fix soon.


(Vincent W.) #18

Hey @Athir_Ayoub @Mitch_Schrader @ccweis I’m looking into this with our Android team. Thanks for the details!

Edit: @Athir_Ayoub if you take your Stryd foot pods away from the room where you are trying to connect Zwift, are you able to pair to your trainer?
And after you select Ride, have you tried restarting Zwift to see if it automatically selects Ride again with your Tacx trainer pairing?


(Athir Ayoub) #19

Thanks Vincent. Yes, as there’s no way to turn the Stryd footpod off, I had to “hide” it from my phone at the other end of the house… in a metal filing cabinet :blush:. All that did was cause the Stryd to disappear from the list of devices I could select for power… my Tacx flow never reappeared.

What did work was going to app info, selecting Storage, and then Clear Storage. This effectively reset the entire app, and once I logged in again, I was immediately able to select my Tacx Flow for Power, Cadence, and Controllable (even with the Stryd pod in range), and was able to go for a ride without any issues.

Unfortunately the next time I signed in and ran using my Stryd pod for the running sensor, the same issue occurred… I wasn’t able to select my Tacx Flow trainer for cycling anymore.

If I didn’t have to recalibrate my Stryd footpod after clearing my app data, this would’ve been a tolerable work-around… but recalibrating just adds too much time/tinkering before each run.

Because I alternate between running and cycling day to day, I’m now back to using my windows laptop for cycling sessions and my Pixel 2 XL for running. I’d prefer to use my phone for everything, so please let me know once this is resolved.

Note, I sold my Tacx Flow this afternoon and my Tacx Flux S should be arriving over the next couple days. I’ll let you know if I have the same issue with that trainer.

Thanks again for looking into this,
Athir