Connected, no signal

I’ve come on here as I’m getting really frustrated and I’m about to give up on Zwift, can someone please help. I can’t get past Connected, No Signal

Current set up:
Wheel on trainer
Samsung S10
Macbook Pro (have also tried with my iMac)
ZC Bluetooth (updated)
Garmin 2 speed and Cadence
Garmin dual HRM
Same wifi network

I used to be able to Zwift with some success using my old Ant+ sensors but they kept dropping so I changed to Bluetooth and now I feel I’m in a worse place then before. Everything seems to work fine with my Garmin device which is off, when I’m trying to Zwift.

I really want this to work and I’m very temped to by a direct drive smart trainer (when in stock) but these connection issues are putting me off.

Any suggestions?

@Chris_Bowman, which BT connection method are you trying to use? Are you connecting your Macbook Pro direct to the devices via the native BT in the computer or using connection through the Companion app?

Which wheel on trainer are you using? I’m running a Wahoo Kickr Snap and eventually got it working.

I’m not an Apple guy, I run a PC, so I can’t speak with Macbook experience. Sharing what I’ve learned in fighting these problems with a PC at least, I’d suggest trying whichever connection method you are not using and see if that helps. Also try downloading the full Zwift app onto your S10 and see if that can connect without the Macbook involved at all. Not a good screen to enjoy Zwift on, so not a long term solution, but it will at least give us info on what works and not to try next steps. I use an S10e and it worked which led me to more ideas of where to go next.

In the end I was able to get everything stable using an ANT+ dongle (ANSELF) on a USB extension cable. If you have that option with your Macbook I’d recommend picking up that dongle from Amazon along with an Amazon Basics USB extension cable and see if it all works. If not, they can be returned, going to ANT+ on the extensions has been great on my PC.

@Joel_Larner thanks for your assistance.

I’m connecting through sensors for a wheel on ride.

Presently trying to use Bluetooth via the Zwift Companion app. Will give it a try on my phone as a work around and update the thread.

I have an Ant+ dongle and USB extension but they aren’t even registering now and they kept on dropping off in the first place hence the upgrades to Garmin 2 sensors.

Any other ideas?


@Chris_Bowman, sounds like you are trying the right things.

One point of clarification, you mention using sensors for “a wheel on ride”. Wheel on trainers exist in both Smart and not smart. i.e. a trainer whose resistence is controlled by Zwift vs not. I’m interpreting your words to mean you do not have a Smart trainer, thus not trying to connect Zwift to the trainer, just the speed, cadence, and HRM correct? Assuming so, what you are doing to get just the basic connections working before buying a Smart trainer (could be wheel on or wheel off, depending on the device you choose) is a good approach.

You mention you have an ANT+ dongle but sounds like it is not getting quality connection. Not all ANT+ dongles are the same. One would think it is a simple device, what could be different. But that is far from the truth. I started out with a CYCPLUS ANT+ dongle and it did as you describe at the start of this thread. It might connect but then I got “No Signal” and it dropped connection a lot. I returned that one to Amazon and bought the ANSELF ANT+ dongle by the recommendation of others on the forum and ZwiftInsider. It is rock solid. That could be another thing to try. Snag an ANSELF dongle from Amazon and a good grounded extension cable (see the recommendations on ZwiftInsider. com). That may just solve your problem as it did for me.

Same issue here. I haven’t changed anything on my set up that I have been using for years now. CONNECTED but NO SIGNAL.
I’m getting really tired of having to find new work through just to get this software working.
How about a fix for this ZWIFT?
Super frustrating.

It isn’t happening on any other cycling app or software.