Connected but no signal ANT+ mac

Hi,

I am using Zwift on a MacBook air with the Garmin ant+ stick through a USB dongle. I am running Mac OSX 10.15.1 (19B88) and the latest Zwift version.

Every time I start up Zwift I can connect all my sensors (speed, cadence, heart rate). But then within a matter of minutes, they all say “No signal”.

I read a lot of support articles having similar issues but none of them solved it for me. So far I have.

  • Turned off my Garmin forerunner 945, I figured this might conflict with the ANT+ stick.
  • Reinstalled Zwift and restarted my computer
  • Reinstalled Zwift, deleted all Zwift files and restarted computer
  • Switched my wifi network to start broadcasting over channel 6. I read somewhere channel 9 to 12 might conflict with the ant+ channels

Update

  • Also replaced the batteries in my sensors (did not fix the issue)

Any help would be much appreciated, as I am about to give up and look into other tools like trainer road.

Thanks

:thinking:
Try a different USB port on your laptop?
Use a USB extension cable to get the dongle closer to your sensors?

:man_shrugging:

2 Likes

Thanks for the tip, but unfortunately tried that already.

I just confirmed all sensors are working normally by using a different laptop.
My latest guess is that it has something to do with the USB C adapter I am using.

What brand / model are your speed & cadence sensors?

Do you know if they transmit only in ANT+, or are they capable of using Bluetooth LE? If they are BLE capable, you might try connecting them to your laptop using BLE instead of the ANT+ stick.

Anyone had any resolution to this? I have the same problem. Got new Macbook pro, so same sensors, same ant+ dongle, same trainer, same environment only difference is a new model of Macbook and an official apple USB C adaptor. Bluetooth works on its own, Ant+ works on its own, but everything falls apart if try to connect sensors using different protocols. Tried all the steps mentioned in original post too without much luck, a laptop restart worked once but continue to have difficulties 90% of the time.

Try turning off Bluetooth on your Mac when using ANT+ to connect to Zwift. I have read multiple reports of the two working well but as soon as someone tries to connect devices using both ANT+ and BT at the same time the ANT+ suffers.

@mike_morris As @Bob_Gorman_Splunk_65 recommends, turn off Bluetooth on your MacBook. I can use one or the other on my MacBook, but if I have them both on sometimes things are okay, but usually not. Even trying to listen to music over Bluetooth will often result in Zwift issues. My solution was to listen to music using my phone instead. I think it’s not so much a Zwift problem but perhaps a problem w/the laptop design resulting in some signal interference at/in the laptop :man_shrugging:

Is there a specific reason you are trying to connect some devices/sensors via ANT+ and some via Bluetooth?

@Lin_Alan main reason is my garmin heart rate monitor only supports ant+, the zwift footpod only supports Bluetooth. My turbo trainer supports both. So it’s really the heart rate monitor that drives my need for both. I see that the newer garmin hrm supports BLE now, so might be time for an upgrade.