Cant pair Garmin ANT stick

cant-pair

(Jan Barborik) #1

Please help me, Im helpless. I have Garmin 935, speed & cadence sensors, HR belt and Garmin USB ANT Stick. I never use Zwift before (but I really want!!!) and I have problem with first setting up. I bought ANT Stick especially to can ride with Zwift.

My MacBook Pro cant see ANT (correctly plugged to USB - tried both ports) and there is some warning on Zwitf (screenshot here: https://ibb.co/J7yXVHq ) nor Garmin Express cannot dettect it. What Im doing bad? It should be plug&play. Or should ANT Stick be connected to USB port via a USB cable?

I have MacBook Pro (2015) with OS Mojave.

Thank you for your help guys…


(Lin Alan) #2

Hi,

I haven’t used Zwift on my MacBook in a long time, but seem to remember a similar issue resulting from having Bluetooth on while trying to pair via ANT+. I could be wrong, but it is simple enough for you to try.

  1. Turn off Bluetooth on your MacBook Pro.
  2. Make sure the ANT+ dongle is firmly plugged in. I highly recommend a USB extension cable to minimize any possible signal issues.
  3. Restart the Zwift app.

Hopefully, you should be able to pair and get started.


(Jan Barborik) #3

Thank you - I tried it, but still same. I tried install Zwift to my wifes Macbook Air - another notebook, but same problem.
I try to buy extension cable…give me few minutes, running to the shop. :slight_smile:


(Lin Alan) #4

Okay…

You made me curious, so I tested with my MacBook Pro (also 2015 w/Mojave) With Bluetooth enabled, ANT+ had no problem pairing as shown below. Also note both the ANT and Bluetooth icons are radiating rings.

Since you tried two different MacBooks, the next best suspect is the USB dongle. What USB dongle are you using? Have you used it before? Are you sure it works?


(Jan Barborik) #5

Yessss!!! I bought USB cable and IT WORKS!!!

Thank you Lin! You saved me.


(Lin Alan) #6

Great to hear! Odd that it didn’t work without the cable. Maybe it doesn’t fit/sit quite right in the USB port and the extension cable does. Whatever, it’s working now :+1:


(Jan Barborik) #7

Its weird, but with cable it works perfectly. See you on track :wink: :biking_man: