Garmin Speed Sensor -- tried everything -- 0 MPH

Hey all,
I have been using Zwift for over a year successfully with Garmin Speed and Cadence 2 and a 27" iMac with an ANT sensor on a USB ext cable. Old classic trainer. I usually have the iPhone app running as well.
All of a sudden the speed sensor connects but does not register any speed (0 mph). Battery is new. I have tried restarting everything, re-pairing, turning off bluetooth on devices nearby, pulling the sensor battery, disconnecting/reconnecting the ANT sensor and cable. No joy. Any ideas?

Maybe the ANT dongle died, can you try bluetooth, does the sensor support it? Or the extension cable? Try without.

Other things can interfere with ANT signal too like fans and microwaves.

Thanks Mike. Same symptoms without the ANT sensor connected. Zwift pairs the Speed Sensor but just reads 0mph. Did not have the fan on and there are no other devices within 30 ft. Since it worked perfectly for months I am thinking the sensor may be faulty.

Time to upgrade to a smart trainer :wink:

Have you already tried pairing it to a different device running Zwift or pairing it via the Companion app as a bridge? I wasn’t sure what you meant by “I usually have the iPhone app running as well.” - do you mean the Companion app? Before concluding that the sensor is faulty, I would want to pair it with (1) the Companion app bridged to Zwift, (2) Zwift on a different device, and (3) some app other than Zwift.

Thanks Paul,

Yes I am using the companion app. And yes I tried it on a MacBook Pro. Same behavior.

One last thing to try since I didn’t read that you had done this - reset the sensor by inserting the battery backwards (or short the + & - terminals) for a good 20 seconds, then re-insert correctly. It’s an old Garmin process that I need to do only on my speed sensors when replacing batteries. I’d also delete your /documents/zwift/knowndevices.xml file before firing up Zwift (it completely removes all pairings and lets you start that process fresh).

Given you get a connection, not sure that this will succeed but worth a shot.

Note I dont use these sensors with Zwift, only directly with Garmin head unit/watch but effectively have similar issues with all 4 of them and dont with any other Garmin sensor.

The first time we tried to use Zwift with my wife’s Garmin sensors, I paired the sensors and selected the proper dumb trainer from the list…and nothing, no speed, no cadence. When I selected another trainer from the list (the wrong trainer but nevermind that), suddenly they were working.

So…I have no idea why that made a difference in our case, but it did. We’re now using a power broadcasting dumb trainer, so I haven’t revisited this issue. But it’s worth a shot–select a different trainer from the dumb trainer list and see what happens.

Sometimes speed sensors just die. Most use a reed switch (a bendy bit of metal that bends each time the magnet passes) and sometimes the switch just breaks. You’d need to try pairing it to another device/program and see if you get a speed reading that way. If not then the problem is most likely the speed sensor itself.

Thanks all. Flipping the battery for 30 sec seems to have worked.