New Zwift Hub - no power, cadence, speed data

After six years away from zwift, the idea of the zwift hub got me back in the saddle.

Or so I hoped.

Took delivery of the Zwift Hub yesterday, updated the firmware and today was going to be my first day riding in over five years - so I’m hoping someone will tell me I’m doing something wrong.

Have reported this to support but yet to get a reply:

Can see the zwift hub on Win 11 (64bit) via both bluetooth and ANT+, can also see it via bluetooth on a Samsung Note 10+ when using companion to pair (it updated firmware fine to v3.9)

But all values read 0 when starting a ride.

Despite it saying I had 25km of trial and until 1st Nov to do this I thought it could be, as per the support page, my very lapsed membership. So I’ve also renewed that and payment has been taken, with the 25km trial having now disappeared (?!) - but still no data via any connection method.

Device Specs are:
PC: Win11 AMD Ryzen 5700G 32GB - finds Hub via ANT+ & BT, no data (but ANT+ HRM is fine)
LT: Win11 MSI Intel i7 7700K 32GB / GTX1060 - finds Hub via ANT+ & BT, no data (again ANT+ HRM okay)
MP: Android Samsung Note10+ (fully updated) - finds Hub via BT and performed Firmware update

Oh - and I can link my Garmin HRM to the Hub just fine, with HRM data being received into the Windows App.

Any help/comments are appreciated - this was going to be my first step back to fitness and has been quite a kick in the undercarriage.

Ride On
Kev

Hi @KevSp

It sound like the HUB is connected to multiple apps.

1 Like

Hi @Gerrie_Delport_ODZ

I’m making sure to only connect to one application - all other devices are powered off (so only the LT or the PC have power)

Each test has been following a full restart of the devices - both the windows PC (or LT) and the Zwift Hub - each power up of the Hub goes through the colour cycles and flashes blue before a solid blue when I connect to the windows app.

Even tried it with BT turned off on the phone in case that was it - still nothing

Do you have the option to turn Bluetooth off on the PC. Try using only ANT+ that is the easiest.

1 Like

Good call - the one combination I hadn’t tried

one moment caller …

Unfortunately nothing there either.

Can pair Power Source, Cadence and ‘Controllable’ all as ‘Zwift Hub 22nnn’ devices but showing 0 watts / 0 rpm in the devices screen.

Just in case I needed to be in a ride, tried that as well and just stood at the side of the road on the 5.3km volcano circuit (I was starting off easy)

Oh - and BT was disabled in Settings and then the device disabled in Device Manager

This sound very strange.

Do you have a bike computer that you can use to test the power reading.

1 Like

Unfortunately no - well yes and I remember updating the firmware on it about a year ago - but we’ve decorated since then and …

Temporary replacement coming tomorrow via Amazon Prime - hopefully it can read the ANT+ data but I honestly think it isn’t doing anything, there’s no resistance on the flywheel when it is powered on (but not sure if that’s normal until a ride is selected).

At least (maybe) I could go out for a little ride once the computer arrives until Zwift get back in touch.

1 Like

When you say you can see it in Windows, are you connecting to Windows bluetooth on a system level, or are you just starting up Zwift and letting it connect in the pairing screen?

Can you post a screen shot of the pairing screen?

1 Like

Hi @Mike_Rowe1

Everything was via the Zwift App, nothing (apart from the test disabling BT) was done at a Windows level on either machine.

Paired [BT] on startup:

Pairing [BT] options (I also bought a Runn which is in the garage):

Pairing [ANT+] added:

And thanks to everyone/anyone that has looked at this thread.

and for completeness - PC BT disabled and ANT+ removed, pairing via Android Companion App:

strange that there isn’t an FE-C option for ANT+?

If you click on the gear icon in the upper right corner of the pairing screen, what option is selected?

1 Like

For the first three images it was local bluetooth, for the last image it was companion app

The Cadence and Controllable auto-populated when selecting the power source - via both the windows zwift app and the android companion app

I’m currently ‘watching’ and monitoring the zwift logs, all server comms seem okay so I’ll connect up the hub again in a mo’ and see if there are any errors.

Have you tried unpairing the Hub with all but one device? I.E. if you have it paired with both a PC and a LT, have one of them forget it. Same for any tablets. Even if the power or BT is off on a device, I’ve seen BT devices struggle that way. When I got my Saris H3 not too long ago, I paired it with the Saris app on my phone first. Then, with the phone’s BT turned off, I went to pair it to other apps on my LT (Rouvy and Zwift). No joy. I had to turn the phone’s BT back on and unpair the H3 from the phone Saris app first. H3 then paired with LT software right away.

And no, I can’t explain it :slight_smile:

1 Like

Hi @Tom_J

I ended up with everything turned off - router wifi (pc hardwired to the router anyway), the mesh discs, mobile phone powered-down and only device on being my PC - still the same thing. Then did this again with just the laptop on, same result.

Just seems it isn’t attempting to control the flywheel (or read any data from it)

With my luck I’ll have the only faulty one out of the enter shipment - not so sure it’s nice back doing ‘desk-side’ troubleshooting, I thought I’d progressed past that to server engineer years ago :smiley:

sounds like you might have a lemon.

You could try doing a free trial of Wahoo RGT or Rouvy to see it works at all with other platforms?

1 Like

Now there’s an idea (thank you) - right, I’m off for more downloads

Didn’t have this problem with the wattbike, that was working fine in 2016 on Watopia before I broke myself MTBing in Scotland

Technology eh … who’d have it :wink:

I’ll have to add this here as I’ve apparently reached a posting limit today
Well that’s a bust on Wahoo- 0w recorded via ANT+
image

BT

Nowt from both - guess I’ll be using the turbo until Zwift Support sort something out.

1 Like

But did you unpair everything? What I’m saying is that my experience with the H3 (and I’ve seen it a few rare times in the past with things like BT headphones even) is that the item (Hub in this case) needs to be unpaired from other devices. Again, I don’t know why it’s worked in the past–if my phone is off or the phone’s BT is off, whether it’s paired with my H3 shouldn’t matter. But it has. As soon as I unpaired the H3 from the phone/app, it was able to work fine with Rouvy and Zwift on my laptop. No other changes had been made.

(Edit: in other words, the H3 being paired with a power-off device was preventing it from pairing with another device properly.)

So I’m saying not to just power everything else off, but to power those other devices on just long enough to unpair the Hub from all of them (go into the BT settings and make them Forget the Hub). Then try with Zwift on just one device.

Not saying the odds of that working are high. But it’s literally what I had to do.

2 Likes

And the fact above that you also did try powering everything else off means that this isn’t likely the culprit–but BT can be interrupted by signals from lots of other things. If you have a smart fridge around the corner sending out signals, something like that could interfere. Even a pair of BT headphones. But powering all that stuff down like you did makes that unlikely.

1 Like