Zwift Hub No Data Showing

I’ve had this problem for the last couple of months. I have a Zwift Hub, using Bluetooth to connect , including a HR monitor. I use the app on Apple TV.
Everything worked fine for months, nothing has changed but now when I turn it on, the hub and the HR monitor connect but show no data , watts , cadence etc. If I start a ride still no data.
The only fix I have found is to delete the Zwift app, reinstall and then it will work as normal. But the next ride , no data as before.
Any ideas?



Hi @Steve_Watson4264, welcome to Forums. It’s Juan here from Zwift. I appreciate you taking ownership of this space to get support from our community.

I take a look at your game logs to get an idea of what’s going on. I noticed that you haven’t experienced many problems with your Bluetooth connection recently. Maybe because of the solution you mentioned about deleting and reinstalling the app.

However, I see that you were experiencing connectivity alerts coming from your devices (HRM and Zwift Hub) caused by Bluetooth disconnections that occurred more frequently in February. It is difficult to identify Bluetooth interruptions. I would like to suggest that you consult this article to rule out causes and isolate a possible root.

If the issue persists, the best way forward would be to contact us to provide you one-on-one assistance. We will be happy to help.

1 Like