Heart rate monitor - dropouts

Hello all,
My otherwise very reliable heart rate monitor (myzone Bluetooth) has been very spotty on Zwift of late. The other connections seem fine. I also tried my old polar one and that too was erratic.
Pretty at a loss of what do aside paying for another one which may have the same issues.

What device are you running Zwift on and have you tried bridging using ZCA to see if that helps?

1 Like

Thanks for replying.
I am using a window 10 pc with a Bluetooth dongle.
What is a ZCA?

Zwift Companion App

If you use this to bridge your HR it might help diagnose the issue.

1 Like

Of course sorry caught out by the acronym!
I’ll try that on my next session.

Excellent, tested tethering to the phone and got a much more stable connection for HRM.

Awesome, great.

I have seen this since 1.52 on AppleTV. Today since 1.53 HR dropout even more frequent. Starts with a value then two dashes same black font then HR greys out. If greyed out more than 30s it displays “lost connection”. Eventually HR reconnects and starts all over again. I can try ZA pairing though I prefer the issue is resolved to use the AppleTV BY connections.

I too have noticed frequent HR dropouts on my AppleTV running Zwift. It started in the last update, and prior to that was rock solid. Using direct BT connect also from a Wahoo Tickr

I have the same problem.
First some dropouts, but the last week no HR data at all.

I can connect the Tickr, it works fine with KickrClimb, but no data on Zwift.

Using the app on iPhone/iPad works fine.

Have to be a problem with the AppleTV app as far as I have figured out.

Anyone who knows the problem and if it’s fixable?

1 Like

Force-closing the Apple TV app after every ride is a common resolution. Try that. This is a typical problem with Zwift on Apple TV.

I force close AppleTV after every ride. That has not solved the issue. I used three different HRMs (Wahoo, Garmin and Magene) all drop out with same frequency. They do stay connected if I pair through CA. That isn’t a satisfactory solution though. This has been going on since 1.52.

Same issue here. Apple TV 4k wil everything updated.
Wahoo tickr x, tickr ver 1, and tickr ver 2 won’t connect to Apple TV directly.
Will connect but not display any HR, then repeatedly drops out.
Connecting via Companion App is rock solid.
HR’s connect to other apps fine, definitely an Apple TV issue since 1.52.
Hard restart of Apple TV does not help.

Is this a know issue?

I did a factory reset of my AppleTV for a different issue. I still had the HR dropouts intermittently. At 60km all sensors disconnected. That had also happened a few times before I began using the CA bridge. Is there any word on a resolution? I prefer to not have to pair through my phone, I’m one of those guys that doesn’t remember to charge the phone.