No power to Zwift Hub

Just got the unit on Thursday and rode through the introduction and then another easy 30 minutes. Last night I updated the firmware, warmed up, did a spin-down calibration and then a ramp test. After the ramp I wanted to cool down, but there was no connectivity. When I looked at the unit, the (formerly) blue LED was not on. I did all of the troubleshooting in the book and on the web, and it looks like I am getting no power to the unit. (Yes, I checked all cables for connections and both outlets that I used.) The Hub was a little hot after my ramp, but my score was woefully low so I can’t imagine that is an issue. Even after an overnight, nuthin!

Tried to chat and contact tech support, but nothing. An “Ambassador” said that were escalating my claim, but still no response a day later.

  1. Is tech support just not going to get back to me until Monday at the earliest? Is there a way to expedite the process?

  2. Anyone have similar problems and/or solutions?

Thanks, Zwifters!