Multiple badges still not working

It can be that the I pad did not close the connection to Zwift. Uninstall Zwift from the Ipad. and just use the PC.

1 Like

Hmmm… that could be the issue. Power off the iPad, and maybe that will close out any open sessions.

1 Like

Cheers, will try that on a short course tomorrow.

1 Like

I did that on Everything Bagel. . . Got the route badge a few weeks before I selected it to {try} and get the route badge, and was rather miffed when I didn’t get the badge notification banner after crossing the last banner, only to check and see I already had it.

Thanks guys, looks like that might have been the problem, I made sure that the iPad was not logged on to Zwift and the badges are now showing up correctly.


Today, I rode 97km, but I couldn’t get the badge because I couldn’t go to volcano kom. I was disappointed this and my legs hurt. I am so sad.

I road three sisters 97km to get the badge, but I could not get that. Also, I have been injured my legs.

You are set to private so no one can see your ride. Did you select the route and then ride it without and manual turns or uturns? Did the route banner come up l say you completed it? Does the badge show up on the ride summary on either your companion app or the zwift website?

Thank you for your reply. In my opinion, my case is bug because I couldn’t go to the volcano comb. Therefore I must not get the badge. I am going to try to get the badge now without work out, and I am going to use uturn skill now.

Finally, I got the badge without a workout. Yesterday, I tried to get the badge with the workout, but I couldn’t access to volcano. On the other hand, I got the badge today.

1 Like

Hi - I did 69km this morning trying to get the Dust in the Wind badge, can this be fixed pls. ? Lovely ride but could do with the XP rather than doing it again. Windows 10 - I’ve got lots and lots of other route achievement badges, first time this has happened. Many thanks :slight_smile:

Hi @Chris_Diggens, looks like you pulled a u-turn at the beginning of your ride and then just rode around the desert and titans grove doing laps. This isn’t the dust in the wind route, you should have went out to the jungle and back. Also, you can’t get route badges if you use manual turns.

Unfortunately you will need to ride it again since you didn’t do the actual route.

OK - thanks for the pointer and the swift response - never (consciously) pulled a U-turn since I started so that’s all a bit odd so I guess I’ll need to ride it again. Is this no longer relevant - seems to be lots of correspondence & exchanges on this route ?

It has been my experience that 99% of the issues with routes are user errors, usually not including the lead-in distance and people stopping short of actually completing the route. Dust in the Wind should work just fine.


Back on June 20th i was able to complete The Uber Pretzel, however i never got the badge for completing the full route. in my case when i was in the middle of the route i got a message from zwift that my membership expired. after a couple of minutes i was able to complete the route but i did not get the badge and of course the membership was active. even you can check my activity on zwift.

https ://

i would appreciate your help to get the badge as its a pretty big route to do it again.

thanks in advance.

I am sorry for being cynical but Zwift doesn’t care about this. Many people have complained about this and for many months. I also recently completed the Uber Pretzel and did not receive the badge. This is not the only route I did not receive recognition for but it is the most painful one! They try to make you feel good about being screwed out of the badge when you report the problem with a message such as this:

Thank you for your recent contact to Zwift Support about not receiving a badge for your completed route… And, congratulations on that fantastic accomplishment. It’s impressive!

We are working on identifying the root cause so that we can prevent it from happening in the future. At this time, we are not able to grant you the badge for the route completed but we have escalated this internally to ensure it never occurs again. We definitely understand that it is not the answer you’re hoping for, especially after such a hard effort! Rest assured that as soon as we have a fix, we will be proactively reaching out with an appropriate resolution.

The .fit file which should be proof enough that the route was completed.

Come on Zwift. This is not good enough!

in my case when i was in the middle of the route i got a message from zwift that my membership expired. after a couple of minutes i was able to complete the route but i did not get the badge and of course the membership was active.

Exactly the same thing happened to me last week on London - Surrey Hills.

I rode London Pretzel today, got the end of Route completion banner and XP points (rode extra couple of miles after the banner too), also shows on Strava segments as Route complete but no badge awarded on Zwift?

Same for UCI worlds and Cobbled Climbs on Richmond today - none of my badges seem to come up!

Hi @Helen_Clayton, where are they not showing up? In the achievement badge section in the settings menu when riding in game? I looked at your activities on the companion app and it shows you earned the route badge.

1 Like