Route achievement badge missing

Last night I completed 2 courses, Queens Highway and Duchy Estate. The route achievement badges appears at the bottom of the screen on completion and it also shows as complete in the summary on the companion app however it does not show on Zwift as a course completed. Anyone know what’s happened.
Thanks

Same here on Everything Bagel, Dust in the Wind and at least one other. I think the route badges are just not ready for prime time. After early success on a few of these I was motivated to go after them all. Because EB and DitW are significant investments, I won’t be pursuing a new route until the problem is fixed. I did select the routes and verified start and end points against Eric’s (using Strava). No manual turns were taken.

2 Likes

I have missed the everything Bagel achievement yesterday, and the Surrey Hills a few weeks ago. Fix this Zwift :slight_smile:

1 Like

Same here, Dust in the Wind and last night Quatch Quest. I cycled additional miles in the hope it would provide the badge but nothing happenend. I’ve send a separate note to the Zwift team to look in to this issue.

If it’s any consolation, I got the Everything Bagel badge a while ago so it does work.
I gather that there is a definite issue with the Dust in the wind and Quatch Quest badges though.

I Have checked my activity against the Zwiftinsider Strava Segment. My activity starts with small loop before hitting the sky roads. The segment does not. So Zwift made a mistake in routing the Everything Bagel route… Verry strange…

See this post, FYI Dust in the Wind badge

Ok. Thanks. Any idea about the apparent similar issue with Quatch Quest?

I would assume that you can do the same with Quatch Quest, u-turn ride past the banner u-turn again and do the route. I have not done Quatch Quest yet. I may test it this weekend.

Yeah, I guess that is worth a try. It would be nice if they fixed it instead.

I think it’s a big change to make, the maps have default spawn points so they will have to make different spawn points for each route. I think it was a bit of an oversight when they created the badges.

I assume it will be addressed at some point.

Ok. Good information

1 Like

Had the same issue today. I hosted a meet up on the Everything Bagel route, but did not get a badge. I’m not terribly upset, but it is frustrating since the meetup was on the Everything Bagel route.

emphasized text[quote=“Steven_Brennan2358, post:1, topic:191742”]
appears at the bottom of the screen on completion and it also shows as complete in the summary on the companion app however it does not show on Zwift as a course completed. Anyone know what’s happened.
Thanks
[/quote]

1 Like

17 posts were split to a new topic: Badge missing for Lady Liberty meetup